Re: -25590 Error
Posted in 2007
First are you using CSM?
Second try changing the password for a users account to see if it
starts working. Strange as it can be I did see this once and never
solved it.
Make sure permissions and security is on files for Informix per the
release notes if any are set correctly.
Eric B. Rowell
On 4/5/07, Link, David A. (Omaha) <DALink@west.com> wrote:
> We are running AIX 5.3 and Informix 10.00.FC6. We have been having an
> intermittent problem connecting to the database and getting the error
> -25590.
>
>
> -25590 Authentication error.
>
> This error indicates that an invalid user ID or password was used to
> connect to the database server. Provide a valid user ID and password.
>
> This error can also occur if the CSM option is enabled on the database
> server side but disabled on the client application side, or vice versa.
> If you want to use a CSM, make sure that the CSM option is set in the
> sqlhosts file for both the database server and client application.
>
>
>
> Based on this description it sounds like this should be an all or
> nothing error. As you can see below dbschema failed 3 times, and then I
> tried myschema which worked and then I tried dbschema again and it
> worked.
>
> I am thinking that this is either an AIX bug or Informix bug. Anybody
> else run into this issue? We do have a case open with IBM as well and
> they are looking into it.
>
> Thanks for any help....
>
> David
>
> Vvvvvvvvvvvvvvvvvvvvvvvvvvvvvv Example
> vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
>
> informix @ ibm119:/wic/log/infoport/20070330: dbschema -d class -f
> zodiac_dlcc_qry
>
> DBSCHEMA Schema Utility INFORMIX-SQL Version 10.00.FC6
>
> Copyright IBM Corporation 1996, 2006 All rights reserved
>
> Software Serial Number AAA#B000000
>
> -25590 - Authentication error.
>
> informix @ ibm119:/wic/log/infoport/20070330: dbschema -d class -f
> zodiac_dlcc_qry
>
> DBSCHEMA Schema Utility INFORMIX-SQL Version 10.00.FC6
>
> Copyright IBM Corporation 1996, 2006 All rights reserved
>
> Software Serial Number AAA#B000000
>
> -25590 - Authentication error.
>
> informix @ ibm119:/wic/log/infoport/20070330: dbschema -d class -f
> zodiac_dlcc_qry
>
> DBSCHEMA Schema Utility INFORMIX-SQL Version 10.00.FC6
>
> Copyright IBM Corporation 1996, 2006 All rights reserved
>
> Software Serial Number AAA#B000000
>
> -25590 - Authentication error.
>
> informix @ ibm119:/wic/log/infoport/20070330: myschema -d class -f
> zodiac_dlcc_qry
>
> Writing full schema DDL to: stdout
>
> CREATE PROCEDURE zodiac_dlcc_qry( p_dlcc char(20), p_network char(12) )>
> RETURNING char(20),smallint,char(2),char(6),char(10),char(12);
>
> .
> .
> .
>
>
> informix @ ibm119:/wic/log/infoport/20070330: dbschema -d class -f
> zodiac_dlcc_qry
>
> DBSCHEMA Schema Utility INFORMIX-SQL Version 10.00.FC6
> Copyright IBM Corporation 1996, 2006 All rights reserved
> Software Serial Number AAA#B000000
>
> CREATE PROCEDURE "infxoper".zodiac_dlcc_qry( p_dlcc char(20), p_network
> char(12) )
>
> RETURNING char(20),smallint,char(2),char(6),char(10),char(12);
>
> .
> .
> .
>
> informix @ ibm119:/wic/log/infoport/20070330:
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>