APACHE, PHP3 and IDS
Posted in 2000
Topics: Error Codes & Troubleshooting, Platform-Specific Issues, Internationalization & Character Sets, Versions, Editions & End-of-Life
I have a problem with connect from php3 to IDS 7.31 UC2. I have php3 v. 3.0.15, apache v. 1.3.12 on hp-ux 10.20. When I try to connect from php, it returning next message : Warning: ifx_pconnect : E [SQLSTATE=IX 000 SQLCODE=-23101] in /apache/htdocs/informix.php3 on line 16 ifx_connect : E [SQLSTATE=IX 000 SQLCODE=-23101] Unable to load locale categories. can not connect to server Where and how I must set this properties ? Please help. Thanks. Sent via Deja.com http://www.deja.com/ Before you buy.
vor@uvn.cz wrote: > I have a problem with connect from php3 to IDS 7.31 UC2. > I have php3 v. 3.0.15, apache v. 1.3.12 on hp-ux 10.20. > When I try to connect from php, it returning next message : > > Warning: ifx_pconnect : E [SQLSTATE=IX 000 SQLCODE=-23101] > in /apache/htdocs/informix.php3 on line 16 > ifx_connect : E [SQLSTATE=IX 000 SQLCODE=-23101] Unable to load locale > categories. can not connect to server > > Where and how I must set this properties ? Probably SetEnv or PassEnv INFORMIXDIR in httpd.conf. Apache rather stringently resets the environment to almost nothing. -- Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) Guardian of DBD::Informix v1.00.PC1 -- see http://www.perl.com/CPAN #include <disclaimer.h>
>Subject: APACHE, PHP3 and IDS >From: vor@uvn.cz >Date: 30.05.00 23:14 W. Europe Daylight Time >Message-id: <8h1avo$tqp$1@nnrp1.deja.com> > >I have a problem with connect from php3 to IDS 7.31 UC2. >I have php3 v. 3.0.15, apache v. 1.3.12 on hp-ux 10.20. >When I try to connect from php, it returning next message : > >Warning: ifx_pconnect : E [SQLSTATE=IX 000 SQLCODE=-23101] >in /apache/htdocs/informix.php3 on line 16 >ifx_connect : E [SQLSTATE=IX 000 SQLCODE=-23101] Unable to load locale >categories. can not connect to server > >Where and how I must set this properties ? >Please help. > >Thanks. > > > >Sent via Deja.com http://www.deja.com/ >Before you buy. > > > > > > add environment variable to the apache startup that describe as a minimum where the INFORMIXDIR is and also add INFORMIXDIR/bin to PATH. Add, if you have cgi or something doing esql/c you might have to set LD_LIBRARY_PATH too. Nona