Informix,ADO and ASP??????
Posted in 1999
Topics: Installation, Setup & Upgrades, Connectivity: ODBC / JDBC / .NET
First: When I use windowsNT as ASP service and web develop client, I always got the error message like: [Microsoft OLE DB Provider for ODBC Drivers '''~ '80004005' Specified driver could not be loaded due to system error 126 (INTERSOLV 3.10 32-BIT INFORMIX 9)] at the code like: [cnn.Open "DSN=TipTop_NT;UID=informix;PWD=informix"] But I can access the informix database server on windows95 or 98 Personal Web Server used the same code. Why? Please help us, we need it to construct our intranet! I can use Dbping and IConnect to connect my informix database server! My web develop client is NT4.0, NT Option Pack, SP4, Visual InterDev 6.0. Our Intranet server is the same (NT4.0, Option Pack, SP4) and Informix database server is in another server. Second: I really felt upset about informix database server yesterday! When we got the IDS7.30 TC7, we tried it successfully upgrade our informix database server but it didn't work with ASP and ADO. So I asked for a nwe PC (PII-266,64MB RAM,6.4HD) and did the steps: 1.Setup WINT4.0(English Version!) 2.Upgrade it to SP3.(English Version!) 3.Setup Option Pack 4.0(English Version!) 4.Install VID6.0 and VB6.0(English Version!) and Vistual studio Services Pack2.(English Version!) 5.Instll informix_client_sdk_2_20_tc1_2_for_intel_pentium_windows_nt_4_0 6.Use SetNet32 to define HOST and SERVER information. 7.Run regcopy 8.Restart system Then I tried the code you give me to access our database server and got the same error message, why??? After that, I decided to setup I new database server on this new PC and did the steps: 1.Install IDS7.30 TC7.(all componment) 2.create database names "stores7" 3.Use SetNet32 to define the correct information! 4.run regcopy 5.restart system now the web and database server are on the same machine, do you know what happen?! Oh, my god! It still fail again! Why??
You are not alone, I went through the same thing. What I did was log in under the IUSR_HOSTNAME (whatever it is for your NT box) and ran regcopy for that account. Also, log in as an administrator and set the PATH to include your Informix directory. The problem is that the account the web-server is running under is lacking the appropriate environment settings. Make sure to set the CLIENT_LOCALE in setnet so the OLE DB driver can give you the correct error messages. I hope this helps you. paoching wrote in message <7gtfj1$752@netnews.hinet.net>... >First: >When I use windowsNT as ASP service and web develop client, I always got the >error message like: > >[Microsoft OLE DB Provider for ODBC Drivers '''~ '80004005' >Specified driver could not be loaded due to system error 126 (INTERSOLV 3.10 >32-BIT INFORMIX 9)] > >at the code like: > >[cnn.Open "DSN=TipTop_NT;UID=informix;PWD=informix"] > >But I can access the informix database server on windows95 or 98 Personal >Web Server used the same code. >Why? Please help us, we need it to construct our intranet! > >I can use Dbping and IConnect to connect my informix database server! >My web develop client is NT4.0, NT Option Pack, SP4, Visual InterDev 6.0. >Our Intranet server is the same (NT4.0, Option Pack, SP4) >and Informix database server is in another server. > >Second: >I really felt upset about informix database server yesterday! >When we got the IDS7.30 TC7, we tried it successfully upgrade our informix >database server but it didn't work with ASP and ADO. So I asked for a nwe PC >(PII-266,64MB RAM,6.4HD) and did the steps: > >1.Setup WINT4.0(English Version!) >2.Upgrade it to SP3.(English Version!) >3.Setup Option Pack 4.0(English Version!) >4.Install VID6.0 and VB6.0(English Version!) and Vistual studio Services >Pack2.(English Version!) >5.Instll informix_client_sdk_2_20_tc1_2_for_intel_pentium_windows_nt_4_0 >6.Use SetNet32 to define HOST and SERVER information. >7.Run regcopy >8.Restart system > >Then I tried the code you give me to access our database server and got the >same error message, why??? > >After that, I decided to setup I new database server on this new PC and did >the steps: > >1.Install IDS7.30 TC7.(all componment) >2.create database names "stores7" >3.Use SetNet32 to define the correct information! >4.run regcopy >5.restart system > >now the web and database server are on the same machine, do you know what >happen?! >Oh, my god! It still fail again! >Why?? > > > > >
If you continue to have problems with the ODBC layer (Intersolv), you may want to investigate the Openlink data access driver suite (http://www.openlinksw.com). They offer a high-performance drivers that handle ASP/ADO seamlessly in client/server environments. Stephen In article <7gtfj1$752@netnews.hinet.net>, "paoching" <paoching@panpi.com.tw> wrote: > First: > When I use windowsNT as ASP service and web develop client, I always got the > error message like: > > [Microsoft OLE DB Provider for ODBC Drivers '''~ '80004005' > Specified driver could not be loaded due to system error 126 (INTERSOLV 3.10 > 32-BIT INFORMIX 9)] > > at the code like: > > [cnn.Open "DSN=TipTop_NT;UID=informix;PWD=informix"] > > But I can access the informix database server on windows95 or 98 Personal > Web Server used the same code. > Why? Please help us, we need it to construct our intranet! > > I can use Dbping and IConnect to connect my informix database server! > My web develop client is NT4.0, NT Option Pack, SP4, Visual InterDev 6.0. > Our Intranet server is the same (NT4.0, Option Pack, SP4) > and Informix database server is in another server. > > Second: > I really felt upset about informix database server yesterday! > When we got the IDS7.30 TC7, we tried it successfully upgrade our informix > database server but it didn't work with ASP and ADO. So I asked for a nwe PC > (PII-266,64MB RAM,6.4HD) and did the steps: > > 1.Setup WINT4.0(English Version!) > 2.Upgrade it to SP3.(English Version!) > 3.Setup Option Pack 4.0(English Version!) > 4.Install VID6.0 and VB6.0(English Version!) and Vistual studio Services > Pack2.(English Version!) > 5.Instll informix_client_sdk_2_20_tc1_2_for_intel_pentium_windows_nt_4_0 > 6.Use SetNet32 to define HOST and SERVER information. > 7.Run regcopy > 8.Restart system > > Then I tried the code you give me to access our database server and got the > same error message, why??? > > After that, I decided to setup I new database server on this new PC and did > the steps: > > 1.Install IDS7.30 TC7.(all componment) > 2.create database names "stores7" > 3.Use SetNet32 to define the correct information! > 4.run regcopy > 5.restart system > > now the web and database server are on the same machine, do you know what > happen?! > Oh, my god! It still fail again! > Why?? > > -----------== Posted via Deja News, The Discussion Network ==---------- http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own