Re: "load from" and stored procedures
Posted in 2000
Yes, I've tried with the system call directly to the program I wish to run, the system call to a shell script that runs the program etc.. I do not get ant error at all from the SP. I am using Cold Fusion and hacve set up the datsource with SDK. I call the procedure from Cold Fusion and it never returns. There's just no error. To give detail If the SP just has a system call to the program e.g. let tmp = "/home/kcj/database/progname"; system tmp; Then any call to the SP from Cold Fusion results in it hanging. If I have a shell script that contains only the program name with redirected output e.g. /home/kcj/database/progname > /home/kcj/tmp/blah Then I get an error message written to blah that says INFORMIXSERVER must be set If I set INFORMIXSERVER in the shell script before I call the prgram, it hangs. If I redirect the output in the string in the SP, it shows nothing (it has hung). All the SPs work if called from within SE. All the scripts work if called from UNIX Kate In article <38F3BB1C.89FC351D@informix.com>, Heiko Giesselmann <heiko.giesselmann@informix.com> wrote: > Kate, > > my understanding is that you have the stored procedure that issues the system > call complete (at least you tried that route in some point in time). This is the > way to go. What error code did you get when you tried this? Most of the time, > problems are caused by incomplete path variables or insufficient permissions. > The error code returned by the stored procedure would definitely help. > > Heiko > > > > > > > > ______________________________________________________ > > > Get Your Private, Free Email at http://www.hotmail.com > > > > > > > > > > Sent via Deja.com http://www.deja.com/ > > Before you buy. > > Sent via Deja.com http://www.deja.com/ Before you buy.