IDS 11.7 : message in online.log :asfcode = -25582
Posted in 2012
Topics: High Availability & Replication, Connectivity: ESQL/C, 4GL & Embedded SQL, Networking & sqlhosts Configuration
Greeting !! I have an IDS 11.70.UC4 running in RHEL 5.5 , I've observed a message like the following in online.log : 11:51:21 ASF Echo-Thread Server: asfcode = -25582: oserr = 0: errstr = : Network connection is broken. Refering to google , I have no idea what is going on , I don't have CDR , neither HDR ... a very pure stand alone engine , with several esql/c running only , and a client select some data through C# application ... Engine goes fine , still I wonder why this message showes , and what can I do to let it disappear ? Any suggestion is welcome , and thanks !!
original post: Greeting !! I have an IDS 11.70.UC4 running in RHEL 5.5 , I've observed a message like the following in online.log : 11:51:21 ASF Echo-Thread Server: asfcode = -25582: oserr = 0: errstr = : Network connection is broken. Refering to google , I have no idea what is going on , I don't have CDR , neither HDR ... a very pure stand alone engine , with several esql/c running only , and a client select some data through C# application ... Engine goes fine , still I wonder why this message showes , and what can I do to let it disappear ? Any suggestion is welcome , and thanks !! Response: I believe I recently saw a defect that said the above error message is reported every time you exit onmonitor on the version you are running. Perhaps you can see if going forward you can confirm you are seeing this message after somebody exits onmonitor. If it is that defect, then until it's fixed, there isn't anything you can do to not see it, other then not use onmonitor. Jacques Renaut IBM Informix Advanced Support APD Team
Hi Jacques! I suggest you to look at Network configuration (such as DNS) and OS kernel configuration. I had similar problem couple years ago, and the problem was DNS infrastructure/configuration + tcp_idle_timeout/ keepalive kernel parameter at OS side, but sometimes oserr = 0, sometimes oserr = 6 (If I'm not wrong regarding oserr error code)... Regards, Alberto Pessonio. -----Mensagem original----- De: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] Em nome de JACQUES RENAUT Enviada em: quarta-feira, 11 de abril de 2012 10:24 Para: ids@iiug.org Assunto: Re: IDS 11.7 : message in online.log :asfcode .... [26690] original post: Greeting !! I have an IDS 11.70.UC4 running in RHEL 5.5 , I've observed a message like the following in online.log : 11:51:21 ASF Echo-Thread Server: asfcode = -25582: oserr = 0: errstr = : Network connection is broken. Refering to google , I have no idea what is going on , I don't have CDR , neither HDR ... a very pure stand alone engine , with several esql/c running only , and a client select some data through C# application ... Engine goes fine , still I wonder why this message showes , and what can I do to let it disappear ? Any suggestion is welcome , and thanks !! Response: I believe I recently saw a defect that said the above error message is reported every time you exit onmonitor on the version you are running. Perhaps you can see if going forward you can confirm you are seeing this message after somebody exits onmonitor. If it is that defect, then until it's fixed, there isn't anything you can do to not see it, other then not use onmonitor. Jacques Renaut IBM Informix Advanced Support APD Team ************************************************************************ ******* Forum Note: Use "Reply" to post a response in the discussion forum.
Yes , thanks .... When I leave onmonitor , it does have a message in online.log ,exactly the description you mentined , thanks !!
Related threads
- System Or Internal Error InterruptedIOException
- 25582 error on high volume of short live trans
- ASF Echo-Thread Server: asfcode = -25582 oserr = 4