Hi IIUG,
Trying to find why my DB blows up to high CPU. it has 62 physical cores (x4
smt) on AIX machine P8 running 11.70 IDS.
We are getting -25582 error after putting significant load of transactions.
The volume of transactions is big but short live.
Here's the config below:
NETTYPE ipcshm,1,100,CPU
NETTYPE soctcp,35,500,NET
LISTEN_TIMEOUT 10
MAX_INCOMPLETE_CONNECTIONS 1024
FASTPOLL 1
NUMFDSERVERS 23
NS_CACHE host=900,service=900,user=60,group=900ASF_SOCTCP_BACKLOG 1024
BUFFERPOOL
default,buffers=23068672,lrus=511,lru_min_dirty=0.28,lru_max_dirty=1.12
BUFFERPOOL
size=4K,buffers=69206016,lrus=511,lru_min_dirty=0.28,lru_max_dirty=1.12
We've tried NUMFDSERVERS=1 as well, but we are still seeing nsf locks. Any
thoughts?
Thank you in advance,
↪ replying to RONALD OLAVIDEZ
Hi Ronald,
I'm looking at this old post and probably the problem has already been solved.
I assume that when the 25582 error occurred there were also several nsf locks
records in the onstat -g lmx output.
I would say you should increase the NUMFDSERVERS parameter to 35 and try.
It would be interesting to know what the definitive solution was.
Best regards.
Roger