Help! Assert failed. Database instance can't startup
Posted in 2000
Topics: Stored Procedures & SPL, Error Codes & Troubleshooting, Logging & Checkpoints, Platform-Specific Issues
Dear all,
Our database instance (7.31UC6 in Solaris 7) can't startup after Online
aborted. The following messages displayed in the message log file:
23:43:18 Physical Recovery Started.
23:43:18 Physical Recovery Complete: 688 Pages Restored.
23:43:18 Logical Recovery Started.
23:43:22 Assert Failed: Rollback error 126
23:43:22 Informix Dynamic Server Version 7.31.UC6
23:43:22 Who: Session(21, informix@hkgs01, 0, 302971816)
Thread(42, fast_rec, 120ca9ec, 4)
File: rstrans.c Line: 2197
23:43:22 Results: Log record (OLDRSAM:HINSERT) in log 3364, offset0x12b21ec w
as not rolled back
23:43:22 Action: Use 'onlog' to view the transaction and repair manually.
23:43:28 See Also: /jdownload/dump/p4/af.4125c9a, shmem.4125c9a.0
23:43:28 Error writing '/jdownload/dump/p4/shmem.4125c9a.0' errno = 28
23:43:28 Assert Failed: Rollback error 126
23:43:28 Informix Dynamic Server Version 7.31.UC6
23:43:28 Who: Session(21, informix@hkgs01, 0, 302971816)
Thread(42, fast_rec, 120ca9ec, 4)
File: rsextlog.c Line: 1450
23:43:28 Results: Log record (OLDRSAM:HINSERT) in log 3364, offset0x12b21ec w
as not rolled back
23:43:28 Action: Use 'onlog' to view the transaction and repair manually.
We have called Informix expert to bring the instance to online mode. Does
any body know what they do? (I think he has dropped some of the transaction
from the current logical log but I don't know how he do this)
Thanks!
They have a special program tbzero to zero the last logical log
This is only for use by qualified Informix personel and last time I
heard giving it to a customer was a sackable offence!
Samuel Chan wrote in message <39f657ae@newsgate.imsbiz.com>...
>Dear all,
>
>Our database instance (7.31UC6 in Solaris 7) can't startup after Online
>aborted. The following messages displayed in the message log file:
>
>23:43:18 Physical Recovery Started.
>23:43:18 Physical Recovery Complete: 688 Pages Restored.
>23:43:18 Logical Recovery Started.
>23:43:22 Assert Failed: Rollback error 126
>23:43:22 Informix Dynamic Server Version 7.31.UC6
>23:43:22 Who: Session(21, informix@hkgs01, 0, 302971816)
> Thread(42, fast_rec, 120ca9ec, 4)
> File: rstrans.c Line: 2197
>23:43:22 Results: Log record (OLDRSAM:HINSERT) in log 3364, offset>0x12b21ec w
>as not rolled back
>23:43:22 Action: Use 'onlog' to view the transaction and repair manually.
>23:43:28 See Also: /jdownload/dump/p4/af.4125c9a, shmem.4125c9a.0
>23:43:28 Error writing '/jdownload/dump/p4/shmem.4125c9a.0' errno = 28
>23:43:28 Assert Failed: Rollback error 126
>23:43:28 Informix Dynamic Server Version 7.31.UC6
>23:43:28 Who: Session(21, informix@hkgs01, 0, 302971816)
> Thread(42, fast_rec, 120ca9ec, 4)
> File: rsextlog.c Line: 1450
>23:43:28 Results: Log record (OLDRSAM:HINSERT) in log 3364, offset>0x12b21ec w
>as not rolled back
>23:43:28 Action: Use 'onlog' to view the transaction and repair manually.>
>We have called Informix expert to bring the instance to online mode. Does
>any body know what they do? (I think he has dropped some of the transaction
>from the current logical log but I don't know how he do this)
>
>Thanks!
>
>
-Sorry for bad english -
PLEASE PLEASE.
After the same action of "qualified ...bla bla bla" in my servers (I have 10
servers)
I must thank Informix qualified bla bla bla . BECAUSE they do not say what
they do.
The result was 3 consecutives CRASH on 3 different servers during the month
following
the bla bla bla.
Here is the explanation (But I have no hair on the head since this period)
Verify if the number of logs is allways the same !!! (onconfig AND
onstat -l )The tool that "qualified Informix personel" could use could be also 'tbone'
that
ADD one log instead of "zero" the last log.
(Note : YOU MUST preserve you last log in onconfig please)
IF YOU HAVE ONE LOG MORE than before , THIS NEW LOG WILL OVERLAP
some data pages of the rootdbs, causing Informix CRASH or inconsistency
datas,
or datapages WILL OVERLAP this LOG, with the SAME RESULT.
RESTAURING will NOT save you, because this log will be here AGAIN.
(For me, to restaure = 18 hours - 3servers*3 crashes, can you imagine ?)
The only thing to do IN THIS CASE is to save (unload) your datas AND REBUILD
you instance (initialize , oninit -i ...), create your database and tables,
and reload all your DATAS
WITHOUT USING ARCHIVES. (use unload , dbload or something like that)
At this point, you will be quiet, hair preserved.
A REAL QUALIFIED (and honest) INFORMIX PERSONEL MUST CONFIRM THIS.
(-> informix, just try to say it is not right and I go to Oracle :) -
Note : to detect a faulty transaction, you can use onstat -g ses to retreive
the session number
that you can terminate with onmode -z <no of session> BEFORE
killing the PID (online mode of course)
Using stats on locks can also help you to identify this
transaction.
Rememember - To terminate a tx, Informix needs logs to record
what it does (Rolback)
(See HighWaterMarks params also in your onconfig) !
Regards - Philippe
"smooth1" <smooth1@iclway.co.uk> a 'crit dans le message news:
3a06e19b_1@news2.vip.uk.com...
> They have a special program tbzero to zero the last logical log
> This is only for use by qualified Informix personel and last time I
> heard giving it to a customer was a sackable offence!
>
>
> Samuel Chan wrote in message <39f657ae@newsgate.imsbiz.com>...
> >Dear all,
> >
> >Our database instance (7.31UC6 in Solaris 7) can't startup after Online
> >aborted. The following messages displayed in the message log file:
> >
> >23:43:18 Physical Recovery Started.
> >23:43:18 Physical Recovery Complete: 688 Pages Restored.
> >23:43:18 Logical Recovery Started.
> >23:43:22 Assert Failed: Rollback error 126
> >23:43:22 Informix Dynamic Server Version 7.31.UC6
> >23:43:22 Who: Session(21, informix@hkgs01, 0, 302971816)
> > Thread(42, fast_rec, 120ca9ec, 4)
> > File: rstrans.c Line: 2197
> >23:43:22 Results: Log record (OLDRSAM:HINSERT) in log 3364, offset> >0x12b21ec w
> >as not rolled back
> >23:43:22 Action: Use 'onlog' to view the transaction and repair
manually.
> >23:43:28 See Also: /jdownload/dump/p4/af.4125c9a, shmem.4125c9a.0
> >23:43:28 Error writing '/jdownload/dump/p4/shmem.4125c9a.0' errno = 28
> >23:43:28 Assert Failed: Rollback error 126
> >23:43:28 Informix Dynamic Server Version 7.31.UC6
> >23:43:28 Who: Session(21, informix@hkgs01, 0, 302971816)
> > Thread(42, fast_rec, 120ca9ec, 4)
> > File: rsextlog.c Line: 1450
> >23:43:28 Results: Log record (OLDRSAM:HINSERT) in log 3364, offset> >0x12b21ec w
> >as not rolled back
> >23:43:28 Action: Use 'onlog' to view the transaction and repair
manually.> >
> >We have called Informix expert to bring the instance to online mode. Does
> >any body know what they do? (I think he has dropped some of the
transaction
> >from the current logical log but I don't know how he do this)
> >
> >Thanks!
> >
> >
>
>