Can't start IDS 7.3 for Linux
Posted in 2000
Topics: Server Administration, Platform-Specific Issues, Versions, Editions & End-of-Life
Dear Friends :
I am trying hard to start Informix IDS 7.3 for Linux.
My OS platform is CorelLinux 1.0.
After executing "oninit -ivy" command , I got the following
messages :
========================================================
Checking group membership to determine server run modesucceeded
Reading configuration file '/opt/informix/etc/onconfig'...succeeded
Creating /INFORMIXTMP/.infxdirs ... FAILED
Creating infos file "/opt/informix/etc/.infos.realguide" ...
"/opt/informix/etc/.conf.realguide" ... succeeded
Writing to infos file ... succeeded
Checking config parameters...succeeded
Allocating and attaching to shared memory...succeeded
Creating resident pool 394 kbytes...succeeded
Creating buffer pool 402 kbytes...succeeded
Initializing rhead structure...succeeded
Initializing ASF ...
========================================================
" Creating /INFORMIXTMP/.infxdirs ... FAILED " ----- What does it
means ?
And then I use "onstat" to check the state , I got :
========================================================
shared memory not initialized for INFORMIXSERVER 'realguide'
========================================================
Could anyone please help me to resolve this problem ? Really thanks
!!
P.S. Should I show my setting files and environment variables ??
Ken @ Taiwan
Hi! I found one bug in installation guide. Step with "create INFORMIXTMP directory" is missing. You probably didn't create INFORMIXTMP directory. Damijan Ken Hu wrote: > > Dear Friends : > < snip > > Ken @ Taiwan
Damijan Sencar wrote: > > Hi! > > I found one bug in installation guide. Step with "create INFORMIXTMP > directory" is missing. You probably didn't create INFORMIXTMP directory. > > Damijan > > Ken Hu wrote: > > > > Dear Friends : > > > < snip > > > > Ken @ Taiwan What are your permissions on the root directory? I don't remember being required to explicitly create that directory. -- John Carlson Informix DBA WHSmith USA #include std_disclaimer.h /* These are my opinions, not my company's opinion */
Ken Hu wrote:
>
> Dear Friends :
>
> I am trying hard to start Informix IDS 7.3 for Linux.
> My OS platform is CorelLinux 1.0.
>
> After executing "oninit -ivy" command , I got the following
> messages :
>
> ========================================================
> Checking group membership to determine server run modesucceeded
> Reading configuration file '/opt/informix/etc/onconfig'...succeeded
> Creating /INFORMIXTMP/.infxdirs ... FAILED
> Creating infos file "/opt/informix/etc/.infos.realguide" ...
> "/opt/informix/etc/.conf.realguide" ... succeeded
> Writing to infos file ... succeeded
> Checking config parameters...succeeded
> Allocating and attaching to shared memory...succeeded
> Creating resident pool 394 kbytes...succeeded
> Creating buffer pool 402 kbytes...succeeded
> Initializing rhead structure...succeeded
> Initializing ASF ...
> ========================================================
> " Creating /INFORMIXTMP/.infxdirs ... FAILED " ----- What does it
> means ?
>
> And then I use "onstat" to check the state , I got :
>
> ========================================================
> shared memory not initialized for INFORMIXSERVER 'realguide'
> ========================================================
>
> Could anyone please help me to resolve this problem ? Really thanks
> !!
>
> P.S. Should I show my setting files and environment variables ??
If you ran the oninit -ivy as user informix you probably did not
have permissions to create the /INFORMIXTMP directory. You can
either run the first oninit -ivy as root or create the directory
manually as root first. The directory should be owned by root and
group informix with permissions: 'chmod 1777 /INFORMIXTMP'.
--
Art S. Kagel & Family
kagel@erols.com