Drop bad chunk, dbspace
Posted in 2015
Topics: Backup & Restore, Storage & Space Management, Error Codes & Troubleshooting, Server Administration, Versions, Editions & End-of-Life
Folks,
Got one dbspaces ( see below) BAD,
Can not drop it. tried all possible commands, not worked,
[informix@stephanie ontape]$ onspaces -d dbdata22
WARNING: Dropping a DBspace.
Do you really want to continue? (y/n)y
WARNING! The dbspace you wish to drop has been disabled. There
may be database catalog entries for tables or indices which contain
data in this dbspace. If you complete the drop they will be unusable.
Do you really want to continue? (y/n)y
Cannot drop the Space.
ISAM error: DBspace is not empty
[informix@stephanie ontape]$ onspaces -d dbdata22 -p
/usr/informix/dev-links/nsofops/dbdata22a1_ops -o 0 -y
Chunk not dropped.
ISAM error: Cannot drop first chunk
[informix@stephanie ontape]$ onspaces -d dbdata22 -p
/usr/informix/dev-links/nsofops/dbdata22a3_ops -o 0 -y
Chunk not dropped.
ISAM error: Primary and Mirror chunks are bad
Any tips?
Thanks
Frank
[informix@stephanie dev]$ onstat -d
IBM Informix Dynamic Server Version 12.10.FC4W1XU -- On-Line -- Up 16:52:21
-- 8615852 KbytesDbspaces
address number flags fchunk nchunks pgsize flags
owner name
..................................
4e1f86b8 37 0x40001 93 4 8192 N BA
informix dbdata21
4e1f88e8 38 0x48001 97 2 2048 N SBA
informix dbsbdata00
4e1f8b18 39 0x60005 105 3 8192 ND BA
informix dbdata22
Chunks
address chunk/dbs offset size free bpages
flags pathname
............................................
4e266028 103 20 0 5000000 4999997
PO-B-- /usr/informix/dev-links/nsofops/dbdata08c_ops
4e267028 104 20 0 5000000 4999997
PO-B-- /usr/informix/dev-links/nsofops/dbdata08d_ops
4e268028 105 39 0 1250000 0
PD-B-- /usr/informix/dev-links/nsofops/dbdata22a1_ops
4e269028 106 39 0 1250000 0
PD-B-- /usr/informix/dev-links/nsofops/dbdata22a2_ops
4e26a028 107 39 0 1250000 0
PD-B-- /usr/informix/dev-links/nsofops/dbdata22a3_ops
107 active, 32766 maximum
--001a1149013e124c60051670c681
Hi Frank,
There isnt a straight way to bring a bad dbspace/chunk down.
If you really dont want the data in it and are 100% sure it is to drop,
then you have to call IBM support so they mark it as online and drop it, if
you can give them access to your system.
Keen regards.
On Tue, 19 May 2015 at 16:15 FRANK <yunyaoqu@gmail.com> wrote:
> Folks,
>
> Got one dbspaces ( see below) BAD,
>
> Can not drop it. tried all possible commands, not worked,
>
> [informix@stephanie ontape]$ onspaces -d dbdata22
> WARNING: Dropping a DBspace.
> Do you really want to continue? (y/n)y
> WARNING! The dbspace you wish to drop has been disabled. There
> may be database catalog entries for tables or indices which contain
> data in this dbspace. If you complete the drop they will be unusable.
> Do you really want to continue? (y/n)y
> Cannot drop the Space.
> ISAM error: DBspace is not empty>
> [informix@stephanie ontape]$ onspaces -d dbdata22 -p
> /usr/informix/dev-links/nsofops/dbdata22a1_ops -o 0 -y
> Chunk not dropped.
> ISAM error: Cannot drop first chunk>
> [informix@stephanie ontape]$ onspaces -d dbdata22 -p
> /usr/informix/dev-links/nsofops/dbdata22a3_ops -o 0 -y
> Chunk not dropped.
> ISAM error: Primary and Mirror chunks are bad>
> Any tips?
>
> Thanks
> Frank
>
> [informix@stephanie dev]$ onstat -d
>
> IBM Informix Dynamic Server Version 12.10.FC4W1XU -- On-Line -- Up 16:52:21
> -- 8615852 Kbytes> Dbspaces
> address number flags fchunk nchunks pgsize flags
> owner name
> ...................................
> 4e1f86b8 37 0x40001 93 4 8192 N BA
> informix dbdata21
> 4e1f88e8 38 0x48001 97 2 2048 N SBA
> informix dbsbdata00
> 4e1f8b18 39 0x60005 105 3 8192 ND BA
> informix dbdata22
>
> Chunks
> address chunk/dbs offset size free bpages
> flags pathname
> .............................................
> 4e266028 103 20 0 5000000 4999997
> PO-B-- /usr/informix/dev-links/nsofops/dbdata08c_ops
> 4e267028 104 20 0 5000000 4999997
> PO-B-- /usr/informix/dev-links/nsofops/dbdata08d_ops
> 4e268028 105 39 0 1250000 0
> PD-B-- /usr/informix/dev-links/nsofops/dbdata22a1_ops
> 4e269028 106 39 0 1250000 0
> PD-B-- /usr/informix/dev-links/nsofops/dbdata22a2_ops
> 4e26a028 107 39 0 1250000 0
> PD-B-- /usr/informix/dev-links/nsofops/dbdata22a3_ops
> 107 active, 32766 maximum
>
> --001a1149013e124c60051670c681
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--f46d043c7dd4e91c98051671faa4
Thanks Ricardo! called IBM, resolved :-) Frank
On Tue, May 19, 2015 at 12:41 PM, Ricardo Henriques <
ricardoaireshenriques@gmail.com> wrote:
> Hi Frank,
>
> There isnt a straight way to bring a bad dbspace/chunk down.
>
> If you really dont want the data in it and are 100% sure it is to drop,
> then you have to call IBM support so they mark it as online and drop it, if
> you can give them access to your system.
>
> Keen regards.
>
> On Tue, 19 May 2015 at 16:15 FRANK <yunyaoqu@gmail.com> wrote:
>
> > Folks,
> >
> > Got one dbspaces ( see below) BAD,
> >
> > Can not drop it. tried all possible commands, not worked,
> >
> > [informix@stephanie ontape]$ onspaces -d dbdata22
> > WARNING: Dropping a DBspace.
> > Do you really want to continue? (y/n)y
> > WARNING! The dbspace you wish to drop has been disabled. There
> > may be database catalog entries for tables or indices which contain
> > data in this dbspace. If you complete the drop they will be unusable.
> > Do you really want to continue? (y/n)y
> > Cannot drop the Space.
> > ISAM error: DBspace is not empty> >
> > [informix@stephanie ontape]$ onspaces -d dbdata22 -p
> > /usr/informix/dev-links/nsofops/dbdata22a1_ops -o 0 -y
> > Chunk not dropped.
> > ISAM error: Cannot drop first chunk> >
> > [informix@stephanie ontape]$ onspaces -d dbdata22 -p
> > /usr/informix/dev-links/nsofops/dbdata22a3_ops -o 0 -y
> > Chunk not dropped.
> > ISAM error: Primary and Mirror chunks are bad> >
> > Any tips?
> >
> > Thanks
> > Frank
> >
> > [informix@stephanie dev]$ onstat -d
> >
> > IBM Informix Dynamic Server Version 12.10.FC4W1XU -- On-Line -- Up
> 16:52:21
> > -- 8615852 Kbytes> > Dbspaces
> > address number flags fchunk nchunks pgsize flags
> > owner name
> > ...................................
> > 4e1f86b8 37 0x40001 93 4 8192 N BA
> > informix dbdata21
> > 4e1f88e8 38 0x48001 97 2 2048 N SBA
> > informix dbsbdata00
> > 4e1f8b18 39 0x60005 105 3 8192 ND BA
> > informix dbdata22
> >
> > Chunks
> > address chunk/dbs offset size free bpages
> > flags pathname
> > .............................................
> > 4e266028 103 20 0 5000000 4999997
> > PO-B-- /usr/informix/dev-links/nsofops/dbdata08c_ops
> > 4e267028 104 20 0 5000000 4999997
> > PO-B-- /usr/informix/dev-links/nsofops/dbdata08d_ops
> > 4e268028 105 39 0 1250000 0
> > PD-B-- /usr/informix/dev-links/nsofops/dbdata22a1_ops
> > 4e269028 106 39 0 1250000 0
> > PD-B-- /usr/informix/dev-links/nsofops/dbdata22a2_ops
> > 4e26a028 107 39 0 1250000 0
> > PD-B-- /usr/informix/dev-links/nsofops/dbdata22a3_ops
> > 107 active, 32766 maximum
> >
> > --001a1149013e124c60051670c681
> >
> >
> >
> >
>
>
*******************************************************************************
> > Forum Note: Use "Reply" to post a response in the discussion forum.
> >
> >
>
> --f46d043c7dd4e91c98051671faa4
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001a1140fc0e27dafe051684a0df
Related threads
- IDS 10 table-level restore
- Informix Development Webinar December 11, 2007
- ontape -p/r with changed ROOTPATH
- Migrate from HP PA-RISC to HP ITANIUM by ontape