Translating with DrWatson… this can take a few seconds the first time.
This is a genuine, complex translation. DrWatson protects commands, error codes, and log output while naturally translating the surrounding text. It’s translated once and saved.
What happens when you reach this limit ?
maximum of 16,777,215 pages per table
Does that table stop working (no more inserts allowed) .... so basically your
DB "goes down" ?
IDS 12
AIX 7
Dirk
-271 Could not insert new row into the table.
is what the client(s) trying to insert new rows into the table will receive.
The database will remain online and you will be able to query the table.
I believe the accompanying ISAM error will be -131, no free disk space.
You have several options at this point:
1- delete some data to free up slots on some pages to allow for new rows,
2- move the table to a dbspace with wider pages so the data fits on fewer
pages,
3- partition the table across two or more fragments each of which can hold
2^24 pages of data.
If you choose #1 I would also REPACK the table to move all of the recovered
row space to the end of the table. Otherwise inserts will tend to be slow
while the server searches for a free slot onto which to place the row.
Especially if the deletes did not empty whole pages but only freed up a slot
or two on each page.
↪ replying to ART KAGEL
MARK SCRANTON — — source: IIUG Forums & Mailing Lists
If you chose REPACK, you'll most likely need to add disk to that dbspace
otherwise the repack will fail since it has no "working storage" (for us COBOL
folks) to work in.
Thanks -
Mark Scranton
The Mark Scranton Group
We use strictly necessary cookies to make this site work. With your
consent we’d also use optional cookies for analytics and marketing. You can accept all,
reject all, or choose. Read our Cookie Policy.