Re: Graphical GUI tool FREE!
Posted in 1997
Joe Lumbley wrote: > > There, I thought that would get your attention. Informix has just > released their graphical database management tool ROM 2.1 into free > distrubiton from their website. http://www.informix.com/trybuy. --- SNIP --- Of course, I could not resist. However, I seem to have a problem configuring it in SetNet-32. When I try to open the one server I have defined, I get the following error message: [informix][sqlinfmx.dll] SQL Error (-931): Cannot locate hpgarsoc service/tcp service in /etc/services Now hpgarsoc is the name of the service in /etc/services on the Unix host system holding my database server. It really is there! What have I done in setnet-32 so far? 1. I have defined a host machine, using the IP address of my host. After the first few failed attempts, I decided to let it prompt me for password at run time. Same error. 2. In the "server" box, I have the name hpgar - the same value as my $INFORMIXSERVER when I log into the host machine for shell access. 3. In desperation, I created the SQLHOSTS.TXT file in c:\\informix\\etc and placed that full path name in the SQLHOSTS "environment variable" in setnet-32. Nothing works. (I recall the 931 problem from early versions of NewEra on Windows-3.1; the solution then was to delete (or rename) the winsock.dll that came with the product so that it would be forced to use another winsoc.dll that happened to be on the system. This is clearly not the problem here - all the winsoc.dll files are under c:\\windows.) I did just notice, however, that on my unix host, the sqlhosts entry for the server has a protocol of onsoctcp 0 - "on" for online; this is what I put in my copy of sqlhosts on the PC. By contrast, in the setnet dialog box, the drop-down box for protocol specifies olsoctcp - "ol" for online. Could this little discrepency be the cause of my grief? Nobody else seems to be complaining about it. And it is not consistent with the error message, which complains about not finding s service I see *is* there in /etc/hosts. Any ideas out there? Thanks. -- -- Jake (In pursuit of undomesticated aquatic avians) +----------------------------------------------------------+ |Aside from that, how did you enjoy the play, Mrs. Lincoln?| +----------------------------------------------------------+