ontape -l with 2 different Tape-Types ?
Posted in 2000
Topics: Backup & Restore, Server Administration
I did a DB-Restore via ontape -r. This was OK.
But now have several LOG-Tapes (ontape -a) with different Sizes (DLT,
DDS).
I restored the first LOG-Tape via ontape -l (DDS 4mm).
Then i switched the TAPE-Device in the Onconfig-File.
Now i want to restore the next LOG-Tape (different Device DLT 7000) via
ontape -l.
This aborts with failures:
1) Informix is online: "Logcal restore failed - There are no DBsapces or
BLOBsapces to revocer.
check the Status by using onstat -d"
2) Informix is offline: "Server is incompatible State"
What can i do to restore the LOG-Tapes ?
Gernot Eder
EWE K'chen/Austria
In article <390a1704$0$81878@SSP1NO17.highway.telekom.at>, Eva Eder
<aon.912194136@aon.at> writes
>I did a DB-Restore via ontape -r. This was OK.
>
>But now have several LOG-Tapes (ontape -a) with different Sizes (DLT,
>DDS).
>I restored the first LOG-Tape via ontape -l (DDS 4mm).
>
>
>Then i switched the TAPE-Device in the Onconfig-File.
>Now i want to restore the next LOG-Tape (different Device DLT 7000) via
>ontape -l.>
>This aborts with failures:
>1) Informix is online: "Logcal restore failed - There are no DBsapces or
>BLOBsapces to revocer.
> check the Status by using onstat -d"
>2) Informix is offline: "Server is incompatible State"
>
>
>What can i do to restore the LOG-Tapes ?
>
Talk to Informix Techincal Support but I don't think you can. They all
need to be the same tape size.
>Gernot Eder
>EWE Küchen/Austria
>
>
--
David Williams
Eva Eder wrote:
>
> I did a DB-Restore via ontape -r. This was OK.
>
> But now have several LOG-Tapes (ontape -a) with different Sizes (DLT,
> DDS).
> I restored the first LOG-Tape via ontape -l (DDS 4mm).
>
> Then i switched the TAPE-Device in the Onconfig-File.
> Now i want to restore the next LOG-Tape (different Device DLT 7000) via
> ontape -l.>
> This aborts with failures:
> 1) Informix is online: "Logcal restore failed - There are no DBsapces or
> BLOBsapces to revocer.
> check the Status by using onstat -d"
> 2) Informix is offline: "Server is incompatible State"
>
> What can i do to restore the LOG-Tapes ?
You have several problems, first all of the logical log tapes must be on
the same device/media/size whatever. So you will have to us dd or some
other utility to copy the logfiles from the DDS to DLT and set the LTAPEDEV
to that (remember that you can only change LTAPEDEV while the engine is
running using onmonitor, modifying ONCONFIG does not take effect until the
engine is bounced). Second ontape -l is NOT for restoring logical logs
after an ontape -r restore, it is for rolling forward a replicant server
after having restored it using ontape -p! What you want to do is:
1) Copy all the logical logs to one type of tape, make sure that the block
size on the output is the same for all tapes also. (If for example you had
LTAPEBLK 16 for DDS and now use LTAPEBLK 256 for DLT use DD ib=16k ob=256k...
when copying).
2) Re-run the ontape -r and when it prompts for logical logs hang those log
tapes in order. Yes you have to run the entire restore over again!
Art S. Kagel
Related threads
- IDS 10 table-level restore
- Informix Development Webinar December 11, 2007
- ontape -p/r with changed ROOTPATH
- Migrate from HP PA-RISC to HP ITANIUM by ontape