Informix problems afters Y2K Solaris 2.5 patch
Posted in 1999
Topics: Error Codes & Troubleshooting, Platform-Specific Issues
Since I did the Y2K patch for Solaris 2.5 on a Ultra Sparc 1 system,
Informix 7.22 refuses to startup properly.
Anyone experienced a simular problem? Any suggestions?
Attached some system information and the relevant part of the online.log
Has van der Krieken.
# uname -a
SunOS sungemms 5.5 Generic_103093-25 sun4u sparc SUNW,Ultra-1
# su - informixSun Microsystems Inc. SunOS 5.5 Generic November 1995
$ onstat -VINFORMIX-OnLine Version 7.22.UC2 Software Serial Number AAA#J917741
$ cat online.log
Mon Dec 27 16:09:48 1999
16:09:48 Event alarms enabled. ALARMPROG = '/informix/etc/no_log.sh'
16:09:48 DR: DRAUTO is 0 (Off)
16:09:49 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
16:09:49 Physical Recovery Started.
16:09:49 Physical Recovery Complete: 0 Pages Restored.
16:09:49 Logical Recovery Started.
16:09:49 shmget: [ENOMEM][12]: key 52574804: out of shared memory, checksystem
SHMALL
16:09:49 out of virtual shared memory
16:09:49 Assert Failed: Internal Error - Segmentation Violation
16:09:49 Who: Session(6, informix@sungemms, 0, 218473640)
Thread(13, bld_logrecs, d039530, 1)
16:09:49 Results: OnLine must abort
16:09:49 Action: Reinitialize shared memory
16:09:49 See Also: /var/tmp/af.d813d
16:09:49 rsinit.c, line 9932, thread 13, proc id 20737, Segmentation
Violation.
16:09:49 PANIC: Attempting to bring system down
Check kernel parameter.
There are some recommended kernel parameters in
$INFORMIXDIR/release/en_us/0333/ONLINE_7.2
Has van der Krieken wrote:
> Since I did the Y2K patch for Solaris 2.5 on a Ultra Sparc 1 system,
> Informix 7.22 refuses to startup properly.
> Anyone experienced a simular problem? Any suggestions?
> Attached some system information and the relevant part of the online.log
>
> Has van der Krieken.
>
> # uname -a
> SunOS sungemms 5.5 Generic_103093-25 sun4u sparc SUNW,Ultra-1
> # su - informix> Sun Microsystems Inc. SunOS 5.5 Generic November 1995
> $ onstat -V> INFORMIX-OnLine Version 7.22.UC2 Software Serial Number AAA#J917741
> $ cat online.log>
> Mon Dec 27 16:09:48 1999
>
> 16:09:48 Event alarms enabled. ALARMPROG = '/informix/etc/no_log.sh'
> 16:09:48 DR: DRAUTO is 0 (Off)
> 16:09:49 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 16:09:49 Physical Recovery Started.
> 16:09:49 Physical Recovery Complete: 0 Pages Restored.
> 16:09:49 Logical Recovery Started.
> 16:09:49 shmget: [ENOMEM][12]: key 52574804: out of shared memory, check> system
> SHMALL
> 16:09:49 out of virtual shared memory
>
> 16:09:49 Assert Failed: Internal Error - Segmentation Violation
> 16:09:49 Who: Session(6, informix@sungemms, 0, 218473640)
> Thread(13, bld_logrecs, d039530, 1)
> 16:09:49 Results: OnLine must abort
> 16:09:49 Action: Reinitialize shared memory
> 16:09:49 See Also: /var/tmp/af.d813d
> 16:09:49 rsinit.c, line 9932, thread 13, proc id 20737, Segmentation
> Violation.
> 16:09:49 PANIC: Attempting to bring system down
Check what happened to /etc/system.
Read the Informix release notes to see what should be in there.
Has van der Krieken wrote:
> Since I did the Y2K patch for Solaris 2.5 on a Ultra Sparc 1 system,
> Informix 7.22 refuses to startup properly.
> Anyone experienced a simular problem? Any suggestions?
> Attached some system information and the relevant part of the online.log
>
> Has van der Krieken.
>
> # uname -a
> SunOS sungemms 5.5 Generic_103093-25 sun4u sparc SUNW,Ultra-1
> # su - informix> Sun Microsystems Inc. SunOS 5.5 Generic November 1995
> $ onstat -V> INFORMIX-OnLine Version 7.22.UC2 Software Serial Number AAA#J917741
> $ cat online.log>
> Mon Dec 27 16:09:48 1999
>
> 16:09:48 Event alarms enabled. ALARMPROG = '/informix/etc/no_log.sh'
> 16:09:48 DR: DRAUTO is 0 (Off)
> 16:09:49 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 16:09:49 Physical Recovery Started.
> 16:09:49 Physical Recovery Complete: 0 Pages Restored.
> 16:09:49 Logical Recovery Started.
> 16:09:49 shmget: [ENOMEM][12]: key 52574804: out of shared memory, check> system
> SHMALL
> 16:09:49 out of virtual shared memory
>
> 16:09:49 Assert Failed: Internal Error - Segmentation Violation
> 16:09:49 Who: Session(6, informix@sungemms, 0, 218473640)
> Thread(13, bld_logrecs, d039530, 1)
> 16:09:49 Results: OnLine must abort
> 16:09:49 Action: Reinitialize shared memory
> 16:09:49 See Also: /var/tmp/af.d813d
> 16:09:49 rsinit.c, line 9932, thread 13, proc id 20737, Segmentation
> Violation.
> 16:09:49 PANIC: Attempting to bring system down
--
Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net)
Guardian of DBD::Informix v0.62 -- see http://www.perl.com/CPAN
#include <disclaimer.h>