Onbar Level 1,2 backup problem.
Posted in 2000
Topics: Backup & Restore, Storage & Space Management, Logging & Checkpoints
I have a problem during level 1 and 2 backup of an informix database. I can backup level-0 archieve of my database successfully. However, when it comes to level-1 or level-2 arhieve of the database it gives an error in the middle of the backup operation. It backups some of the dbspaces successfully. However , at the middle of the operation it gives the error listed below. Please see the listing taken from bar_act.log file below. All comments are welcome. Regards, ps. This error has occured since 03/09/2000. Yener ===================================================================== 2000-09-04 13:45:03 6281 6280 /export/home/informix/bin/onbar_d -b -L 1 2000-09-04 13:45:07 6281 6280 Begin level 1 backup rootdbs. 2000-09-04 13:45:07 6281 6280 Successfully connected to Storage Manager. 2000-09-04 13:45:09 6281 6280 Completed level 1 backup rootdbs. 2000-09-04 13:45:12 6291 6281 Process 6291 6281 successfully forked. 2000-09-04 13:45:12 6292 6281 Process 6292 6281 successfully forked. 2000-09-04 13:45:12 6293 6281 Process 6293 6281 successfully forked. 2000-09-04 13:45:12 6294 6281 Process 6294 6281 successfully forked. 2000-09-04 13:45:12 6295 6281 Process 6295 6281 successfully forked. 2000-09-04 13:45:12 6298 6281 Process 6298 6281 successfully forked. 2000-09-04 13:45:12 6297 6281 Process 6297 6281 successfully forked. 2000-09-04 13:45:12 6296 6281 Process 6296 6281 successfully forked. 2000-09-04 13:45:13 6299 6281 Process 6299 6281 successfully forked. 2000-09-04 13:45:14 6291 6281 Begin level 1 backup logdbs. 2000-09-04 13:45:14 6291 6281 Successfully connected to Storage Manager. 2000-09-04 13:45:14 6291 6281 Completed level 1 backup logdbs. 2000-09-04 13:45:16 6292 6281 Begin level 1 backup dbs1. 2000-09-04 13:45:16 6292 6281 Successfully connected to Storage Manager. 2000-09-04 13:45:18 6294 6281 Begin level 1 backup dbs3. 2000-09-04 13:45:18 6294 6281 Successfully connected to Storage Manager. 2000-09-04 13:45:18 6293 6281 Begin level 1 backup dbs2. 2000-09-04 13:45:18 6293 6281 Successfully connected to Storage Manager. 2000-09-04 13:45:20 6299 6281 Begin level 1 backup dbspos. 2000-09-04 13:45:20 6299 6281 Successfully connected to Storage Manager. 2000-09-04 13:45:21 6291 6281 Process 6291 6281 completed. 2000-09-04 13:45:25 6297 6281 Begin level 1 backup dbs6. 2000-09-04 13:45:25 6297 6281 Successfully connected to Storage Manager. 2000-09-04 13:45:25 6297 6281 Completed level 1 backup dbs6. 2000-09-04 13:45:32 6297 6281 Process 6297 6281 completed. 2000-09-04 13:47:04 6296 6281 Begin level 1 backup dbs5. 2000-09-04 13:47:04 6296 6281 Successfully connected to Storage Manager. 2000-09-04 13:47:56 6292 6281 Completed level 1 backup dbs1. 2000-09-04 13:48:03 6292 6281 Process 6292 6281 completed. 2000-09-04 13:48:51 6295 6281 Begin level 1 backup dbs4. 2000-09-04 13:48:51 6295 6281 Successfully connected to Storage Manager. 2000-09-04 13:51:20 6299 6281 Completed level 1 backup dbspos. 2000-09-04 13:51:27 6299 6281 Process 6299 6281 completed. 2000-09-04 13:55:20 6298 6281 ERROR: No response was received from the database server. Aborting ON-Bar. 2000-09-04 13:55:20 6298 6281 Process 6298 received signal 14; process exiting with code 141 (0x8d). 2000-09-04 13:55:20 6296 6281 Process 6296 received signal 3. Process will exit after cleanup. 2000-09-04 13:55:20 6295 6281 Process 6295 received signal 3. Process will exit after cleanup. 2000-09-04 13:55:20 6293 6281 Process 6293 received signal 3. Process will exit after cleanup. 2000-09-04 13:55:20 6294 6281 Process 6294 received signal 3. Process will exit after cleanup. 2000-09-04 13:55:20 6281 6280 Process 6281 received signal 3. Process will exit after cleanup. 2000-09-04 13:55:21 6294 6281 ERROR: Unable to get backup data from the database server: . 2000-09-04 13:55:21 6281 6280 The ON-Bar process 6298 exited with a problem (exit code 141 (0x8d), signal 0). 2000-09-04 13:55:21 6294 6281 Process 6294 6281 completed. 2000-09-04 13:55:21 6281 6280 The ON-Bar process 6294 exited with a problem (exit code 131 (0x83), signal 0). 2000-09-04 13:55:22 6293 6281 ERROR: Unable to get backup data from the database server: . 2000-09-04 13:55:23 6293 6281 Process 6293 6281 completed. 2000-09-04 13:55:23 6281 6280 The ON-Bar process 6293 exited with a problem (exit code 131 (0x83), signal 0). 2000-09-04 13:55:23 6281 6280 The ON-Bar process 6293 exited without returning an exit code. 2000-09-04 13:55:34 6296 6281 ERROR: Unable to get backup data from the database server: . 2000-09-04 13:55:35 6296 6281 Process 6296 6281 completed. 2000-09-04 13:55:35 6281 6280 The ON-Bar process 6296 exited with a problem (exit code 131 (0x83), signal 0). 2000-09-04 13:55:55 6295 6281 ERROR: Unable to get backup data from the database server: . 2000-09-04 13:55:56 6295 6281 Process 6295 6281 completed. 2000-09-04 13:55:56 6281 6280 The ON-Bar process 6295 exited with a problem (exit code 131 (0x83), signal 0). 2000-09-04 13:55:56 6281 6280 The ON-Bar process 6295 exited without returning an exit code. 2000-09-04 13:58:11 6715 6714 /export/home/informix/bin/onbar_d -l 2000-09-04 13:58:11 6715 6714 Begin backup logical log 35744. 2000-09-04 13:58:20 6715 6714 Successfully connected to Storage Manager. 2000-09-04 13:58:39 6715 6714 Completed backup logical log 35744. ===================================================================== Sent via Deja.com http://www.deja.com/ Before you buy.
Hi Yener,
do you have IDS 7.30.UC7 or equivalent?
We have the same problem. It could not cleared yet by the Informix support.
It seems to me a time-out problem. Your dbspace at which onbar exists is
large and may not have been updated or very seldom since the last archive.
Therefore it takes relative long until the database server carries the
updated pages to be backed up and onbar is not "patient" enough and thinks
he must break down the communication. This happens only during a level 1/2
archive.
What is the solution? No idea. The time-out parameter should be found but
it may be undocumented.
Do a level-0 archive more frequently and save also the logical logs of
course. Let your tapes clone if you can. Then you are on the secure side,
you have everything to do a successful restore.
And of course if you get a solution from your Informix support please send
it to me.
Regards
Peter
--
Peter Dzvonyar
SAP-Consultant R/3 BC
_______________________________________________________________
email: sap-ext-001@ops.de p.dzvonyar@t-online.de
_______________________________________________________________
yener@my-deja.com schrieb:
> I have a problem during level 1 and 2 backup of an informix database.
>
> I can backup level-0 archieve of my database successfully. However,
> when it comes to level-1 or level-2 arhieve of the database it gives an
> error in the middle of the backup operation. It backups some of the
> dbspaces successfully. However , at the middle of the operation it
> gives the error listed below. Please see the listing taken from
> bar_act.log file below.
>
> All comments are welcome.
>
> Regards,
>
> ps. This error has occured since 03/09/2000.
>
>
Dear Peter,
We have IDS 7.31 UC3 running on Solaris 2.6.
You are right with your observations. We have a newly created dbspace
which is not updated so often. We haven't insert any record into that
table after we created it.
I tried to backup only that dbspace. It gives the same error. I omit
that dbspace and try to backup other dbspaces. It doesn't gives any
error.
You have said that "do a level-0 archive more frequently and save
logical logs". Let me ask a question, if I take full and incremental
backup of dbspaces ( except the one that will never change), can i
restore the whole system from backups. For instance I have the
following dbspaced.
rootdbs
logdbs
dbs1
dbs2
dbs3 - dbs that never changes.
I have level-0 backup of dbs3 for 01/09/2000.
I have level-0 backup of rootdbs,logdbs,dbs1 and dbs2 for 03/09/2000.
I have level-1 backup of rootdbs,logdbs,dbs1 and dbs2 for 04/09/2000.
I have also continues logical log backup with onbar.
Crash happens on 05/09/2000.
What should I do now. The following sequence is the correct one or I
have no chance to restore whole to the position when crash happened.
i. Restore level-0 backup of all dbspaces including dbs3
ii. Restore level-0 backup of rootdbs,logdbs,dbs1 and dbs2.
iii. Restore logical-logs.
What do you think about the result of this restore. Do you think that
can I restore the system to the point where crash occured.
Regards,
Yener
ps. We already reporte this problem to our Informix support. However,
we haven't been informed about the cause of the problem yet. If I get a
result, I will let you know.
In article <39B60847.63D084BB@ops.de>,
Peter Dzvonyar <sap-ext-001@ops.de> wrote:
> Hi Yener,
>
> do you have IDS 7.30.UC7 or equivalent?
> We have the same problem. It could not cleared yet by the Informix
support.
>
> It seems to me a time-out problem. Your dbspace at which onbar exists
is
> large and may not have been updated or very seldom since the last
archive.
> Therefore it takes relative long until the database server carries the
> updated pages to be backed up and onbar is not "patient" enough and
thinks
> he must break down the communication. This happens only during a
level 1/2
> archive.
>
> What is the solution? No idea. The time-out parameter should be found
but
> it may be undocumented.
> Do a level-0 archive more frequently and save also the logical logs of
> course. Let your tapes clone if you can. Then you are on the secure
side,
> you have everything to do a successful restore.
>
> And of course if you get a solution from your Informix support please
send
> it to me.
>
> Regards
> Peter
> --
> Peter Dzvonyar
> SAP-Consultant R/3 BC
> _______________________________________________________________
>
> email: sap-ext-001@ops.de p.dzvonyar@t-online.de
> _______________________________________________________________
>
> yener@my-deja.com schrieb:
>
> > I have a problem during level 1 and 2 backup of an informix
database.
> >
> > I can backup level-0 archieve of my database successfully. However,
> > when it comes to level-1 or level-2 arhieve of the database it
gives an
> > error in the middle of the backup operation. It backups some of the
> > dbspaces successfully. However , at the middle of the operation it
> > gives the error listed below. Please see the listing taken from
> > bar_act.log file below.
> >
> > All comments are welcome.
> >
> > Regards,
> >
> > ps. This error has occured since 03/09/2000.
> >
> >
>
>
Sent via Deja.com http://www.deja.com/
Before you buy.
Hi Yener,
> rootdbs
> logdbs
> dbs1
> dbs2
> dbs3 - dbs that never changes.
>
> I have level-0 backup of dbs3 for 01/09/2000.
> I have level-0 backup of rootdbs,logdbs,dbs1 and dbs2 for 03/09/2000.
> I have level-1 backup of rootdbs,logdbs,dbs1 and dbs2 for 04/09/2000.
> I have also continues logical log backup with onbar.
>
> Crash happens on 05/09/2000.
>
> What should I do now. The following sequence is the correct one or I
> have no chance to restore whole to the position when crash happened.
>
> i. Restore level-0 backup of all dbspaces including dbs3
> ii. Restore level-0 backup of rootdbs,logdbs,dbs1 and dbs2.
> iii. Restore logical-logs.
>
> What do you think about the result of this restore. Do you think that
> can I restore the system to the point where crash occured.
I am not sure. Let us suppose the rootdbs have been destroyed (worst case)
and you have to cold restore your whole database. In this case the first
thing onbar tries to restore is the rootdbs, it looks for an appropriate
save-set and restores it. I do not think it is possible to restore dbs3 from
an earlier level 0 archive now. I have never tried it but I would not risk
it though.
But what you could do in any case and it is safe is as follows. You do not
need to make a level-0 achive more frequently. Do it as frequent as until
now - once a week for example. But always the whole system with all
dbspaces. Then make a level 1 or 2 archive respectively every day of all
dbspaces but dbs3. And of course back the logical logs regurarly up. With
this scenario your level 1 or 2 archive does not abort and you can restore
if you have a crash.
> ps. We already reporte this problem to our Informix support. However,
> we haven't been informed about the cause of the problem yet. If I get a
> result, I will let you know.
Many thanks in advance.
Regards
Peter