ontape error
Posted in 2000
Topics: Backup & Restore, Storage & Space Management, Error Codes & Troubleshooting, Platform-Specific Issues, Versions, Editions & End-of-Life
This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.
------_=_NextPart_001_01C00E7E.5B6CE90A
Content-Type: text/plain;
charset="iso-8859-1"
Hi all,
OS - Sun Solaris 2.6
SUN E10K Server
IDS 7.30.UC5
I'm using ontape to perform level 0 database backup on daily basic since day
one. Currently, my database is around 36G and the tape size is 40G. Sometime
my backup will fail and given the following error message:
Archive failed - ISAM error:no more extent
However, the backup was successful when I re-run the ontape backup on the
same tape again. Any idea on this???
Best Regards,
Jason
------_=_NextPart_001_01C00E7E.5B6CE90A
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Diso-8859-1">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
5.5.2650.12">
<TITLE>ontape error</TITLE>
</HEAD>
<BODY>
<P><FONT SIZE=3D2>Hi all,</FONT>
</P>
<P><FONT SIZE=3D2>OS - Sun Solaris 2.6</FONT>
<BR><FONT SIZE=3D2>SUN E10K Server</FONT>
<BR><FONT SIZE=3D2>IDS 7.30.UC5</FONT>
</P>
<P><FONT SIZE=3D2>I'm using ontape to perform level 0 database backup =
on daily basic since day one. Currently, my database is around 36G and =
the tape size is 40G. Sometime my backup will fail and given the =
following error message:</FONT></P>
<P><FONT SIZE=3D2>Archive failed - ISAM error:no more extent</FONT>
</P>
<P><FONT SIZE=3D2>However, the backup was successful when I re-run the =
ontape backup on the same tape again. Any idea on this???</FONT>
</P>
<P><FONT SIZE=3D2>Best Regards,</FONT>
<BR><FONT SIZE=3D2>Jason</FONT>
</P>
</BODY>
</HTML>
------_=_NextPart_001_01C00E7E.5B6CE90A--
Jason no HTML/MIME this is a text only newsgroup.
JasonYLPang@pg.SLR.com wrote:
> OS - Sun Solaris 2.6
> SUN E10K Server
> IDS 7.30.UC5
>
> I'm using ontape to perform level 0 database backup on daily basic since day
> one. Currently, my database is around 36G and the tape size is 40G. Sometime
> my backup will fail and given the following error message:
>
> Archive failed - ISAM error:no more extent
My guess? You have everything in one or two huge dbspaces and you have only
one tempdbspace, right? During the archive the engine logs the pre-images
of all pages modified to a set of temp tables one per dbspace and fragments
each temp table across all temp dbspaces. These tables are created with
minimal extent sizing so the interleaved growth of the tables causes the
table to eventually exceed the maximum number of extents and this causes
the archive to abort. Each temp table is deleted after being dumped to
tape at the end of backing up its dbspace. If you have lots of activity
and few dbspaces you may see this. Rerunning may succeed if there were
less update activity on one or all dbspaces during the rerun.
> However, the backup was successful when I re-run the ontape backup on the
> same tape again. Any idea on this???
Fix? Add more tempdbspaces (if you have one big one now drop it and make
three or four smaller ones sorts and archives go faster then anyway).
Break up your disk space into more dbspaces creating the most active ones,
in terms of updates during an archive, so they are backed up early
eliminating the need for their temp tables during the rest of the archive.
Art S. Kagel
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"