Trouble solving error -931
Posted in 1999
Topics: Installation, Setup & Upgrades, Server Administration, Networking & sqlhosts Configuration, Java & JDBC Development
Hello.
I've got INFORMIX-OnLine Version 7.22.UC1 running on a SunOS 5.6
workstation. It runs fine when configured for shared-memory connections
but fails to initialize when set to accept TCP connections.
18:06:03 listener-thread: err = -931:
Cannot locate online service/tcp service in
/etc/services.
Here's the config summary, hoping that I didn't miss anything.
$INFORMIXDIR/etc/$ONCONFIG
DBSERVERALIASES dbserver_tcp
$INFORMIXDIR/etc/sqlhosts
dbserver_tcp ontlitcp csjava online
/etc/services
online 1525/tcp
/etc/hosts
<ipaddr> csjava
However, I have noticed something odd. Upon running "oninit", I expect
the access time of /etc/services to be updated but it is not. NIS is not
running either.
My first guess is that Informix has disabled TCP connections for that
installation in accordance with the licensing agreement. My next guess
is that it is a bug, but I'm having a hard time accepting that.
Thanks for any ideas.
Edwin
In article <36E0160F.43544D55@panix.com>,
Edwin Babadaglian <edwinb@panix.com> wrote:
> Hello.
>
> I've got INFORMIX-OnLine Version 7.22.UC1 running on a SunOS 5.6
> workstation. It runs fine when configured for shared-memory connections
> but fails to initialize when set to accept TCP connections.
>
> 18:06:03 listener-thread: err = -931:
> Cannot locate online service/tcp service in
> /etc/services.
>
> Here's the config summary, hoping that I didn't miss anything.
>
> $INFORMIXDIR/etc/$ONCONFIG
> DBSERVERALIASES dbserver_tcp>
> $INFORMIXDIR/etc/sqlhosts
> dbserver_tcp ontlitcp csjava online>
> /etc/services
> online 1525/tcp
>
> /etc/hosts
> <ipaddr> csjava
>
> However, I have noticed something odd. Upon running "oninit", I expect
> the access time of /etc/services to be updated but it is not. NIS is not
> running either.
>
> My first guess is that Informix has disabled TCP connections for that
> installation in accordance with the licensing agreement. My next guess
> is that it is a bug, but I'm having a hard time accepting that.
>
> Thanks for any ideas.
>
> Edwin
>
>
Are you sure that your platform supports TLI connections ??? Maybe you should
use onsoctcp instead of ontlitcp on your sqlhosts file. Remember to verify
the parameter NETTYPE on your onconfig file. If you really have to use
sockets, you must fill an entry with soctcp on Protocol field. You can find
it out in the Release Notes file, on $INFORMIXDIR/release
HIH
Paulo Amorim
TS&O Consulting
Brasil
pauloamorim@uol.com.br
-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own