HOW CAN I CHANGE CHUNK STATUS
Posted in 2000
Topics: Storage & Space Management, Error Codes & Troubleshooting, Server Administration
This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.
------_=_NextPart_001_01BF667A.F7119AC0
Content-Type: text/plain;
charset="iso-8859-1"
I have a chunk that is down. I am trying to change the status from PD to PO.
I tried to do onspaces -s tempdb1 -p /links/TEMPDB1_ACP -o 0 -O.
Cannot change chunk status.
ISAM error: Primary and Mirror chunks are bad.I tried to drop the chunk onspaces -d tempdb1 -p /links/TEMPDB1_ACP -o 0
I get message "Chunk not dropped.
ISAM error: Can not drop first chunk.
This database instance is not mirrored at Informix level is mirrored at Unix
level.
I am running a Informix 7.22 on Unix AIX.
------_=_NextPart_001_01BF667A.F7119AC0
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Diso-8859-1">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
5.5.2448.0">
<TITLE>HOW CAN I CHANGE CHUNK STATUS</TITLE>
</HEAD>
<BODY>
<P><FONT SIZE=3D2 FACE=3D"Arial">I have a chunk that is down. I am =
trying to change the status from PD to PO. I tried to do</FONT> <FONT =
SIZE=3D2 FACE=3D"r_ansi">onspaces -s tempdb1 -p /links/TEMPDB1_ACP -o 0 =
-O. </FONT></P>
<P><FONT SIZE=3D2 FACE=3D"r_ansi">Cannot change chunk status.</FONT>
<BR><FONT SIZE=3D2 FACE=3D"r_ansi">ISAM error: Primary and Mirror =
chunks are bad. </FONT>
<BR><FONT SIZE=3D2 FACE=3D"r_ansi">I tried to drop the chunk onspaces =
-d tempdb1 -p /links/TEMPDB1_ACP -o 0</FONT>
<BR><FONT SIZE=3D2 FACE=3D"r_ansi">I get message "Chunk not =
dropped.</FONT>
<BR><FONT SIZE=3D2 FACE=3D"r_ansi">ISAM error: Can not drop first =
chunk.</FONT>
</P>
<BR>
<P><FONT SIZE=3D2 FACE=3D"r_ansi">This database instance is not =
mirrored at Informix level is mirrored at Unix level. </FONT>
</P>
<P><FONT SIZE=3D2 FACE=3D"r_ansi">I am running a Informix 7.22 on Unix =
AIX.</FONT>
</P>
</BODY>
</HTML>
------_=_NextPart_001_01BF667A.F7119AC0--
If onspaces will not mark the chunk up then the data on it has been damaged.
If you have a recent archive restore that dbspace from archive including
rolling any logs forward. If you have no recent archive you are hosed. You
can try to have Informix Tech Support force mark the chunk online but then
it may or may not be usable and I'd recommend unloading EVERYTHING in that
dbspace drop the tables, drop all the chunks, recreate the dbspace and tables,
and reload.
You say you have hardware mirror. Are there mirror errors in the system log
or the array's log? If so try dropping the damaged side of the mirror and
rebuilding it (perhaps after replacing the drive), assuming of course you did
not do that already. No insult, if I don't mention the 'dumb' stuff you may
get to beat your head for no reason.
Art S. Kagel
George Ayou wrote:
>
> This message is in MIME format. Since your mail reader does not understand
> this format, some or all of this message may not be legible.
>
> ------_=_NextPart_001_01BF667A.F7119AC0
> Content-Type: text/plain;
> charset="iso-8859-1"
>
> I have a chunk that is down. I am trying to change the status from PD to PO.
> I tried to do onspaces -s tempdb1 -p /links/TEMPDB1_ACP -o 0 -O.
> Cannot change chunk status.
> ISAM error: Primary and Mirror chunks are bad.> I tried to drop the chunk onspaces -d tempdb1 -p /links/TEMPDB1_ACP -o 0
> I get message "Chunk not dropped.
> ISAM error: Can not drop first chunk.>
> This database instance is not mirrored at Informix level is mirrored at Unix
> level.
>
> I am running a Informix 7.22 on Unix AIX.
>
> ------_=_NextPart_001_01BF667A.F7119AC0
> Content-Type: text/html;
> charset="iso-8859-1"
> Content-Transfer-Encoding: quoted-printable
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> <HTML>
> <HEAD>
> <META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
> charset=3Diso-8859-1">
> <META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
> 5.5.2448.0">
> <TITLE>HOW CAN I CHANGE CHUNK STATUS</TITLE>
> </HEAD>
> <BODY>
>
> <P><FONT SIZE=3D2 FACE=3D"Arial">I have a chunk that is down. I am =
> trying to change the status from PD to PO. I tried to do</FONT> <FONT =
> SIZE=3D2 FACE=3D"r_ansi">onspaces -s tempdb1 -p /links/TEMPDB1_ACP -o 0 =
> -O. </FONT></P>
>
> <P><FONT SIZE=3D2 FACE=3D"r_ansi">Cannot change chunk status.</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"r_ansi">ISAM error: Primary and Mirror =
> chunks are bad. </FONT>
> <BR><FONT SIZE=3D2 FACE=3D"r_ansi">I tried to drop the chunk onspaces =
> -d tempdb1 -p /links/TEMPDB1_ACP -o 0</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"r_ansi">I get message "Chunk not =
> dropped.</FONT>
> <BR><FONT SIZE=3D2 FACE=3D"r_ansi">ISAM error: Can not drop first =
> chunk.</FONT>
> </P>
> <BR>
>
> <P><FONT SIZE=3D2 FACE=3D"r_ansi">This database instance is not =
> mirrored at Informix level is mirrored at Unix level. </FONT>
> </P>
>
> <P><FONT SIZE=3D2 FACE=3D"r_ansi">I am running a Informix 7.22 on Unix =
> AIX.</FONT>
> </P>
>
> </BODY>
> </HTML>
> ------_=_NextPart_001_01BF667A.F7119AC0--
Related threads
- Conversion to differeent characters sets
- Problem in changing locale via dbexport/dbimport
- RE: openlink error "Unable to load locale categories"