Live system problem - urgent!
Posted in 2000
Topics: Error Codes & Troubleshooting, Migration, Import/Export & Data Conversion, Platform-Specific Issues
IDS v7.24 UC6 on HP-UX 10.20 I've defragged a large table by using HPL to unload it. Used HPL to reload it without indexes then built the indexes. All seems fine, same number of rows (> 13.6 million!), and I can read it fine. But when my key application comes to update the table, I get: File LIVE/COLINE. StoreDBRec error is Informix database error (51). Additional information is -242, -197. Additional Text is: Could not open database table (root.coline). ISAM error: Partiton recently appended to; can't open for write or logging. Looks like I'll have to perform an 18-hour restore, unless you guys can help PQD!! thanks Neil
The guy in US Tech Support suggested a level 0 to /dev/null. This worked.
The oddity is that I did the HPL/index creation with logging switched off,
and switched it back on again with an ontape -s -B before starting the
application. Therefore I didn't think to do another one, and was sceptical
when the Tech Support guy so suggested.
But what do I know?
Neil Truby wrote in message <8hud3o$knp$1@taliesin2.netcom.net.uk>...
>IDS v7.24 UC6 on HP-UX 10.20
>
>I've defragged a large table by using HPL to unload it. Used HPL to reload
>it without indexes then built the indexes. All seems fine, same number of
>rows (> 13.6 million!), and I can read it fine. But when my key
application
>comes to update the table, I get:
>
>File LIVE/COLINE.
> StoreDBRec error is Informix database error (51).
> Additional information is -242, -197.
> Additional Text is:
> Could not open database table (root.coline). ISAM error:
>Partiton
> recently appended to; can't open for write or logging.
>
>Looks like I'll have to perform an 18-hour restore, unless you guys can
help
>PQD!!
>
>thanks
>Neil
>
>
Hi Neil, Have you performed a Level 0 backup after rebuilding the table. My understanding is that table may be in readonly mode. If you use HPL Express mode table will be kept in read-only mode untill you take a Level 0 Archive. Thanks & Regards, Venkata .R. Potluri Neil Truby wrote in message <8hud3o$knp$1@taliesin2.netcom.net.uk>... >IDS v7.24 UC6 on HP-UX 10.20 > >I've defragged a large table by using HPL to unload it. Used HPL to reload >it without indexes then built the indexes. All seems fine, same number of >rows (> 13.6 million!), and I can read it fine. But when my key application >comes to update the table, I get: > >File LIVE/COLINE. > StoreDBRec error is Informix database error (51). > Additional information is -242, -197. > Additional Text is: > Could not open database table (root.coline). ISAM error: >Partiton > recently appended to; can't open for write or logging. > >Looks like I'll have to perform an 18-hour restore, unless you guys can help >PQD!! > >thanks >Neil > >
i think the 'problem' is that when hpl turns off constraints, in express mode, it also turns off logging to logical logs. if for example, you update the table, without taking a level 0, then the system crashes, you won't see the updates, because nothing is in the logical logs at all, to indicate the update, because, you have just updated a record which does not really exist (?) at least not synced with the logs...hence the need to do the Level 0 immediately after the hpl load... Neil Truby wrote: > IDS v7.24 UC6 on HP-UX 10.20 > > I've defragged a large table by using HPL to unload it. Used HPL to reload > it without indexes then built the indexes. All seems fine, same number of > rows (> 13.6 million!), and I can read it fine. But when my key application > comes to update the table, I get: > > File LIVE/COLINE. > StoreDBRec error is Informix database error (51). > Additional information is -242, -197. > Additional Text is: > Could not open database table (root.coline). ISAM error: > Partiton > recently appended to; can't open for write or logging. > > Looks like I'll have to perform an 18-hour restore, unless you guys can help > PQD!! > > thanks > Neil
Have you tried making a backup? If not possible at the moment try doing a fake backup.I remember something like it you have to do a Level 0 backup.But try it if you haven't. Alkin TEZUYSAL INFORMIX DBA Neil Truby wrote: > IDS v7.24 UC6 on HP-UX 10.20 > > I've defragged a large table by using HPL to unload it. Used HPL to reload > it without indexes then built the indexes. All seems fine, same number of > rows (> 13.6 million!), and I can read it fine. But when my key application > comes to update the table, I get: > > File LIVE/COLINE. > StoreDBRec error is Informix database error (51). > Additional information is -242, -197. > Additional Text is: > Could not open database table (root.coline). ISAM error: > Partiton > recently appended to; can't open for write or logging. > > Looks like I'll have to perform an 18-hour restore, unless you guys can help > PQD!! > > thanks > Neil
Neil Truby wrote:
>
> The guy in US Tech Support suggested a level 0 to /dev/null. This worked.
> The oddity is that I did the HPL/index creation with logging switched off,
> and switched it back on again with an ontape -s -B before starting the
> application. Therefore I didn't think to do another one, and was sceptical
> when the Tech Support guy so suggested.
>
> But what do I know?
>
> Neil Truby wrote in message <8hud3o$knp$1@taliesin2.netcom.net.uk>...
> >IDS v7.24 UC6 on HP-UX 10.20
> >
> >I've defragged a large table by using HPL to unload it. Used HPL to reload
> >it without indexes then built the indexes. All seems fine, same number of
> >rows (> 13.6 million!), and I can read it fine. But when my key
> application
> >comes to update the table, I get:
> >
> >File LIVE/COLINE.
> > StoreDBRec error is Informix database error (51).
> > Additional information is -242, -197.
> > Additional Text is:
> > Could not open database table (root.coline). ISAM error:
> >Partiton
> > recently appended to; can't open for write or logging.
> >
> >Looks like I'll have to perform an 18-hour restore, unless you guys can
> help
> >PQD!!
> >
> >thanks
> >Neil
> >
> >
It does seem a bit odd that HPL will not only load the table but allow
indices to be created in read-only mode. I guess they only mean
external reads . . . . . 8-)
--
John Carlson
Informix DBA
WHSmith USA
#include std_disclaimer.h /* These are my opinions, not my company's
opinion */