Cannot read systemcatalog
Posted in 2010
Topics: Performance & Tuning, Connectivity: ESQL/C, 4GL & Embedded SQL, Logging & Checkpoints, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi guys, During execution of "update statistics" scripts, which are build based on the performance guide and the recommendations of John Miller we have following issue on Solaris with IDS 9.4UC7. Database is in buffered logging mode. In the scripts , for every 100 statements we have a "begin work" and a "commit work". This was added because without them too many logical logfiles were filled for databases in unbuffered logging mode. Now when these scripts start running (at night), users complain about their sessions being aborted with error messages as : Program error at "/home1/extrpvcs/prod/sources/siskue.4gl", line number 268. SQL statement error number -211. Cannot read system catalog (sysdistrib) Cannot read system catalog (systables Any ideas what's the cause and how to solve it ? Thanks, Jacques Lapeire
The cause is the BEGIN WORK. Each UPDATE STATISTICS run will do an UPDATE on the systables at the beginning... So the record for the table in systables will be locked. If you can't take out the BEGIN WORK please open a PMR explaining the situation and reference APAR IC57589. The issue is being worked by R&D. This specific APAR is related to ANSI databases. Not sure if a possible fix will solve your situation. I'm wondering why it consumes too many logical logs without BEGIN WORK... Never faced a situation like that. Hmmm.... you'e on 9.40. A PMR for that will not be accepted unless you have extended support... And any fix will not be done for that version... I guees you have to take out the BEGIN WORK... Regards. On Thu, Mar 25, 2010 at 9:49 AM, JACQUES LAPEIRE < jacques.lapeire@ts.fujitsu.com> wrote: > Hi guys, > > During execution of "update statistics" scripts, which are build based on > the > performance guide and the recommendations of John Miller we have following > issue on Solaris with IDS 9.4UC7. Database is in buffered logging mode. > > In the scripts , for every 100 statements we have a "begin work" and a > "commit > work". This was added because without them too many logical logfiles were > filled for databases in unbuffered logging mode. > > Now when these scripts start running (at night), users complain about their > sessions being aborted with error messages as : > > Program error at "/home1/extrpvcs/prod/sources/siskue.4gl", line number > 268. > SQL statement error number -211. > > Cannot read system catalog (sysdistrib) > Cannot read system catalog (systables > > Any ideas what's the cause and how to solve it ? > > Thanks, > Jacques Lapeire > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > -- Fernando Nunes Portugal http://informix-technology.blogspot.com My email works... but I don't check it frequently... --0016e6469686fc03ec04829d6da3