Bill,
Are You sure, that fiel /etc/hosts was not modified since
last informix startup, or server was renamed, or file
sqlhosts was modified?
That error usaully means, that IDS is unable to open
listen socket on specific network adapter.
------------------------------------------
Alexey Sonkin
Senior Database Administrator
> -----Original Message-----
> From: Bill Hamilton [mailto:laidback@finsco.com]
> Sent: Monday, February 09, 2004 4:14 PM
> To: informix-list
> Subject: expanding physical log failed
>
> This is IDS 9.4 UC2 on Windows 2000.
>
> I attempted to increase the size of the physical log today with ugly
> results.
>
> I created the new space and checked it for contiguous space.
>
> I executed
> onparams -p -s 32768 -d physpace1 -y>
> Onparams kept telling me that the server had to be in quiescent mode,
> even though it was already it that mode.
>
> I then modified the ONCONFIG file to change the PHYSFILE and PHYSDBS
> variables and restarted the IDS.
> I got this:
>
> 14:47:13 Booting Language <c> from module <>
> 14:47:13 Loading Module <CNULL>
> 14:47:13 Booting Language <builtin> from module <>
> 14:47:13 Loading Module <BUILTINNULL>
> 14:47:18 IBM Informix Dynamic Server Version 9.40.TC2 Software Serial> Number AAA#B000000
> 14:47:18 listener-thread: err = -25572: oserr = 48: errstr = : Network> driver cannot bind a name to the port.
> System error = 48.
> 14:47:18 sql_listener: ASF_LISTEN failed
> 14:47:18 Attempting to bring listener thread down.
> 14:47:18 Server stopped.>
> I put the onconfig back the way it was and restarted with the same result.
> I booted the machine and started IDS again with the same result.
> I tried one more time to start IDS and it came up correctly.
> Any ideas as to what caused this?
>
> sending to informix-list
sending to informix-list