onbar restore problem
Posted in 2006
Topics: Backup & Restore, Storage & Space Management, Logging & Checkpoints
Hello everybody..
I need some help here.My problem is I could not restore logical log on one of
my development instance.When it goes to physical point in time restore..the
restoration was successfull.But when i tried to restore logical log (time is
equal to physical restore) the restoration failed..
here is my command to restore:
1)onbar -r -p -t "2006-08-06 19:12:00" --> restoration successfull
2)onbar -r -l -t "2006-08-06 19:12:00" --->restoration failed
my question is.. could I change the Inconsistent chunk to online without
restoring the logical log? (because the logical log restore always failed)
log from onbar_activity:
2006-08-17 08:11:13 17297 17295 /informix/bin/onbar_d -r -p -t 2006-08-06
19:12:00
2006-08-17 08:11:13 17297 17295 Working with veritas-netbackup as generic
storage manager.
2006-08-17 08:11:14 17297 17295 Successfully connected to Storage Manager.
2006-08-17 08:14:49 17297 17295 Begin cold level 0 restore rootdbs (Storage
Manager copy ID: 0 1154862064).
2006-08-17 08:15:07 17297 17295 Completed cold level 0 restore rootdbs.
2006-08-17 08:15:07 17425 17297 Process 17425 17297 successfully forked.
2006-08-17 08:15:07 17423 17297 Process 17423 17297 successfully forked.
2006-08-17 08:15:07 17424 17297 Process 17424 17297 successfully forked.
2006-08-17 08:15:07 17429 17297 Process 17429 17297 successfully forked.
2006-08-17 08:15:07 17427 17297 Process 17427 17297 successfully forked.
2006-08-17 08:15:07 17424 17297 Successfully connected to Storage Manager.
2006-08-17 08:15:07 17425 17297 Successfully connected to Storage Manager.
2006-08-17 08:15:07 17429 17297 Successfully connected to Storage Manager.
2006-08-17 08:15:08 17423 17297 Successfully connected to Storage Manager.
2006-08-17 08:15:08 17426 17297 Process 17426 17297 successfully forked.
2006-08-17 08:15:08 17428 17297 Process 17428 17297 successfully forked.
2006-08-17 08:15:08 17427 17297 Successfully connected to Storage Manager.
2006-08-17 08:15:08 17428 17297 Successfully connected to Storage Manager.
2006-08-17 08:15:08 17426 17297 Successfully connected to Storage Manager.
2006-08-17 08:15:28 17424 17297 Begin cold level 0 restore dbspace1 (Storage
Manager copy ID: 0 1154862317).
2006-08-17 08:16:48 17424 17297 Completed cold level 0 restore dbspace1.
2006-08-17 08:16:48 17424 17297 Process 17424 17297 completed.
2006-08-17 08:16:48 17426 17297 Begin cold level 0 restore dbspace3 (Storage
Manager copy ID: 0 1154862603).
2006-08-17 08:17:58 17423 17297 Begin cold level 0 restore logdbs (Storage
Manager copy ID: 0 1154862307).
2006-08-17 08:18:03 17425 17297 Begin cold level 0 restore dbspace2 (Storage
Manager copy ID: 0 1154862432).
2006-08-17 08:18:06 17423 17297 Completed cold level 0 restore logdbs.
2006-08-17 08:18:06 17423 17297 Process 17423 17297 completed.
2006-08-17 08:20:28 17428 17297 Begin cold level 0 restore dbspace5 (Storage
Manager copy ID: 0 1154862946).
2006-08-17 08:20:31 17426 17297 Completed cold level 0 restore dbspace3.
2006-08-17 08:20:31 17426 17297 Process 17426 17297 completed.
2006-08-17 08:20:36 17428 17297 Completed cold level 0 restore dbspace5.
2006-08-17 08:20:36 17428 17297 Process 17428 17297 completed.
2006-08-17 08:21:04 17427 17297 Begin cold level 0 restore dbspace4 (Storage
Manager copy ID: 0 1154862818).
2006-08-17 08:21:07 17425 17297 Completed cold level 0 restore dbspace2.
2006-08-17 08:21:07 17425 17297 Process 17425 17297 completed.
2006-08-17 08:22:33 17429 17297 Begin cold level 0 restore sbspace1 (Storage
Manager copy ID: 0 1154862966).
2006-08-17 08:22:36 17427 17297 Completed cold level 0 restore dbspace4.
2006-08-17 08:22:36 17427 17297 Process 17427 17297 completed.
2006-08-17 08:22:41 17429 17297 Completed cold level 0 restore sbspace1.
2006-08-17 08:22:41 17429 17297 Process 17429 17297 completed.
2006-08-17 08:22:41 17297 17295 (-43177) Physical restore complete. Logical
restore required before work can
continue. Use 'onbar -r -l' to do logical restore.
If the physical restore is from a whole-system backup, then logical
restore is not required.
2006-08-17 08:22:41 17297 17295 /informix/bin/onbar_d complete, returning 0
(0x00)
2006-08-17 08:24:50 17799 17797 /informix/bin/onbar_d -r -l -t 2006-08-06
19:12:00
2006-08-17 08:24:50 17799 17797 Working with veritas-netbackup as generic
storage manager.
2006-08-17 08:24:51 17799 17797 Successfully connected to Storage Manager.
2006-08-17 08:29:51 17799 17797 Begin restore logical log 1017 (Storage
Manager copy ID: 0 1155714260).
2006-08-17 08:29:51 17799 17797 Unable to write storage space restore data to
the database server: buc_fe.c : Archive API processi
ng failed at line 905 for msgtype.
2006-08-17 08:29:56 17799 17797 Unable to close the storage space restore:
buc_fe.c : Archive API processing failed at line 905 fo
r msgtype.
2006-08-17 08:29:56 17799 17797 /informix/bin/onbar_d complete, returning 131
(0x83)
onstat -d :
dev : /informix> onstat -d
IBM Informix Dynamic Server Version 9.40.FC8W1 -- Fast Recovery -- Up 00:08:37
-- 583680 Kbytes
Dbspaces
address number flags fchunk nchunks flags owner name
115486490 1 0x401 1 1 NP informix rootdbs
1162b34f0 2 0x401 2 1 NP informix logdbs
1162b3958 3 0x2005 3 1 NDT informix tempdbs
1162b6028 4 0x2005 4 1 NDT informix tempdbs1
1162b6490 5 0x2005 5 1 NDT informix tempdbs2
1162b68f8 6 0x401 6 1 NP informix dbspace1
1162ba028 7 0x401 7 1 NP informix dbspace2
1162ba490 8 0x401 8 3 NP informix dbspace3
1162ba8f8 9 0x401 10 2 NP informix dbspace4
1162be028 10 0x8401 13 1 NPS informix sbspace1
1162be490 11 0x401 14 1 NP informix dbspace5
11 active, 2047 maximum
Chunks
address chunk/dbs offset size free bpages flags pathname
1154868f8 1 1 0 250000 235290 PI-- /informix/data/dev/rootchk1
115486af8 2 2 0 500000 49947 PI-- /informix/data/dev/logchk1
115486c90 3 3 0 500000 497769 PI-- /informix/data/dev/tempchk1
115486e28 4 4 0 500000 497797 PI-- /informix/data/dev/tempchk2
115653450 5 5 0 500000 497797 PI-- /informix/data/dev/tempchk3
1156535e8 6 6 0 500000 194744 PI-- /informix/data/dev/datachk1
115653780 7 7 0 500000 130011 PI-- /informix/data/dev/datachk2
115653918 8 8 0 500000 117186 PI-- /informix/data/dev/datachk3
115653ab0 9 8 500000 500000 437303 PI-- /informix/data/dev/datachk4
115653c48 10 9 500000 500000 318871 PI-- /informix/data/dev/datachk5
115653de0 11 9 500000 500000 412254 PI-- /informix/data/dev/datachk6
1162b3028 12 8 0 1000000 986775 PI-- /informix/data/dev/datachk7
1162b31c0 13 10 0 1000000 -1 -1 PIS- /informix/data/dev/sbschk1
1162b3358 14 11 0 1000000 382960 PI-- /informix/data/dev/datachk8
14 active, 2047 maximum
Expanded chunk capacity mode: disabled
Hi,
unfortunately you cannot simply get inconsistent chunks marked
as on-line. In general they are really inconsistent after the physical
restore and logical log restore really is necessary to get them
consistent.
Only exception to the above rule is for whole system backups
(done with "onbar -b -w ..."). These can be fully restored (done
with "onbar -r -w -p") without the need for logical log restore.
See the manual for more info on this.
If you have done whole system backup (which I can't see from
the info provided), then you can do whole system restore as
described above. You cannot do a whole system restore of
a backup that was not done as a whole system backup.
Have you tried to simply do 'onbar -r -t "2006-08-06 19:12:00" ',
i.e. in one step as opposed to two separate steps?
I'm not sure that this would work, but it may be well worth a try.
Apart from that (as a developer) I think that there is a problem
in the code causing the error you see. Please open a call with
IBM Informix Tech Support (if you have not done so already)
to get the problem analyzed and fixed. (You will need to
provide the onbar debug log, for that set BAR_DEBUG to at
least 6 or 7, just for the command "onbar -r -l -t ...").
I know that there has been a problem in this area in the last
couple of months, but I thought it looked somewhat different.
However, analysis by Tech Support might still reveal that your
problem is already fixed in a newer PID drop ("W-release").
If not it surely will find its way to my groups defect list ... :)
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
IBM Information On Demand Global Conference
October 15-20, 2006, Anaheim, California
see http://www.ibm.com/events/informationondemand
ids-bounces@iiug.org wrote on 17.08.2006 02:49:15:
>
> Hello everybody..
>
> I need some help here.My problem is I could not restore logical log on
one of
> my development instance.When it goes to physical point in time
restore..the
> restoration was successfull.But when i tried to restore logical log
(time is
> equal to physical restore) the restoration failed..
>
> here is my command to restore:
>
> 1)onbar -r -p -t "2006-08-06 19:12:00" --> restoration successfull
> 2)onbar -r -l -t "2006-08-06 19:12:00" --->restoration failed
>
> my question is.. could I change the Inconsistent chunk to online without
> restoring the logical log? (because the logical log restore always
failed)
>
> log from onbar_activity:
>
> 2006-08-17 08:11:13 17297 17295 /informix/bin/onbar_d -r -p -t
2006-08-06
> 19:12:00
> 2006-08-17 08:11:13 17297 17295 Working with veritas-netbackup as
generic
> storage manager.
> 2006-08-17 08:11:14 17297 17295 Successfully connected to Storage
Manager.
> 2006-08-17 08:14:49 17297 17295 Begin cold level 0 restore rootdbs
(Storage
> Manager copy ID: 0 1154862064).
> 2006-08-17 08:15:07 17297 17295 Completed cold level 0 restore rootdbs.
> 2006-08-17 08:15:07 17425 17297 Process 17425 17297 successfully forked.
> 2006-08-17 08:15:07 17423 17297 Process 17423 17297 successfully forked.
> 2006-08-17 08:15:07 17424 17297 Process 17424 17297 successfully forked.
> 2006-08-17 08:15:07 17429 17297 Process 17429 17297 successfully forked.
> 2006-08-17 08:15:07 17427 17297 Process 17427 17297 successfully forked.
> 2006-08-17 08:15:07 17424 17297 Successfully connected to Storage
Manager.
> 2006-08-17 08:15:07 17425 17297 Successfully connected to Storage
Manager.
> 2006-08-17 08:15:07 17429 17297 Successfully connected to Storage
Manager.
> 2006-08-17 08:15:08 17423 17297 Successfully connected to Storage
Manager.
> 2006-08-17 08:15:08 17426 17297 Process 17426 17297 successfully forked.
> 2006-08-17 08:15:08 17428 17297 Process 17428 17297 successfully forked.
> 2006-08-17 08:15:08 17427 17297 Successfully connected to Storage
Manager.
> 2006-08-17 08:15:08 17428 17297 Successfully connected to Storage
Manager.
> 2006-08-17 08:15:08 17426 17297 Successfully connected to Storage
Manager.
> 2006-08-17 08:15:28 17424 17297 Begin cold level 0 restore dbspace1
(Storage
> Manager copy ID: 0 1154862317).
> 2006-08-17 08:16:48 17424 17297 Completed cold level 0 restore dbspace1.
> 2006-08-17 08:16:48 17424 17297 Process 17424 17297 completed.
> 2006-08-17 08:16:48 17426 17297 Begin cold level 0 restore dbspace3
(Storage
> Manager copy ID: 0 1154862603).
> 2006-08-17 08:17:58 17423 17297 Begin cold level 0 restore logdbs
(Storage
> Manager copy ID: 0 1154862307).
> 2006-08-17 08:18:03 17425 17297 Begin cold level 0 restore dbspace2
(Storage
> Manager copy ID: 0 1154862432).
> 2006-08-17 08:18:06 17423 17297 Completed cold level 0 restore logdbs.
> 2006-08-17 08:18:06 17423 17297 Process 17423 17297 completed.
> 2006-08-17 08:20:28 17428 17297 Begin cold level 0 restore dbspace5
(Storage
> Manager copy ID: 0 1154862946).
> 2006-08-17 08:20:31 17426 17297 Completed cold level 0 restore dbspace3.
> 2006-08-17 08:20:31 17426 17297 Process 17426 17297 completed.
> 2006-08-17 08:20:36 17428 17297 Completed cold level 0 restore dbspace5.
> 2006-08-17 08:20:36 17428 17297 Process 17428 17297 completed.
> 2006-08-17 08:21:04 17427 17297 Begin cold level 0 restore dbspace4
(Storage
> Manager copy ID: 0 1154862818).
> 2006-08-17 08:21:07 17425 17297 Completed cold level 0 restore dbspace2.
> 2006-08-17 08:21:07 17425 17297 Process 17425 17297 completed.
> 2006-08-17 08:22:33 17429 17297 Begin cold level 0 restore sbspace1
(Storage
> Manager copy ID: 0 1154862966).
> 2006-08-17 08:22:36 17427 17297 Completed cold level 0 restore dbspace4.
> 2006-08-17 08:22:36 17427 17297 Process 17427 17297 completed.
> 2006-08-17 08:22:41 17429 17297 Completed cold level 0 restore sbspace1.
> 2006-08-17 08:22:41 17429 17297 Process 17429 17297 completed.
> 2006-08-17 08:22:41 17297 17295 (-43177) Physical restore complete.
Logical
> restore required before work can
> continue. Use 'onbar -r -l' to do logical restore.
> If the physical restore is from a whole-system backup, then logical
> restore is not required.
> 2006-08-17 08:22:41 17297 17295 /informix/bin/onbar_d complete,
returning 0
> (0x00)
> 2006-08-17 08:24:50 17799 17797 /informix/bin/onbar_d -r -l -t
2006-08-06
> 19:12:00
> 2006-08-17 08:24:50 17799 17797 Working with veritas-netbackup as
generic
> storage manager.
> 2006-08-17 08:24:51 17799 17797 Successfully connected to Storage
Manager.
> 2006-08-17 08:29:51 17799 17797 Begin restore logical log 1017 (Storage
> Manager copy ID: 0 1155714260).
> 2006-08-17 08:29:51 17799 17797 Unable to write storage space restore
data to
> the database server: buc_fe.c : Archive API processi
> ng failed at line 905 for msgtype.
> 2006-08-17 08:29:56 17799 17797 Unable to close the storage space
restore:
> buc_fe.c : Archive API processing failed at line 905 fo
> r msgtype.
> 2006-08-17 08:29:56 17799 17797 /informix/bin/onbar_d complete,
returning 131
> (0x83)
>
> o
yes I've tried that one too
(Have you tried to simply do 'onbar -r -t "2006-08-06 19:12:00" ',).
The problem occur when its try to restore logical log
I was told that informix support does have a tool to overcome this problem.
.Below is the list onbar restore type that I have done:
onbar -r -w
onbar -r -t " " (time is different but the problem still the same..cannotrestore logical log)
onbar -r -p -w (this one succes on physical restore but dbspace5 still down).
I've asked development team and they said the logical log is not important
because they only want the data in the dbspace5
Related threads
- IDS 10 table-level restore
- Informix Development Webinar December 11, 2007
- ontape -p/r with changed ROOTPATH
- Migrate from HP PA-RISC to HP ITANIUM by ontape