HDR-Connectivity issue
Posted in 2011
Topics: High Availability & Replication, Logging & Checkpoints, Networking & sqlhosts Configuration, Platform-Specific Issues
Our HDR setup between Production and Disaster Recovery is fairly new ( 4 months old) but this issue has been noted more recetly: three times in the past 2 weeks, always/only at night. The cause appears to be a brief network outage, though, the network admin. cannot see it with his tools tuned to poll every 5 secs. Not sure what to do next to diagnose further. ( HP-UX B.11.31, Informix 11.50.FC5W2) The Online logs have the following lines: On Primary server 01:39:03 Logical Log 14129 Complete, timestamp: 0xec5ee9de. 01:40:44 DR: ping timeout 01:40:46 DR: Receive error 01:40:46 ASF Echo-Thread Server: asfcode = -25582: oserr = 0: errstr = : Network connection is broken. 01:40:46 DR_ERR set to -1 01:40:47 DR: Turned off on primary server 01:40:47 DR: Cannot connect to secondary server 01:40:58 DR: Primary server connected On Secondary server 01:40:47 DR: Receive error 01:40:47 ASF Echo-Thread Server: asfcode = -25582: oserr = 0: errstr = : Network connection is broken. 01:40:47 DR_ERR set to -1 01:40:47 DR: Warning - Proxy Subsystem not terminated 01:40:51 Logical Log 14129 Complete, timestamp: 0xec5f15e9. 01:40:51 DR: Turned off on secondary server 01:40:55 DR: Secondary server connected The 3 instances I have noted this are at the following times: 23:05:02 DR_ERR set to -1 01:42:34 DR_ERR set to -1 01:40:46 DR_ERR set to -1 Alarmprogram.sh sends me the following in separate emails: DR: Turned off on primary server DR: Cannot connect to secondary server
What is DR_TIMEOUT set to? From: "MURALI PAZHAYANNUR" <pmurali@ftportfolios.com> To: ids@iiug.org Date: 12/16/2011 09:48 AM Subject: HDR-Connectivity issue [25651] Sent by: ids-bounces@iiug.org Our HDR setup between Production and Disaster Recovery is fairly new ( 4 months old) but this issue has been noted more recetly: three times in the past 2 weeks, always/only at night. The cause appears to be a brief network outage, though, the network admin. cannot see it with his tools tuned to poll every 5 secs. Not sure what to do next to diagnose further. ( HP-UX B.11.31, Informix 11.50.FC5W2) The Online logs have the following lines: On Primary server 01:39:03 Logical Log 14129 Complete, timestamp: 0xec5ee9de. 01:40:44 DR: ping timeout 01:40:46 DR: Receive error 01:40:46 ASF Echo-Thread Server: asfcode = -25582: oserr = 0: errstr = : Network connection is broken. 01:40:46 DR_ERR set to -1 01:40:47 DR: Turned off on primary server 01:40:47 DR: Cannot connect to secondary server 01:40:58 DR: Primary server connected On Secondary server 01:40:47 DR: Receive error 01:40:47 ASF Echo-Thread Server: asfcode = -25582: oserr = 0: errstr = : Network connection is broken. 01:40:47 DR_ERR set to -1 01:40:47 DR: Warning - Proxy Subsystem not terminated 01:40:51 Logical Log 14129 Complete, timestamp: 0xec5f15e9. 01:40:51 DR: Turned off on secondary server 01:40:55 DR: Secondary server connected The 3 instances I have noted this are at the following times: 23:05:02 DR_ERR set to -1 01:42:34 DR_ERR set to -1 01:40:46 DR_ERR set to -1 Alarmprogram.sh sends me the following in separate emails: DR: Turned off on primary server DR: Cannot connect to secondary server ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
I'll assume you meant DRTIMEOUT. Here are the values:
DRAUTO 0
DRINTERVAL 30
DRTIMEOUT 30
try to test your connection first from primary to secondary server
dbaccess> databases > connect.
If you cannot, check the setup, sqlhosts and authentication.
If you can connect to the secondary server,you can setup by
onmode -d primary <secondary server>
Related threads
- System Or Internal Error InterruptedIOException
- 25582 error on high volume of short live trans
- ASF Echo-Thread Server: asfcode = -25582 oserr = 4