RE: Assert Failed: Internal Error - Bus Error
Posted in 1997
Yakov,
I recommend you to update your Informix database server. We have
to upgrade one of our customers site from 7.13 to 7.20 on a=20
Digital Machine ( Alpha with DGUX 4.0 ). We experimented that
kind of Assert Failures. Jeff Craig is right, Informix has a bug
with numeric-string conversion when the table field ( for example an =
integer )
does not match the program variable ( for example char ) but this
bug is already fixed in the latest versions.
Regards,
Mario Estrada
---------------Reply Separator----------------
----------
From: Jeff Craig[SMTP:settler@rmy.emory.edu]
Sent: Monday, July 14, 1997 6:10 PM
To: informix-list@rmy.emory.edu; PROJECT Yakov Berkovitch 5055
Subject: Re: Assert Failed: Internal Error - Bus Error
}>From ilist@rmy.emory.edu Mon Jul 14 05:24:28 1997
}>Received: from rmy.rmy.emory.edu by hobbes.dbintellect.com via ESMTP =
(950413.SGI.8.6.12/930416.SGI.AUTO)
}> for <settler@dbintellect.com> id FAA06490; Mon, 14 Jul 1997 05:24:26 =
-0600
}>Received: (from ilist@localhost) by rmy.rmy.emory.edu (8.7.1/8.7.1) id =
FAA20581 for informix-list-out; Mon, 14 Jul 1997 05:10:01 -0400 (EDT)
}>From: PROJECT Yakov Berkovitch 5055 <berko@cpm.elex.co.il>
}>Message-Id: <33C9C6D3.78FE@cpm.elex.co.il>
}>Subject: Assert Failed: Internal Error - Bus Error
}>Date: Mon, 14 Jul 1997 06:27:32 GMT
}>Reply-To: PROJECT Yakov Berkovitch 5055 <berko@cpm.elex.co.il>
}>Organization: Telrad Ltd.
}>Sender: informix-list-owner@rmy.emory.edu
}>To: informix-list@rmy.emory.edu
}>X-Informix-List-Id: <news.40382>
}>
}>Hello,
}>
}>we have a serious problem with our Informix release. I also don't know
}>if newer release solved the problem.
}>
}>Here is our configuration:
}> - Informix Online 7.12 UC1 on HPUX 9.05.
}>
}>The problem:
}>Since a few days the oninit processes are going down almost one time =
per
}>day. The big problem is that the application is already in service in
}>one of our big customer. It's very difficult for us to reproduce the
}>problem in our development site.
}>
}>Here is what was written in the online.log file:
}>
}>02:28:52 Logical Log 3916 Complete.
}>02:33:59 Checkpoint Completed: duration was 8 seconds.
}>02:39:06 Checkpoint Completed: duration was 5 seconds.
}>02:44:14 Checkpoint Completed: duration was 5 seconds.
}>02:47:33 Logical Log 3917 Complete.
}>02:49:24 Checkpoint Completed: duration was 8 seconds.
}>02:54:30 Checkpoint Completed: duration was 6 seconds.
}>02:59:37 Checkpoint Completed: duration was 5 seconds.
}>03:03:25 Logical Log 3918 Complete.
}>03:03:57 Assert Failed: Internal Error - Bus Error
}>03:03:57 Who:Session(126, atlas@gl1os1, 24700, -1029554752)
}> Thread(49, sqlexec, c2a031b0, 1)
}>03:03:57 Results: OnLine must abort
}>03:03:57 Action: Reinitialize shared memory
}>03:03:57 See Also: /tmp/af.316ced, shmem.316ced.0
}>03:04:52 rsinit.c, line 9151, thread 49, proc id 24199, Bus Error.
}>03:04:53 PANIC: Attempting to bring system down
}>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
}> - Also a core file is generated.
}> - Can anybody (Informix people) tell me what is in the file rsinit.c
}>line 9151. It always failed in this file and line.
}> - We can also see that in the output
}>"Who:Session(126, atlas@gl1os1, 24700, -1029554752)"
}>the last number seems to be incorrect.
}>
}>My problem is also that i cannot look inside the memory dump
}>'shmem.316ced.0' with the onstat -i tool. I get this error:
}>
}>HP_shmgetat(): Virtual address 0xc043b000 not available got 0xc3286000
}>rinfile: shmget/shmat error errno=3D2
}>
}>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D
}>You understand that it's very critical. The customer wants to drop
}>Informix from his site !!!!!
}>
}>Every suggestion will help me.
}>Our Informix supplier get also the description of the problem, but i
}>prefer to ask more people.
}>
}>Also i know that there are newer release of Informix Online BUT if i
}>need to replace the actual release i want to be sure that the problem
}>will be solved !!
}>
}>Thanks for your help.
}>--=20
}>
}>Yakov.
}> <Yakov Berkovitch - berko@cpm.elex.co.il>
}>
I have received these on an Informix 7.20.UC2 version running on IRIX =
6.2.=20
We finally traced ours down to a problem in the way Informix was =
handling
a conversion error. The SQL compared an INTEGER column with a CHAR
constant. This problem "disappeared" in release 7.22, but that release =
had
other problems, so we are waiting for Informix 7.23. In the meantime,
we occasionally have PANICs, and the database server crashes. The only=20
thing I can suggest is that your application developers check their=20
programs to be sure that they have defined host variables and that the=20
data they are putting into the host variables matches the data type of =
the
column they are comparing to.
-------------------------------------------------------------------
Jeff Craig | dbINTELLECT Technologies, Inc.
Senior Consultant | Golden, CO
| (303) 275-6954 ext. 8008
| email: settler@dbintellect.com =
=20
| fax: (303) 275-2134
-------------------------------------------------------------------