oninit error ..
Posted in 2005
Topics: General Discussion
Hello,
When I do an oninit -iy for the first time , I get the following eorror :-
Shared memory not initailized:permission not available.
What are the basic causes of such error ?
I mean, the error points to some permissions not available but which
permissions am I supposed to grant.
Please do reply...
Hi,
your question lacks some essential information: What operating
are you using? Informix version?
Regards,
Andreas Kutsche
>
-------------------------------------------
SPAR Oesterreichische Warenhandels-AG
Hauptzentrale
Europastrasse 3
A - 5015 Salzburg
Tel: +43 662 4470 24223
Mobile: +43 664 6259575
E-Mail: Andreas.KUTSCHE@spar.at
Internet: http://www.spar.at
-------------------------------------------
-----Ursprüngliche Nachricht-----
> Von: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org]Im
> Auftrag von SANTOSH NIKUMBH
> Gesendet: Dienstag, 26. Juli 2005 08:11
> An: ids@iiug.org
> Betreff: oninit error .. [5493]
>
>
> Hello,
>
> When I do an oninit -iy for the first time , I get the
> following eorror :-
>
> Shared memory not initailized:permission not available.
>
> What are the basic causes of such error ?
>
> I mean, the error points to some permissions not available
> but which permissions am I supposed to grant.
>
> Please do reply...
>
>
Hi,
did you perform the complete installation procedure?
It sounds like the "oninit" executable does not have the
correct file access permissions. These are set during
the installation procedure.
Other than that you can check the IDS message log file
(see MSGPATH parameter in your onconfig file) for
more information.
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Information Management
forum.subscriber@iiug.org wrote on 07/26/2005 08:10:36 AM:
> Hello,
>
> When I do an oninit -iy for the first time , I get the following eorror
:-
>
> Shared memory not initailized:permission not available.
>
> What are the basic causes of such error ?
>
> I mean, the error points to some permissions not available but which
permissions am I supposed to grant.
>
> Please do reply...
>
One more update for this . I get the following in the log :- 16:12:29 listener-thread: err = -25572: oserr = 227: errstr = : Network driver cannot bind a name to the port. System error = 227. ------------------------------------------------------------------ Does it mean that my entry in the "services" file is NOT proper ? I have made an entry in /etc/services file as :- padbv2 3400/tcp #informix padbv2 instance
SANTOSH NIKUMBH wrote >One more update for this . I get the following in the log :- >16:12:29 listener-thread: err = -25572: oserr = 227: errstr = : Network driver cannot >bind a name to the port. > System error = 227. ------------------------------------------------------------------ >Does it mean that my entry in the "services" file is NOT proper ? >I have made an entry in /etc/services file as :- >padbv2 3400/tcp #informix padbv2 instance What does 'grep padbv2 $INFORMIXDIR/etc/sqlhosts' output (assuming Unix platform) Colin Bull ======================================================================= This email may contain confidential and privileged information and is intended for the named or authorised recipients only. If you are not the named or authorised recipient of this email, please note that any copying, distribution, disclosure or use of its contents is strictly prohibited. If you have received this email in error please notify the sender immediately and then destroy it. The views expressed in this email are not necessarily those held by VNL, and VNL does not accept any liability for any action taken in reliance on the contents of this message. VNL does not guarantee that the integrity of this email has been maintained, nor that it is free of viruses, interceptions or interference. _______________________________________________________________________ This email has been scanned for all known viruses by the MessageLabs Email Security System. _______________________________________________________________________
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts