listener-thread: err = -25572:
Posted in 2001
Topics: Installation, Setup & Upgrades, Storage & Space Management, Error Codes & Troubleshooting, Platform-Specific Issues
After starting Informix Version 7.23.UC1 with oninit no daemon is
running and i get the following error in online.log:
**************************
/usr/informix> pg online.log
19:21:42 VP pid=11876 priority fixed at 65, former = 93
Fri Jan 26 19:21:46 2001
19:21:46 Event alarms enabled. ALARMPROG =
'/usr/informix/etc/log_full.sh'
19:21:48 DR: DRAUTO is 0 (Off)
19:21:48 AIX MP latch code enabled
19:21:48 listener-thread: err = -25572: Network driver cannot bind aname to th
e port.
System error = 68.
19:21:48 Attempting to bring listener thread down
19:21:48 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
19:21:48 Warning: Invalid dbspace 'infs010' listed in DBSPACETEMP.
19:21:48 Physical Recovery Started.
19:21:48 Physical Recovery Complete: 0 Pages Restored.
19:21:48 Logical Recovery Started.
19:21:48 PANIC: Attempting to bring system down
**************************************************
Can someone tell what the erro can be. This installation was running for
over two years without change.
Can it be some network depending change like new DNS server etc.?
Wolfgang
$ finderr -25572-25572 Network driver cannot bind a name to the port.
A system call has failed. The sqlexecd daemon or database server cannot
access the network port that is specified by the servicename in the
sqlhosts file. This situation might occur because the network port is
already in use by another sqlexecd, database server, or other
application. Use a different servicename on the command line (prior to
Version 6.0) or in the sqlhosts file (beginning with Version 6.0).
Contact your system administrator for assistance.
/usr/include/sys/errno.h
#define EADDRNOTAVAIL 68 /* Can't assign requested address */
Could be an NIS problem or maybe an /etc/services vs. sqlhosts mismatch.
Also check /etc/netsvc.conf to determine name resolution order
(hosts=local,nis works for us.)
In /usr/informix/etc/sqlhosts you could use the service number(s) and IP
address instead of allowing the OS resolve them.
oninit -v may provide other hints.
FYI: You can fix that annoying DBSPACETEMP error by exporting the
DBSPACETEMP environment variable to the correct dbspace before
starting oninit.
Wolfgang Brandl wrote:
> After starting Informix Version 7.23.UC1 with oninit no daemon is
> running and i get the following error in online.log:
>
> **************************
> /usr/informix> pg online.log
> 19:21:42 VP pid=11876 priority fixed at 65, former = 93>
> Fri Jan 26 19:21:46 2001
>
> 19:21:46 Event alarms enabled. ALARMPROG =
> '/usr/informix/etc/log_full.sh'
> 19:21:48 DR: DRAUTO is 0 (Off)
> 19:21:48 AIX MP latch code enabled
> 19:21:48 listener-thread: err = -25572: Network driver cannot bind a> name to th
> e port.
> System error = 68.
> 19:21:48 Attempting to bring listener thread down
>
> 19:21:48 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 19:21:48 Warning: Invalid dbspace 'infs010' listed in DBSPACETEMP.
> 19:21:48 Physical Recovery Started.
> 19:21:48 Physical Recovery Complete: 0 Pages Restored.
> 19:21:48 Logical Recovery Started.
> 19:21:48 PANIC: Attempting to bring system down
> **************************************************>
> Can someone tell what the erro can be. This installation was running for
> over two years without change.
> Can it be some network depending change like new DNS server etc.?
> Wolfgang
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts