RE: ISAM Error -136
Posted in 2000
Looks like you found the issue. 3 bytes are dedicated to logical pages in a tablespace 256^3 is the number of logical pages a tablespace can have. 256^3=16777216 your extents 15*1047776 + 1015033 + 45542 = 16777215 16777216 - 16777215 = 1 I guess you need to be fragmenting your index... Will >===== Original Message From "Rob Burba" <bburba@earthlink.net> ===== >OK, Here is what I have found so far. > >The table extents seem to be working fine; however, the problem may be with >the index. The table is fragmented across 8 dbspaces, but the index is >detached in a single dbspace. Here is what I find in the >sysmaster:sysextents table for the index > >dbsname tabname start size > >dbsname prim_constr 2097205 1047776 >dbsname prim_constr 3145731 1047776 >dbsname prim_constr 11534339 1047776 >dbsname prim_constr 12582915 1047776 >dbsname prim_constr 31457283 1047776 >dbsname prim_constr 32505859 1047776 >dbsname prim_constr 33554435 1047776 >dbsname prim_constr 34603011 1047776 >dbsname prim_constr 35651587 1047776 >dbsname prim_constr 36700163 1047776 >dbsname prim_constr 37748739 1047776 >dbsname prim_constr 38797315 1047776 >dbsname prim_constr 39845891 1047776 >dbsname prim_constr 40894467 1047776 >dbsname prim_constr 41943043 1047776 >dbsname prim_constr 42991619 1015033 >dbsname prim_constr 44040195 45542 > >I have isolated a record that fails the insert and it always fails with >a -271 informix error and ISAM error -136. We think we may have hit the >maximum pages per fragment (which is a possible cause of the error), but I'm >not sure how to verify that. > >Art S. Kagel <kagel@bloomberg.net> wrote in message >news:392C435D.6E3B0508@bloomberg.net... >> Rob Burba wrote: >> > >> > Version 7.31.UC4 >> > Sun 5000 >> > Solaris 2.6 >> > >> > Error indicates that engine is having problems creating new extent on >table. >> > >> > Table is fragmented across 8 dbspaces and has 1-3 extents per dbspace >> > >> > Has anybody else run into this problem? >> >> There was a thread on this a week or two ago look back in the IIUG >Archives >> of CDI. Basically a table with many variable length columns (VARCHAR, >TEXT, >> etc) can have fewer extents than a table with fewer such columns or none >> since the extent records and descriptions of variable length columns must >> share the same fixed location on disk. >> >> Art S. Kagel >> ------------------------------------------------------------ This e-mail has been sent to you courtesy of OperaMail, as a free service from Opera Software, makers of the award-winning Web Browser, Opera. Visit us at http://www.opera.com/ or our portal at: http://www.myopera.com/ Your free e-mail account is waiting at: http://www.operamail.com/ ------------------------------------------------------------