Threads from 2025
Browse by month: Jan · Feb · Mar · Apr · May · Jun · Jul · Aug · Sep · Oct · Nov · Dec
Rootdbs initially in a large chunk
Hi again Family. I want to create a totally new instance and start the rootdbs at 20GB, rather than the old (pre IDS-10) default max chunk size of 2GB. I don't have the new machine yet so I can't try it myself. Is this doable or will that first oninit -i barf at that large first…
Update to myexport
I have just uploaded an update to the myexport package that includes a new option, -g <table list> which implements the equivalent of the dbexport option -no-data-tables=<table list> to specify tables that are to be exported as DDL only by no data unload. As usual, you can downlo…
What is the load on an individual listener or sqlexec thread?
(Deep breath ;-) Greetings, Family. I can see if a specific thread is getting used lot: Just run onstat -g cpu: Thread CPU Info: tid name vp Last Run CPU Time #scheds status 2 lio vp 0 3lio* 12/30 03:36:02 0.0000 …
REMOTE_SERVER_CFG issue/question
All, I tried posting this via the web, but every time I click on the "Post" link, I get a pop-up stating: Access Denied You don't have permission to access "http://community.ibm.com/higherlogic/ui/mvc/contributedcontent/contributedcontent/createQuestion" on this server. Reference…
How to alter a table become a read only one?
Hi, The develop DBA want to change some tables to read only , include the DBA himself can't update/insert/delete those record also. Do anyone have experience how to implement it in informix? The document told me "You cannot revoke privileges from yourself." Any suggestion are we…
Need help for Usage of "UTL_FILE_GET_LINE"
Hello, When I use UTL_FILE_GET_LINE I always get the error: (EXC04) - Message cannot be found. Version 15.0.0.2 on Ubuntu. Trace shows, that the file is open: execute function informix.utl_file_is_open[procid=613] ( arg[0] = 0 ) expression: (select (<procedure> utl_file_is_open, …
ESQL/C DESCRIBE OUTPUT after OPEN (with DECLARE CURSOR name) fails with -410
Hello, With ESQL/C 4.50.FC10 (Linux Debian 12): I am trying to use the DESCRIBE OUTPUT instruction to get column information of a SELECT, after the PREPARE / DECLARE CURSOR / OPEN sequence. The idea here is to postpone the DESCRIBE OUTPUT after the OPEN, to potentially use the IF…
bson_update with special characters crashes session
Hi all! Following bson_update leads to a failure: # dbaccess charly - Database selected. > create table z_bson_test (b bson); Table created. > insert into z_bson_test values ('{"field1":"Nom","field2":"Chatelain"}'::json::bson); 1 row(s) inserted. > select b::JSON from z_bson_tes…
InformixHQ: In Performance/Sessions section: filter by "NOT informix"
In the aforementioned section of InformixHQ I can look for sessions owned by user "joe". I can do the same with onstat -g ses | grep joe . But in that same grep command I can also say: onstat -g ses | grep -v informix if I want to see all but informix sessions. What is the syntax…
Informix 15.0.0.2: Aggregate function group_concat now built-in created but the underlying functions are not.
Hi, we are currently testing Informix Server 15.0.0.2. On a fresh initialized DB (with oninit -i...) the group_concat() aggregate function is now built in. Which would be great. Additional info: In Informix 14 we had our own implementation of group_concat() based on community/doc…
Corrupted 4DB installation files on Fixcentral for AIX
Hello, It seem that these binaries are corrupted, as signature verification fails: Verfication of ISQL is oK openssl dgst -sha256 -verify informix.pem.pub.key -signature ibm.sql.7.51.FC4.AIX.64.ppc64.tar.cosign.sig ibm.sql.7.51.FC4.AIX.64.ppc64.tar Verified OK But verification of…
DBD::Informix - Cannot unset AutoCommit for unlogged databases
Hi, Trying to use DBD::Informix. Oracle Linux Server 8.10 Perl v5.26.3 DBI 1.641-4 DBD::Informix 2018.1031 CSDK 4.50.FC5 Informix Dynamic Server 11.70.FC5XE When I execute $dbh_bl->{AutoCommit} = 0; Perl aborts with the above message, DBD::Informix - Cannot unset AutoCommit for u…
Informix version 15.0.0.2 is out!
Hi, Informix version 15.0.0.2 is out! https://www.ibm.com/docs/en/informix-servers/15.0.0?topic=overview-whats-new-in-informix Looks like the only change is adding support for "AlmaLinux release 8.10 (Cerulean Leopard) on aarch64 compatible processors (ARMv8)". https://www.ibm.co…
Informix Systmaster presentation at the IBM TechXchange 2025
Folks, I will be presenting my latest Informix Systmaster presentation at the IBM TechXchange 2025 IBM TechXchange 2025: Managing and Optimizing the IBM Informix Server using the Sysmaster Database by Lester Knutsen Session ID 1325, Date: Tuesday, October 7, 2025 Description: Les…
External backups/restores and logical restoring of logs passed last Level-0 backup
Hi, We are considering doing disk snap-shots with external backups which are very fast, and still continue doing daily onbar level-0 and, of course, keep doing onbar logical log backups. One doubt we had, and could not find clear doc about this, is if it is possible to restore an…
Purge informix log file
Hi Experts, Our informix log file (which outputs from onstat -m or MSGPATH parameter in onconfig) isn't purged since years &7 has grown in size. Please help how to purge this file & does this requires shutdown. Any risk to DB if done in improper way? Thanks in advance Syed H ---…
C UDR using mi_trigger_get_old_row() and mi_trigger_get_new_row()
I suspect you are getting a NULL rather that a valid row ptr, I believe it will be NULL cos you are in a SPL An MI_ROW pointer A pointer to the old row. NULL The function was one of the following: not successful. not in the trigger action. not in the FOR EACH row trigger. n…
Any concern if use JDBC 15 to connect with IDS 14.10.FC10W2?
Could I ask for advice if any concern to use JDBC version 15 with IDS 14.10.FC10W2? Would there be any back-compatiblity concern? Could we hit some performance issue if use this higher version of JDBC driver? Where could we get information from, regarding the difference between J…
Need advice on preparation work before upgrading to IDS 15.0.0.1
Hi community, May I ask for your opinion and advice on preparations before upgrading IDS from 14.10 to 15.0.0.1? Thank you! So far, I've noted the followings are to be done prior to the upgrade: Check for outstanding IPA tables and settle them Arrage a full DB backup, in case req…
Ontape restore with differenct Db Chunk spaces
Hi all, hopefully this is an easy one for you all, but getting a straight answer at our end is eluding us. Periodically, we do a Live to Test restore of a level 0 backup. We are using ontape for the backup and restore. We've recently had a situation where the DB chunk names and s…
What does onstat header look like if there is blocking checkpoint in progress
This is a companion question to "how long has a transaction been running?" I have not encountered a blocking checkpoint indication in an onstat header in many years. If I run an onstat command every second in a script, piping to grep, what the header line look like so that I can…
How long has a transaction or query been running?
Hi Family. I've been quiet for too long so I'll make for that with two threads. How to tell if there is blocking transaction at the moment. This will be the subject of my next thread. How long has a transaction been running? And how long as a current query been running? That is…
oncheck warning,What impact will it have on the future?
Hi, expert: The customer restore the instance into another machine ,and run oncheck on the whole database, it report below errors . but I can't see those errors in the production environment. TBLspace data check for gapsdb:gaps.beps_fft_qydjb WARNING: data page 0xb240 in tablespa…
Informix CDC API - Is there a way to pull the change record using .NET?
Hi, I'm trying to work with the Informix CDC API using the Informix .NET provider, but I haven't been able to find any sample code, and the documentation has been difficult to follow. I've put together the following code sample, but it doesn't seem to be retrieving any change rec…
InformixHQ 3
You may have seen this: www.ibm.com/support/pages/node/7240777 Security Bulletin: Informix HQ is vulnerable to HTML injection and does not lock out users after multiple incorrect password attempts 28 Jul 2025 The latest version 3.1.0 is described here: www.ibm.com/docs/en/informi…
Getting Perl module DBD::Informix off the ground
I will likely post this on the mailing list dbi-users@perl.org but at this time I don't know if that list still being supported. So I post here first, for that rarified special group of DBD::Informix users. I got my management to allow me to download DBD::Informix on one of our h…
Informix update
Hello I've been out of Informix for a long time it is a productive environment I have to update "Informix Enterprise Edition 14.10.FC8" to "14.10.FC11" Am I right that I am in the PassportAdvantage under "IBM Informix Enterprise Edition 14.10.FC11 Multiplatform English eAssembly …
LOG FILES
Hello everyone. Previously, I checked that in some cases the log files were filling up, and this was causing errors at some point. So we decided to increase the number of log files as well as their size. Today we had a problem because they filled up, and the log manager remained …
C4GL 7.51.FC4 ships *15a .so libraries and non-15a .so libraries that are in fact identical
Hello, After installing Informix 4GL 7.51.FC4, I see several (older) *.so libs that have the same content then new *15a.so libs. $ md5sum DEV-7.51.FC4/lib/esql/libifsql*so 5e08b67a797bfd6faed87320a360714b DEV-7.51.FC4/lib/esql/libifsql15a.so 5e08b67a797bfd6faed87320a360714b DEV…
Informix 43258 error onbar logical restore
Hello All. I ran onbar -r -p to restore the database which rab successfully. But after running onbar -r -l (Logical Restore) I got 43258 and 43168 error. Please let me know how to overcome from this issue and run the restore successfully. current Informix and OS version: Online.l…
Extending chunk capacity
Hi, in a 24x7 Informix v14.10, x86 SuSE linux instance with 2KB and 16K dbspaces and smart-blobspaces, with +250 chunks, we neede to grow the disk capacity and we are considering the option of extend chunk capacity instead of adding new chunks. We have successfully tested the fol…
Oninit engine won't start: log staging directory is not secure
Hi Y'all. Interesting (i.e.. frustrating as all blazes) problem I have trying to start up on a bug-fix copy of oninit. I start up oninit and it dies right away with the error message: Secondary Delay or Stop Apply: The log staging directory (/usr/informix/< subdir >log_staging_di…
Selecting rows where tuple in condition
Hi, Using Informix v14.10, we want to select rows from a table using syntax similar to what other sql engines can do: SELECT * FROM mytable WHERE (group_id, group_type) IN ( ('1234-567', 2), ('4321-765', 3), ('1111-222', 5) ); SELECT * FROM mytable WHERE (group_id, group_type) IN…
Cast a datetime to character in default clause
Hi Y'all. (English REALLY needs a plural "you"!) I have a situation where a commercial software package goes bananas with datetime data types. But it is happy to work with a time stamp if it is character data type. I have been tasked with adding a few columns to a table. I am tr…
BSON with Informix 15.0
Hi, I'm testing BSON on Informix 15. I have the following table: create table brev ( seq serial not null , data "informix".bson ) PUT data in ( sbspace1 ) extent size 10000 next size 10000 lock mode row ; This is an example of one row: rseq 824 rdata {"_id":ObjectId("683f199109fe…
Informix with Hibernate 6.X anyone?
Since Hibernate 6, the InformixDialect class file has been moved out of Hibernate core to the community provided content. Are there anyone with experience in the combination of Hibernate and Informix here? Have you modified or adapted the InformixDialect class? We are having some…
Query using temp table is much faster then join/subquery
I have problem with query (duration 40s), when I use temp table is much faster (<2s). Can I do anything to improve query? Using temporary tables is cumbersome. Here is sqexplain, first for regular query, second with temp table: QUERY: (OPTIMIZATION TIMESTAMP: 05-30-2025 09:38:28)…
is there a rowsize function in SQL similar to rowid?
This should be a quickie: Yes or no. And I'd classify it as low priority. We can always select rowid for an individual row. I was curious, though I could not easily find it with google: Can I do this in SQL? select rowsize, rowid, < some real columns > from <table> In a table wi…
What triggers a blocking checkpoint?
Hi Y'all family. In the system under my purvey, checkpoints occur very often, almost always duration is on the order of 1/10 of a second. However (Bet'cha I telegraphed that coming :-), a couple of times a day, there is a blocking checkpoint that temporarily blocks all applicati…
Informix 14.10xc8 crash
Hello, Anybody has facing this situation ? 20:14:49 20:14:49 IBM Informix Dynamic Server Version 14.10.FC8AEE 20:14:49 Assert Failed: VARLEN SORT - compressed row len 32754 > srt_rowsize 3870 20:14:49 Who: Session(******************, 1336024, 0x4c0a6b28) Thread(673511, sqlexe…
Extended Support
Hello Experts, Now that IBM has announced EOS for IDS 12.10, does the 1st year extended support requires additional payment in case any P1 ticket is opened? or does the support come under normal annual support maintenance without additional payment. Thanks in advance Syed H -----…
raw disk support deprecated in RHEL 9.x
I have been informed by my RH sysadm that support for raw disk has been deprecated in RHEL 9.x (specifically RH 9.5). He says that they have gone so far as to remove all information from the man pages. As we currently have our Informix instances on raw disks, I wanted to see whe…
Informix Language Supplement" (ILS) 3.50.MC7
Hello, I am new to informix community. I installed Informix 12.10 and 14.10 on a few machines. Working it out slowly. I hit a problem on Linux(both Ubuntu 22.04 and RedHat 7.9), Informix 12.10. I am trying to get support for bg_bg.8859-5. On Windows 2016 all works like charm and…
Column ti_flags in systabinfo
Man! This guy just keeps going!! <grin> About 9 years ago I wrote a perl module (FragmentList.pm) to consolidate information about data and index partitions. I may even have posted it as part of a contribution to the IIUG Software Repository. That aside: In that module I have t…
Informix V15 in Production
Hello all, Has anybody migrated to or has Informix V15 in production ? Thanks -- Cordialement, Regards, Khaled Bentebal Directeur Général - ConsultiX Tél: 33 (0) 1 39 12 18 00 Mobile: 33 (0) 6 07 78 41 97 Email: khaled.bentebal@consult-ix.fr Site Web: www.consult-ix.fr…
Cannot connect to Informix database via Python
I am trying to modify an existing Python script that has run in a customer environment, but fails to connect in any of my local environments: Windows, Ubuntu or CentOS. They all return essentially the same error using packages SQLAlchemy, ibm_db of IfxPy: Exception: [IBM][CLI Dri…
future support of UTF-8 character handling
Hello Informix community, the fact that the current implementation of UTF-8 in the Informix database is not optimal and difficult to handle is probably known to everyone who has ever dealt with this topic. Before I submit an RFE, I would like to know the opinions of other members…
Table dual is not in the database
I may be going mad here: This worked yesterday (unless I dreamed it): select current year to month as this_month, current year to month - interval(1) month to month as last_month from dual; As it happens, I was in a sysmaster database but that's hardly important. Today I get thi…
Onlog columns documentation
(Since my previous 2 posts on the serial columns failed to post, I wonder about this one.) Hi Family. Is there any coherent and correct documentation on the columns in the output of onlog? The HCL pages I've found have on OK start for the 6-column record header but seem to be wr…
Announcing the passing of Stuart Litel
Stuart. J. Litel passed away on April 19, 2025 at his home in Waban, Massachusetts. Stu was the beloved son of the late Joseph and Barbara E. (Sulkin) Litel of Newton, Massachusetts. Robin Chapman was his loving domestic partner for 20 years in Waban. He was a dear nephew to Barr…
Informix 11.50.FC9W3 assert failed question
Hi, I use Informix 11.50.FC9W3 , it's the newest version on 11.50 . today the RSS SERVER is abnormal terminated. blow are some information from online.log and af file. 1) online.log 00:06:51 Maximum server connections 65 00:06:51 Checkpoint Statistics - Avg. Txn Block Time 0.00…
#Instalador Informix 4GL
Buen día. Recién estoy aprendiendo a programar en Informix 4GL. Logré instalar Informix Developer Edition para el servidor de base de datos, pero no he podido probar código en 4GL porque no encuentro un instalador. Alguien me podría ayudar por favor?. Gracias de antemano --------…
Quickie question on serial and bigserial data types
Hi y'all. This is a quick question. I have determined that for a serial column, the coltype in syscolumns is an integer: 262. We have not loaded ak_utils here so I can't check the code to see what the coltype value is for bigserial column. At this time we are not yet using bigse…
onbar is rejecting my date for point-in-time restore
Hi Family. I'm having enough frustration getting cross-system restore to work. But this is SO frustrating: With my entire environment set up by a script that has been working for years, I made the modification: /usr/informix/bin/onbar_d -r -p -w -t "2023-11-30 05:00:00" And it's …
informix 15 esql in conjunction with latest AIX compiler generation
Dear community! In the Machine Notes for my Installation is noted that: 1. This product was built on AIX 7.2 Technology using the following compilers: IBM XL C/C++ for AIX, V16.1.0 (5725-C72, 5765-J12) XL C/C++ Runtime 16.1.0.10 That is quite ok for me, but when it comes t…
Error: INFORMIXDIR /home/informix is not owned by group
Hi, OS: NAME="SLES" VERSION="15-SP5" VERSION_ID="15.5" PRETTY_NAME="SUSE Linux Enterprise Server 15 SP5" ID="sles" ID_LIKE="suse" ANSI_COLOR="0;32" CPE_NAME="cpe:/o:suse:sles:15:sp5" Informix: ibm.server.15.0.0.1.Linux.64.x86_64.tar Issue: Where we run any command [oninit, onclea…
Informix V15 and watsonx.ai
Hello all, Has anybody used Informix v15.0 with watsonx.ai or is planning to use it in a real project -- Cordialement, Regards, Khaled Bentebal Directeur Général - ConsultiX Tél: 33 (0) 1 39 12 18 00 Mobile: 33 (0) 6 07 78 41 97 Email: khaled.bentebal@consult-ix.fr Site Web: www…
Automated Update Statistics and FORCE
Hi everyone. AUS seems to append FORCE to all UPDATE STATISTICS statements saved in sysadmin:aus_command.aus_cmd_exe on some systems and not others. Why is that so, and how can it be enabled or disabled? We have a site where an exceptional table is excluded by altering STATCHANGE…
Perl-like string manipulation in SPL?
Hi again, Family. I am rereading up on SPL (which I have not touched in nearly 30 years - and the times, they are a-changin'!) because I found a user request for an interesting constraint on a column in a table. It must look like an email address i.e. yodel@spaceballs.org . (or m…
ROWID 8 BYTES
Hello everyone Recently, as you may know, version 15 of IDS was released. I was running some tests, and among the issues that arose was the use of the ROWID by clients, especially from C# and/or ODBC. It turns out that when I include the line in the SELECT statement, it doesn't s…
Munich Tech Day, Informix Roadmap and Informix Newsletter
Hi, Any update on the slides from the Munich Tech Days? Is there an updated roadmap for Informix now that V15 is out? When if the first fixpack for V15 due? Is there an English version of these ? https://iug.de/informix-newsletter/ Regards, David. ------------------------------ D…
Columns in ixbar file
As threatened er, promised in another thread, I am reviving a question posed in 2013 or so on comp.databases.informix: Does anyone know a query on sysutils that would recreate the ixbar file ? Sadly, only 2 people responded and neither had an answer. I did find a page that purp…
Data or date-time columns in oncfg_(servername).(servernum)
Hi Family. Working toward my better knowledge of onbar, I'm writing a Perl script to sort the DBspaces and logs sections of the oncfg file in more sensible ways. (I have yet to determine if my new employer will permit me to post it where y'all can get it.) My source of informat…
New Informix RFE
Please vote for the new RFE I entered. INFX-I-663 Add a session setting to make an index invisible just for the current session and one to reverse that setting. ------------------------------ Art S. Kagel, President and Principal Consultant ASK Database Management Corp. www.askdb…
Onbar: Failed to determine archive's encryption mode. Error code 2
My thanks to the group, especially Mike Walker, for your help in getting that blessed onbar restore going successfully. Now I have a variation on that issue but it calls for a new thread. I have it working NOW but I'm just hoping for an explanation of a screwy rabbit error in a f…
How to verify all the requirements for an onbar restore
Hi Family. I've been mostly quiet on this group because my gigs of late have been Perl with little to no Informix. That has now changed. (YAY!) I have little to no experience with onbar. I performed some backups by rote and used archecker to get back a table my client had inadve…
Verify my login to IIUG Community via text to mobile phone
Hi Family. This question is not specifically about Informix though I have a doozy of a question to compose at work. Here's the problem: I can log in to the Informix community http://www.iiug.org/community with my email address. As it is set up, it sends a verification code to t…
Informix Technology Days 2025 in Munich on March 12 and 13
The Informix Technology Days in Munich will be taking place again this year . You can find details below, including the link to register. You are also welcome to forward this invitation to anyone interested in this event.. I would be delighted if we could welcome you there this y…
Informix 4GL to Aubit4gl migration
Hi, We have a huge Informix 4GL-based project, RDS on SPARC Solaris. Our goal is to migrate it to x86 Linux. A problem with Aubit4gl is that it does not have same scripts as I4GL that we use. Does anybody have an experience of porting a large I4GL project to Aubit4gl? -----------…
Art's myschema/myexport utilities on the AIX platform
I would like to ask if there is anyone who is actively using Art's myschema/myexport utilities https://www.askdbmgt.com/my-utilities.html on the AIX platform? ------------------------------ Antonin Rozehnal ------------------------------…
Informix 12.10 vs Informix 14.10 Performance Differences
Our company has (finally) begun an upgrade from Informix 12 to Informix 14, the version that we are trying to certify for our ERP software. We managed to migrate the 12.10FC14 instance to 14.10FC11 on an AIX 7.3 O/S platform. All went well and we have the instance up and running.…
An accurate timestamp in a stored procedure
Hi All, the background to this challenge is a repetitively used stored procedure that usually take no longer than 5 seconds each execution. Unfortunately, it is run thousands of times and so every millisecond I can drop off the SP execution time will help. So the plan of attack w…
Can we get the same output as onstat -g spa from SQL queries against sysmaster
Hello community, does anybody tried to get the same or similar output as an SQL query from sysmaster? Thanks a lot Milan Rafaj Unless stated otherwise above: Kyndryl Česká republika, spol. s r. o. Sídlo: V Parku 2308/8, Chodov, 148 00 Praha 4, IČ: 096 28 886 Zapsaná v obchodním r…
GSKit Changes With 14.10FC10W1 - FC11
As a note that I don't think was well documented, when going to the newer versions of Informix with the newer releases of GSKit (8.0.55 or 8.0.60) the old -type cms keystores no longer work for servers. If you set one up using -type cms you can bring the engine online, however if…
Who needs a HOME?
Just saying ... OpenSuse ... letting the 14.10.FC11W1 installer create the user informix ... and no $HOME is directory is created. ------------------------------ Jon Ritson ------------------------------…
Resync RSS server
Hello I need to re-initiate synchronization between a primary server and the RSS. They re currently connected, active prim :/prod/dbown>onstat -g cluster ... Server ACKed Log Applied Log Supports Status (log, page) (log, page) Updates ids_tlv_rss 0,0 0,0 No ASYNC(RSS), Connected,…
HTML Email in AIX2.7 environment
Hi - We have a AIX 2.7 environment in which we wanted to send HTML emails so that the emails can have tables and styles as per customer needs. We are using SendMail tool to send the email which is working for a plan text email. Can anyone advice if HTML formatting is possible wit…
RSS slowing down
Hi, IBM Informix Dynamic Server Version 11.70.FC5XE Today we have a RSS replication slowed down. I mean not froze but just applying logs slower than the primary filling them. That has not happened ever in working hours. Filling pace was not any unusual for the time. After restart…
Segfault since CSDK 4.50.FC10 with LVARCHAR and CLIENT_LOCALE different from DB_LOCALE
Hello! Starting with CSDK 4.50.FC10 (we cannot reproduce with 4.50.FC9W1), With DB_LOCALE=en_us.8859-15 and CLIENT_LOCALE=en_us.utf8, LC_ALL=en_US.utf8, Fetching an LVARCHAR with auto-allocation API using ifx_var_flag(ptr,1), we get a segfault when fetching. THE PROBLEM DOES NOT …
Hyperswap and Flashcopy
Hello, i have two FS5200 configured in Hyperswap. Now the first FS5200 (FS5200A) is temporarely out of service do to a fire in the sita A. Each hyperswap volume was also flash copied regularly to target volumes residing in a pool of FS5200A To fix that , a have configured new tar…
Informix Client download
Happy New to All. Please let me know how can I download Informix clients (4GL, 4DS, SQL etc) for Non licensed version. I wantto download these clients for IDS 12.10 and IDS 14.10 for my own use. I can't find in Fix central. Kindly help. Thanks Amit Patel -------------------------…
Recently appended logged partitions
Hello all and wish you happy new year. Is it possible to list tables/partitions for which (fake) level0 backup must be run to allow writing to it? There is a flag with value 32768 in sysptnhdr but this flag is on even after L0 backup is finished. Thank you Milan Rafaj Senior Lead…
Informix 15 CSDK compatibility indicator
Hello, Since Informix 15 CSDK introduced changes for example in the sqlca definition, I was wondering if there is some way to distinguish at compile time when an ESQL/C compiler V15 or V4.50 is used, so we can maintain the same .ec source code for different versions of ESQL/C. I …
Informix 15 server / CSDK compatibility matrix
Hello, Simple questions: Can I use a CSDK 4.50.* to connect to an Informix 15 server? Can I use a CSDK 15 to connect to an Informix 14 server? Is there some compatibility matrix available? I have just face the following: 1) With CSDK 15 connected to Informix 15 server: CREATE TAB…
Where to report bugs for Informix 15
Hello, Sorry it's unclear to me where I should report bugs... (we found one with HCL Informix 15 CSDK) On https://support.hcl-software.com , I can't find "HCL Informix" in the product list... only OneDB ... We detected a defect in the ESQL/C libs when using a CONNECT TO with USER…
Informix Client SDK 4.10.TC16 Windows 64 only installing as 32 bit
I downloaded Informix Client SDK 4.10.TC16 Windows 64 from the IBM downloads site. I am trying to run this driver with an application that runs on 64 bit. It is installing as a 32 bit, and I cannot figure out what I am doing wrong. I download the file then run the clientsdk insta…
ESQL/C conversion error with CLVCHARPTRTYPE
Hello, Once I reported an issue with ESQL/C charset conversion when using the CLVCHARPTRTYPE type: https://ibm-data-and-ai.ideas.ibm.com/ideas/INFX-I-400 Sorry but I have no bug or feature ID, I am totally confused with HCL/Actian/IBM forums and support channels, so I don't know …