Sometimes on Win2000, when I stop the IDS, it will not restart with a
reboot.
The message in the log says:
13:48:06 IBM Informix Dynamic Server Version 9.40.TC2
13:48:06 listener-thread: err = -25572: oserr = 48: errstr = : Networkdriver cannot bind a name to the port.
System error = 48.
13:48:06 sql_listener: ASF_LISTEN failed
13:48:06 Attempting to bring listener thread down.
13:48:06 Server stopped.
Is there a way to bring the IDS back up without a reboot?
sending to informix-list
↪ replying to Bill Hamilton
Normally this is caused by the engine crashing and informix
failing to tidy up. You could try stopping and starting the network
on the card, that might sort it.
When it fails to start, run netstat -a, you should not see a FIN_WAIT2
on the informix port, if you are then the network bind as not been made
correctly - this is a coding problem, either informix (not very likely
due to problems with this in the past) or windows (likely 'cos it's
crap)
Cheers
Paul
Bill Hamilton wrote:
>
> Sometimes on Win2000, when I stop the IDS, it will not restart with a
> reboot.
> The message in the log says:
>
> 13:48:06 IBM Informix Dynamic Server Version 9.40.TC2
> 13:48:06 listener-thread: err = -25572: oserr = 48: errstr = : Network> driver cannot bind a name to the port.
> System error = 48.
> 13:48:06 sql_listener: ASF_LISTEN failed
>
> 13:48:06 Attempting to bring listener thread down.
> 13:48:06 Server stopped.>
> Is there a way to bring the IDS back up without a reboot?
>
> sending to informix-list
--
Paul Watson #
Oninit Ltd # Growing old is mandatory
Tel: +44 1436 672201 # Growing up is optional
Fax: +44 1436 678693 #
Mob: +44 7818 003457 #
www.oninit.com #