Re: Startup Script Error
Posted in 1998
>BEATRIZ ROCHA wrote:
>>
>> I am setting up the startup scripts for the Informix Online Dynamic server,
>> and I am getting an error (copy of error below), and then the Online starts
>> up fine. I just have not been able to find out why is the error occurring.
>> Any help will be greatly appreciated.
>>
>> Platform: HP-UX 10.20
>> Running Informix Online Dynamic Server 7.2
>>
>> I place the startup script in the rc2.d directory (it is really in the
>> /sbin/init.d directory with a soft link to the rc2.d directory). I named
>> the script so it is the last one executed in the rc2.d directory
>> (S910online_start).
>>
>> This is a copy of the log file when I reboot the machine:
>>
>> 09:23:56 INFORMIX-OnLine Stopped.>>
>> Tue Sep 29 09:33:32 1998
>>
>> 09:33:32 Event alarms enabled. ALARMPROG = '/usr/informix/log_full.sh'
>> 09:33:33 DR: DRAUTO is 0 (Off)
>> 09:33:34 listener-thread: err = -25572: Network driver cannot bind a name>> to the port.
>> System error = 227.
>> 09:33:34 Attempting to bring listener thread down
>>
>> 09:33:34 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
>> 09:33:34 Physical Recovery Started.
>> 09:33:34 Physical Recovery Complete: 0 Pages Restored.
>> 09:33:34 Logical Recovery Started.
>> 09:33:35 invoke_alarm(): /bin/sh -c '/usr/informix/log_full.sh 5 6>> "Internal Subsystem failure: 'MT'" "Attempting to bring listener thread
>> down
>> " '
>> 09:33:35 invoke_alarm(): mt_exec failed, status -1, errno 0
>> 09:33:35 PANIC: Attempting to bring system down>>
>> Tue Sep 29 09:36:03 1998
>>
>> 09:36:03 Event alarms enabled. ALARMPROG = '/usr/informix/log_full.sh'
>> 09:36:04 DR: DRAUTO is 0 (Off)
>> 09:36:04 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
>> 09:36:04 Physical Recovery Started.
>> 09:36:04 Physical Recovery Complete: 0 Pages Restored.
>> 09:36:04 Logical Recovery Started.
>> 09:36:07 Logical Recovery Complete.>> 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>>
>> 09:36:07 Dataskip is now OFF for all dbspaces
>> 09:36:08 On-Line Mode
>> 09:36:08 Checkpoint Completed: duration was 0 seconds.>>
>> Does any one has an Idea of what can it be? I also tried to move the start
>> up script to be the last one to execute in the rc3.d directory (after the
>> NFS has been started), and I got the same error
>>
>> THANK YOU VERY MUCH
Check with "netstat -na" that the TCP port used by your server
(look for it in sqlhosts file) is free. This error usually happenes
when there are other applications listening/connected to the TCP port
configured for your Informix server. The most simple thing is changing
the service name in $INFORMIXDIR/etc/sqlhosts and the port number
in /etc/services (you could make just the last change).
Best Regards,
Octav
--
Octav Chiriac Phone: (373) 2 21 20 96
NetInfo S.R.L. Fax: (373) 2 21 36 59
Chisinau (373) 2 24 00 83
Moldova, Republic of mailto:com@netinfo-moldova.com