Re: Startup Script Error
Posted in 1998
BEATRIZ ROCHA wrote:
>
> I am setting up the startup scripts for the Informix Online Dynamic server,
> and I am getting an error (copy of error below), and then the Online starts
> up fine. I just have not been able to find out why is the error occurring.
> Any help will be greatly appreciated.
>
> Platform: HP-UX 10.20
> Running Informix Online Dynamic Server 7.2
>
> I place the startup script in the rc2.d directory (it is really in the
> /sbin/init.d directory with a soft link to the rc2.d directory). I named
> the script so it is the last one executed in the rc2.d directory
> (S910online_start).
>
> This is a copy of the log file when I reboot the machine:
>
> 09:23:56 INFORMIX-OnLine Stopped.>
> Tue Sep 29 09:33:32 1998
>
> 09:33:32 Event alarms enabled. ALARMPROG = '/usr/informix/log_full.sh'
> 09:33:33 DR: DRAUTO is 0 (Off)
> 09:33:34 listener-thread: err = -25572: Network driver cannot bind a name> to the port.
> System error = 227.
> 09:33:34 Attempting to bring listener thread down
>
> 09:33:34 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 09:33:34 Physical Recovery Started.
> 09:33:34 Physical Recovery Complete: 0 Pages Restored.
> 09:33:34 Logical Recovery Started.
> 09:33:35 invoke_alarm(): /bin/sh -c '/usr/informix/log_full.sh 5 6> "Internal Subsystem failure: 'MT'" "Attempting to bring listener thread
> down
> " '
> 09:33:35 invoke_alarm(): mt_exec failed, status -1, errno 0
> 09:33:35 PANIC: Attempting to bring system down>
> Tue Sep 29 09:36:03 1998
>
> 09:36:03 Event alarms enabled. ALARMPROG = '/usr/informix/log_full.sh'
> 09:36:04 DR: DRAUTO is 0 (Off)
> 09:36:04 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 09:36:04 Physical Recovery Started.
> 09:36:04 Physical Recovery Complete: 0 Pages Restored.
> 09:36:04 Logical Recovery Started.
> 09:36:07 Logical Recovery Complete.> 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 09:36:07 Dataskip is now OFF for all dbspaces
> 09:36:08 On-Line Mode
> 09:36:08 Checkpoint Completed: duration was 0 seconds.>
> Does any one has an Idea of what can it be? I also tried to move the start
> up script to be the last one to execute in the rc3.d directory (after the
> NFS has been started), and I got the same error
>
> THANK YOU VERY MUCH
More importantly, did you write an rc script to shutdown IDS? It looks
like IDS effectively 'crashed' and you need to clear the contents of
your /INFORMIXTMP directory.
Hope that helps,
--
Mark.
+----------------------------------------------------------+-----------+
|Mark D. Stock - Informix SA http://www.informix.com |//////// /|
|mailto:mdstock@informix.com http://www.informix.com/idn |///// / //|
|http://www.iiug.org +-----------------------------------+//// / ///|
| Tel: +27 11 807 0313 |If it's slow, the users complain. |/// / ////|
| Fax: +27 11 807 2594 |If it's fast, the users keep quiet.|// / /////|
|Cell: +27 83 250 2325 |Therefore, "No news: travels fast"!|/ ////////|
+----------------------+-----------------------------------+-----------+