Network driver cannot bind a name to the port!
Posted in 2003
Topics: General Discussion
Hi all, when i tried to startup the IDS server, the following messages show in "online.log", i am sure that the network port is not in use, can somebody help? My OS is RedHat 9.0 and IDS is 9.4, thanks. 01:53:08 Event alarms enabled. ALARMPROG = '/opt/informix/LE/etc/alarmprogram.sh' 01:53:08 Booting Language <c> from module <> 01:53:08 Loading Module <CNULL> 01:53:08 Booting Language <builtin> from module <> 01:53:08 Loading Module <BUILTINNULL> 01:53:13 Dynamically allocated new message shared memory segment (size 2192KB) 01:53:13 Dynamically allocated new virtual shared memory segment (size 8192KB) 01:53:13 IBM Informix Dynamic Server Version 9.40.UC2E1 Software Serial Number AAA#B000000 01:53:13 listener-thread: err = -25572: oserr = 99: errstr = : Network driver cannot bind a name to the port. System error = 99. 01:53:13 sql_listener: ASF_LISTEN failed 01:53:13 Attempting to bring listener thread down. 01:53:13 Server stopped. 01:53:13 IBM Informix Dynamic Server Stopped.
Hi, I think you have some setup problem in the hosts or in sqlhosts file. You are getting: #define EADDRNOTAVAIL 99 /* Cannot assign requested address */ You are attempting to bind(2) to a local address that isn't local. For example if the IP addresses of a machine are 127.0.0.1 and 1.2.3.4, and you're trying to bind to 1.2.3.5 you are going to get this error. Check to make sure the address you are trying to bind to exists on the machine you are trying to bind it from. bye Sandor IBM Certified Professional IBM Informix Development Munich Data Management Solutions Oskar Messter-Str. 20 D-85737 Ismaning Germany Tel +49 89 9603 3254 Fax: +49 89 9603 3200 Cell: +49 16090750915 "CHENDER LEE" <cdlee@ms16.url.c To: ids@iiug.org om.tw> cc: Sent by: Subject: Network driver cannot bind a name to the port! [2027] forum.subscriber@ iiug.org 14.10.2003 14:12 Hi all, when i tried to startup the IDS server, the following messages show in "online.log", i am sure that the network port is not in use, can somebody help? My OS is RedHat 9.0 and IDS is 9.4, thanks. 01:53:08 Event alarms enabled. ALARMPROG = '/opt/informix/LE/etc/alarmprogram.sh' 01:53:08 Booting Language <c> from module <> 01:53:08 Loading Module <CNULL> 01:53:08 Booting Language <builtin> from module <> 01:53:08 Loading Module <BUILTINNULL> 01:53:13 Dynamically allocated new message shared memory segment (size 2192KB) 01:53:13 Dynamically allocated new virtual shared memory segment (size 8192KB) 01:53:13 IBM Informix Dynamic Server Version 9.40.UC2E1 Software Serial Number AAA#B000000 01:53:13 listener-thread: err = -25572: oserr = 99: errstr = : Network driver cannot bind a name to the port. System error = 99. 01:53:13 sql_listener: ASF_LISTEN failed 01:53:13 Attempting to bring listener thread down. 01:53:13 Server stopped. 01:53:13 IBM Informix Dynamic Server Stopped.
Hi bro, Probably you've some kind of mess in onconfig and specially sqlhosts file Check for correct DBSERVERNAME, DBSERVERALIASES, hostname and port. See also services file for correct service name/number Greetz
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts