Network driver cannot bind a name to the port
Posted in 2010
Topics: Networking & sqlhosts Configuration
Hi,
I'm facing the following problem : I'm trying to run an instance on an AIX
box, and I have these messages in my online.log
.....
10:15:21 IBM Informix Dynamic Server Version 9.40.FC9 Software Serial Number
AAA#B000000
10:15:22 listener-thread: err = -25572: oserr = 67: errstr = : Network driver
cannot bind a name to the port.
System error = 67.
10:15:22 sql_listener: ASF_LISTEN failed
10:15:22 Attempting to bring listener thread down.
10:15:22 Server stopped.
10:15:22 IBM Informix Dynamic Server Stopped.
10:15:22 mt_shm_remove: WARNING: may not have removed all/correct segments
Here are the entries in my informix sqlhosts :
pcoipinf onipcshm pcoiic01 pcoiisrv_net1
pcoipinf_tcp onsoctcp pcoiic01 pcoipinfsrv_net1
pcoipinfsrv_tcp onsoctcp pcoiic01 pcoipinfsrv_net1
and I have the following entries in the /etc/services :
informix@pcoiic01:pcoipinf_tcp:/produits/informix/940FC9/etc>
cat /etc/services | grep pcoi
pcoipcoi_net1 15011/tcp # Instance pcoipcoi
pcoiisrv_net1 46015/tcp # Instance pcoiisrv
pcoipinfsrv_net1 46203/tcp # Instance Infocentre
pcoipbfisrv_net1 46213/tcp # Instance Base figée
Can someone help please ?
Gilles
How did the engine shutdown? Cleanly?
run netstat -an and check there are no applications holding your TCP ports
open and kill any that are. Ensure /INFORMIXTMP is empty (provided there
are no other instances running, else ensure any files related to your
instance are removed).
Try to restart again using oninit -v to get more verbose messages.
If it starts OK then stop and restart to ensure as clean as possible.
Keith
On 28 September 2010 11:42, GILLES TCHAPPI <ntgilfr@voila.fr> wrote:
> Hi,
> I'm facing the following problem : I'm trying to run an instance on an AIX
> box, and I have these messages in my online.log
>
> ......
> 10:15:21 IBM Informix Dynamic Server Version 9.40.FC9 Software Serial Number
> AAA#B000000
> 10:15:22 listener-thread: err = -25572: oserr = 67: errstr = : Network driver
> cannot bind a name to the port.
> System error = 67.
> 10:15:22 sql_listener: ASF_LISTEN failed
>
> 10:15:22 Attempting to bring listener thread down.
>
> 10:15:22 Server stopped.
>
> 10:15:22 IBM Informix Dynamic Server Stopped.
>
> 10:15:22 mt_shm_remove: WARNING: may not have removed all/correct segments
>
> Here are the entries in my informix sqlhosts :
> pcoipinf onipcshm pcoiic01 pcoiisrv_net1
> pcoipinf_tcp onsoctcp pcoiic01 pcoipinfsrv_net1
> pcoipinfsrv_tcp onsoctcp pcoiic01 pcoipinfsrv_net1>
> and I have the following entries in the /etc/services :
> informix@pcoiic01:pcoipinf_tcp:/produits/informix/940FC9/etc>
> cat /etc/services | grep pcoi
> pcoipcoi_net1 15011/tcp # Instance pcoipcoi
> pcoiisrv_net1 46015/tcp # Instance pcoiisrv
> pcoipinfsrv_net1 46203/tcp # Instance Infocentre
> pcoipbfisrv_net1 46213/tcp # Instance Base figée
>
> Can someone help please ?
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
Keith
In fact, the instance is a clone created by copying the volume group of an
instance files from another AIX box (let's call the box pcoi01) to the actual
(same) AIX (version) box (called pcoiic01) therefore is the first time I'm
trying to run the instance.
Folloing is the netstat result :
informix@pcoiic01:pcoipinf_tcp:/bases/informix/pcoipcoi/app> netstat -na |
grep 15011
informix@pcoiic01:pcoipinf_tcp:/bases/informix/pcoipcoi/app> netstat -na |
grep 46015
informix@pcoiic01:pcoipinf_tcp:/bases/informix/pcoipcoi/app> netstat -na |
grep 46203
informix@pcoiic01:pcoipinf_tcp:/bases/informix/pcoipcoi/app> netstat -na |
grep 46213
informix@pcoiic01:pcoipinf_tcp:/bases/informix/pcoipcoi/app>
And running oninit -v gives :
informix@pcoiic01:pcoipinf_tcp:/bases/informix/pcoipcoi/app> oninit -v
Checking group membership to determine server run modesucceeded
Reading configuration file
'/produits/informix/940FC9/etc/onconfig.pcoipinf'...succeeded
Creating /INFORMIXTMP/.infxdirs ... succeeded
Creating infos file "/produits/informix/940FC9/etc/.infos.pcoipinf" ...
"/produits/informix/940FC9/etc/.conf.pcoipinf" ... succeeded
Writing to infos file ... succeeded
Checking config parameters...succeeded
WARNING : If you intend to use J/Foundation or GLS for Unicode feature(GLU)
with this Server instance, please make sure that your SHMBASE value specifies
in onconfig is 0x700000010000000 or above. Otherwise you will have problems
while attaching or dynamically adding virtual shared memory segments. Please
refer to Server machine notes for more information.
Allocating and attaching to shared memory...succeeded
Creating resident pool 333576 kbytes...succeeded
Creating buffer pool 3860148 kbytes...succeeded
Creating buffer pool 543876 kbytes...succeeded
Initializing rhead structure...succeeded
Initializing ASF ...succeeded
Initializing Dictionary Cache and SPL Routine Cache...succeeded
Bringing up ADM VP...succeeded
Creating VP classes...succeeded
Onlining 2 additional cpu vps...succeeded
Onlining 85 IO vps...succeeded
Initialization of Encryption...succeeded
Forking main_loop thread...succeeded
Initializing DR structures...succeeded
Forking 1 'ipcshm' listener threads...succeeded
Forking 1 'soctcp' listener threads...succeeded
Forking 1 'soctcp' listener threads...succeeded
Starting tracing...succeeded
Initializing 128 flushers...succeeded
informix@pcoiic01:pcoipinf_tcp:/bases/informix/pcoipcoi/app>
and onstat -m gives :
Message Log File: /bases/informix/pcoipcoi/var/bdump/online.log
12:26:18 Event alarms enabled. ALARMPROG =
'/bases/informix/pcoipcoi/admin/ontape/sh/log_full.sh'
12:26:18 Booting Language <c> from module <>
12:26:18 Loading Module <CNULL>
12:26:18 Booting Language <builtin> from module <>
12:26:18 Loading Module <BUILTINNULL>
12:26:31 AIX MP latch code enabled
12:26:31 Dynamically allocated new message shared memory segment (size 672KB)
12:26:31 Memory sizes:resident:4194288 KB, virtual:5263136 KB, no SHMTOTAL
limit
12:26:32 IBM Informix Dynamic Server Version 9.40.FC9 Software Serial Number
AAA#B000000
12:26:32 listener-thread: err = -25572: oserr = 67: errstr = : Network driver
cannot bind a name to the port.
System error = 67.
12:26:32 sql_listener: ASF_LISTEN failed
12:26:32 Attempting to bring listener thread down.
12:26:32 Server stopped.
12:26:32 IBM Informix Dynamic Server Stopped.
12:26:32 mt_shm_remove: WARNING: may not have removed all/correct segments
Regards
Original post:
Hi,
I'm facing the following problem : I'm trying to run an instance on an AIX
box, and I have these messages in my online.log
.....
10:15:21 IBM Informix Dynamic Server Version 9.40.FC9 Software Serial Number
AAA#B000000
10:15:22 listener-thread: err = -25572: oserr = 67: errstr = : Network driver
cannot bind a name to the port.
System error = 67.
10:15:22 sql_listener: ASF_LISTEN failed
10:15:22 Attempting to bring listener thread down.
10:15:22 Server stopped.
10:15:22 IBM Informix Dynamic Server Stopped.
10:15:22 mt_shm_remove: WARNING: may not have removed all/correct segments
Here are the entries in my informix sqlhosts :
pcoipinf onipcshm pcoiic01 pcoiisrv_net1
pcoipinf_tcp onsoctcp pcoiic01 pcoipinfsrv_net1
pcoipinfsrv_tcp onsoctcp pcoiic01 pcoipinfsrv_net1
and I have the following entries in the /etc/services :
informix@pcoiic01:pcoipinf_tcp:/produits/informix/940FC9/etc>
cat /etc/services | grep pcoi
pcoipcoi_net1 15011/tcp # Instance pcoipcoi
pcoiisrv_net1 46015/tcp # Instance pcoiisrv
pcoipinfsrv_net1 46203/tcp # Instance Infocentre
pcoipbfisrv_net1 46213/tcp # Instance Base figée
Can someone help please ?
Response:
So am I reading correctly that both pcoipinf_tcp and pcoipinfsrv_tcp have the
same host (pcoiic01) and service name (pcoipinfsrv_net1)? If so, that would
imply to me that you are attempting to start 2 listener threads on the same
hostname/port number combo, which you can't do. The 1st listener thread using
that combo will work, but when the 2nd tries to start up, it would get a fail
to bind to port error.
Jacques Renaut
IBM Informix Advanced Support
APD Team
Hi Jacques,
You're rigth. I modified the first entry in my sqlhosts changing
'pcoipinf onipcshm pcoiic01 pcoiisrv_net1' by 'pcoipinf onipcshm pcoiic01
pcoipcoi_net1' and reran 'oninit' again. And now the instance is up
Thanks a lot
Thanks to Keith too for his answer.
Bests regards
and I have the following entries in the /etc/services :
informix@pcoiic01:pcoipinf_tcp:/produits/informix/940FC9/etc>
cat /etc/services | grep pcoi
pcoipcoi_net1 15011/tcp # Instance pcoipcoi
pcoiisrv_net1 46015/tcp # Instance pcoiisrv
pcoipinfsrv_net1 46203/tcp # Instance Infocentre
pcoipbfisrv_net1 46213/tcp # Instance Base figée
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts