(error -25572) Network driver cannot bind a name to the port.
Posted in 2000
Topics: Installation, Setup & Upgrades, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi! I installed Informix client SDK (2.40) on a SUN box (Solaris 8). I'm unable to open a connection to my database server! I always get the error: (error -25572) Network driver cannot bind a name to the port. The system is ready: .netrc, sqlhosts, /etc/services, environment... Any idea about this problem? While sniffing there is _NO_ traffic between the client and the server. (The Solaris box runs a dual stack IPv4/IPv6.) X -- Xavier Mertens &Wanadoo Belgium "Contrary to popular belief, Unix is NOC Manager a subsidiary of userfriendly. It just happens to be XM1-6BONE XM3-RIPE France Telecom selective about who it makes friens with"
I seem to remember some problem running Informix and other IPv4 apps on Solaris 8 because of a bug in the dual TCP/IP stack handling. I believe there is a Solaris patch that is needed. Art S. Kagel Xavier Mertens wrote: > > Hi! > > I installed Informix client SDK (2.40) on a SUN box (Solaris 8). > I'm unable to open a connection to my database server! > > I always get the error: > (error -25572) Network driver cannot bind a name to the port. > > The system is ready: .netrc, sqlhosts, /etc/services, environment... > Any idea about this problem? While sniffing there is _NO_ traffic between > the client and the server. > > (The Solaris box runs a dual stack IPv4/IPv6.) > > X > > -- > Xavier Mertens &Wanadoo Belgium "Contrary to popular belief, Unix is > NOC Manager a subsidiary of userfriendly. It just happens to be > XM1-6BONE XM3-RIPE France Telecom selective about who it makes friens with"
Hi, Do you know which patch is needed? I checked the SUNSolve database without success... X -- Xavier Mertens &Wanadoo Belgium "Contrary to popular belief, Unix is NOC Manager a subsidiary of userfriendly. It just happens to be XM1-6BONE XM3-RIPE France Telecom selective about who it makes friends with" On Thu, 5 Oct 2000, Art S. Kagel wrote: > I seem to remember some problem running Informix and other IPv4 apps on > Solaris 8 because of a bug in the dual TCP/IP stack handling. I believe > there is a Solaris patch that is needed. > > Art S. Kagel > > Xavier Mertens wrote: > > > > Hi! > > > > I installed Informix client SDK (2.40) on a SUN box (Solaris 8). > > I'm unable to open a connection to my database server! > > > > I always get the error: > > (error -25572) Network driver cannot bind a name to the port. > > > > The system is ready: .netrc, sqlhosts, /etc/services, environment... > > Any idea about this problem? While sniffing there is _NO_ traffic between > > the client and the server. > > > > (The Solaris box runs a dual stack IPv4/IPv6.) > > > > X > > > > -- > > Xavier Mertens &Wanadoo Belgium "Contrary to popular belief, Unix is > > NOC Manager a subsidiary of userfriendly. It just happens to be > > XM1-6BONE XM3-RIPE France Telecom selective about who it makes friens with" >
Xavier, This is part of a known Informix bug with Solaris 8. The defect number is 124759. ON SOLARIS 8, SERVER FAILS TO BUILD SYSMASTER BECAUSE BUILDSMI CONNECT TO DATABASE FAILS WITH ERROR 25572 WITH "EXEC FORMAT ERROR" USING TLITCP. With ipcshm, it works fine. Still waiting on a patch though. Todd Xavier Mertens wrote: > Hi! > > I installed Informix client SDK (2.40) on a SUN box (Solaris 8). > I'm unable to open a connection to my database server! > > I always get the error: > (error -25572) Network driver cannot bind a name to the port. > > The system is ready: .netrc, sqlhosts, /etc/services, environment... > Any idea about this problem? While sniffing there is _NO_ traffic between > the client and the server. > > (The Solaris box runs a dual stack IPv4/IPv6.) > > X > > -- > Xavier Mertens &Wanadoo Belgium "Contrary to popular belief, Unix is > NOC Manager a subsidiary of userfriendly. It just happens to be > XM1-6BONE XM3-RIPE France Telecom selective about who it makes friens with"
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts