You'll have a FIN_WAIT(2) reporting on the netstat, either wait for it
to timeout (~15 mins) or trace it through using lsof and might be able to
shoot the offending process. Under Solaris 2.7 the tcp control/Informix
interface must have been re-worked 'cos even if the port is in use the
engine
will re-start, it never used to
Paul Watson #
WF Software Ltd # You are only young once
Tel: +44 1436 674729 # but you can be immature
Fax: +44 1436 678693 # forever
www.wfsoftware.com #
On 7 Jun 2000, at 17:48, Stacey Windsor wrote:
>
> COMPAQ Proliant 1600
> 4/200 MHz cpu
> SCO UNIX 5.05
> INFORMIX 7.30_uc2
>
> Problem:
> Errors in online.log file:
>
> 16:28:00 listener-thread: err = -25572: oserr = 4: errstr = : Networkdriver
> cannot bind a name to the port.
> System error = 4.
>
> 16:28:01 listener-thread: err = -25572: oserr = 4: errstr = : Networkdriver
> cannot bind a name to the port.
> System error = 4.
>
> Can anyone shed some light on this. Many thanks.
>
>
> Stacey Windsor
> x6071
>
The contents of this e-mail are confidential to the ordinary user(s) of the
mail address(es) to which it was sent and may be legally privileged.
If you are not the intended recipient, any disclosure, copying, distribution
or use of it, or any part of it, in any form whatsoever, and any actions
taken or omitted to be taken in reliance on it, is prohibited and may be
unlawful.
↪ replying to Watson Paul
In article <8hqart$mf2$1@news.xmission.com>, Watson Paul
<Paul.Watson@fefc.ac.uk> writes
>
>You'll have a FIN_WAIT(2) reporting on the netstat, either wait for it
>to timeout (~15 mins) or trace it through using lsof and might be able to
>shoot the offending process. Under Solaris 2.7 the tcp control/Informix
>interface must have been re-worked 'cos even if the port is in use the
>engine
>will re-start, it never used to
>
>Paul Watson #
>WF Software Ltd # You are only young once
>Tel: +44 1436 674729 # but you can be immature
>Fax: +44 1436 678693 # forever
>www.wfsoftware.com #
>
Yes, there is a TCP option SE_REUSEADDR which would allow the server
to restart.
--
David Williams