HELP! Can't start IDS9.2 w/tcp!
Posted in 2000
Topics: Installation, Setup & Upgrades, Server Administration, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi all...
I have an error which has me stumped. Any help appreciated.
Machine: Sun E4000 w/4G Ram; Solaris 2.7
Installing IDS9.2
Given:
Environment variable: INFORMIXSERVER=devtcp; export INFORMIXSERVER
sqlhosts:
testdb onipcshm dev xxx
testdbtcp ontlitcp dev devtcp
onconfig
DBSERVERNAME testdb
DBSERVERALIASES testdbtcp
/etc/services
devtcp 7777/tcp
/etc/hosts
133.356.432.111 loghost dev
When I oninit -i with DBSERVERALIASES commented out and INFORMIXSERVER
set to testdb, the server starts with no problems.
When I oninit -i with DBSERVERALIASES, (using the above configuration),
I get in the error log:
listener-thread: err = -25572: oserr = 0; errstr = : Network driver
cannot bind a name to the port.
Anybody see what I've coded wrong and can suggest a solution?
And...yes...the networking appears to be OK.
Thanks in advance,
Joe
In article <38d68bcf_3@dilbert.ic.sunysb.edu>,
trubisz@cs.sunysb.edu (Joe Trubisz) wrote:
> Hi all...
>
> I have an error which has me stumped. Any help appreciated.
>
> Machine: Sun E4000 w/4G Ram; Solaris 2.7
> Installing IDS9.2
>
> Given:
>
> Environment variable: INFORMIXSERVER=devtcp; export INFORMIXSERVER
>
> sqlhosts:
> testdb onipcshm dev xxx
> testdbtcp ontlitcp dev devtcp>
> onconfig
> DBSERVERNAME testdb
> DBSERVERALIASES testdbtcp>
What about NETTYPE entry in the config file ? Are you sure that the
system is not part of a NFS.
Check if the command >ypcat services returns any data. If it does then
you have to configure the port number within the yellow pages.
HTH
Ram S.
> /etc/services
> devtcp 7777/tcp
>
> /etc/hosts
> 133.356.432.111 loghost dev
>
> When I oninit -i with DBSERVERALIASES commented out and INFORMIXSERVER
> set to testdb, the server starts with no problems.
>
> When I oninit -i with DBSERVERALIASES, (using the above
configuration),
> I get in the error log:
>
> listener-thread: err = -25572: oserr = 0; errstr = : Network driver
> cannot bind a name to the port.
>
> Anybody see what I've coded wrong and can suggest a solution?
> And...yes...the networking appears to be OK.
>
> Thanks in advance,
> Joe
>
>
Sent via Deja.com http://www.deja.com/
Before you buy.
try
INFORMIXSERVER=testdb; export INFORMIXSERVER
with DBSERVERALIASES not commented out
but make shure your tcp port isn't in use
netstat -a | grep devtcp
there are no more server processe of your instance + you receive a line like
xxxx dev.devtcp *.* LISTEN
or even
xxxx *.devtcp *.* LISTEN
you have to look for another tcp port number
ram_cnc wrote:
> In article <38d68bcf_3@dilbert.ic.sunysb.edu>,
> trubisz@cs.sunysb.edu (Joe Trubisz) wrote:
> > Hi all...
> >
> > I have an error which has me stumped. Any help appreciated.
> >
> > Machine: Sun E4000 w/4G Ram; Solaris 2.7
> > Installing IDS9.2
> >
> > Given:
> >
> > Environment variable: INFORMIXSERVER=devtcp; export INFORMIXSERVER
> >
> > sqlhosts:
> > testdb onipcshm dev xxx
> > testdbtcp ontlitcp dev devtcp> >
> > onconfig
> > DBSERVERNAME testdb
> > DBSERVERALIASES testdbtcp> >
>
> What about NETTYPE entry in the config file ? Are you sure that the
> system is not part of a NFS.
>
> Check if the command >ypcat services returns any data. If it does then
> you have to configure the port number within the yellow pages.
>
> HTH
>
> Ram S.
>
> > /etc/services
> > devtcp 7777/tcp
> >
> > /etc/hosts
> > 133.356.432.111 loghost dev
> >
> > When I oninit -i with DBSERVERALIASES commented out and INFORMIXSERVER
> > set to testdb, the server starts with no problems.
> >
> > When I oninit -i with DBSERVERALIASES, (using the above
> configuration),
> > I get in the error log:
> >
> > listener-thread: err = -25572: oserr = 0; errstr = : Network driver
> > cannot bind a name to the port.
> >
> > Anybody see what I've coded wrong and can suggest a solution?
> > And...yes...the networking appears to be OK.
> >
> > Thanks in advance,
> > Joe
> >
> >
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts