OnLine won't start ...
Posted in 1999
Topics: Error Codes & Troubleshooting
I got the following error message when I tried to startup our database.
Thu Apr 8 19:16:18 1999
19:16:18 Event alarms enabled. ALARMPROG = '/opt/informix/etc/log_full.sh'
19:16:23 DR: DRAUTO is 0 (Off) 19:16:24 listener-thread: err = -25572:Network driver cannot bind a name to th e port. System error = 8. 19:16:24
Attempting to bring listener thread down
19:16:24 WARNING! LTXHWM (100) and/or LTXEHWM (100) config parameters exceed recommended values of 50 and 60. This may
cause On-Line to wait too long before rolling
back a long transaction and allow it to completely
fill the logs. See the OnLine Administrators Guide
and $INFORMIXDIR/release/SERVERS_7.1 for more
information on resetting LTXHWM and LTXEHWM.
19:16:25 PANIC: Attempting to bring system down
19:16:25 mt.c, line 1197, thread 0, proc id 443, semop: errno = 36
19:16:25 Assert Failed: semop: errno = 36
19:16:25 Who: Session(0, @, 0, 0)
Thread(0, idle, 0, 3)
19:16:25 Assert Failed: semop: errno = 36
19:16:25 Results: Fatal Internal Error requires system shutdown
19:16:25 Action: Restart OnLine
19:16:25 See Also: /tmp/af.38c8
19:16:25 mt.c, line 1197, thread 0, proc id 443, semop: errno = 22
.
19:16:25 Assert Failed: semop: errno = 22
19:16:25 Who: Session(0, @, 0, 0)
Thread(0, idle, 0, 3)
19:16:25 Results: Fatal Internal Error requires system shutdown
19:16:25 Action: Restart OnLine
Any idea ?!?!?
Thanks!
Edwin M. Manalo
-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own
First thing is that it looks like either the service name defined in your
sqlhosts file for network connections is either not defined in your
/etc/services or it is already used by another program. Next It looks like
your long transaction high water mark / exclusive high water mark is set too
high. Set LTXHWM to no greater than 50 and LTXEHWM to no greater than 60.
Setting them higher is looking for trouble. Some people recommend setting
LTXEHWM to 50 so that you can guarantee a rollback. If you run out of log
before you rollback, it's restore time.
Hope this helps
Scott Kolaya
manaloe@my-dejanews.com wrote in message
<7ejeig$841$1@nnrp1.dejanews.com>...
>I got the following error message when I tried to startup our database.
>
>Thu Apr 8 19:16:18 1999
>
>19:16:18 Event alarms enabled. ALARMPROG =
'/opt/informix/etc/log_full.sh'
>19:16:23 DR: DRAUTO is 0 (Off) 19:16:24 listener-thread: err = -25572:>Network driver cannot bind a name to th e port. System error = 8. 19:16:24
>Attempting to bring listener thread down
>
>19:16:24 WARNING! LTXHWM (100) and/or LTXEHWM (100) config parameters> exceed recommended values of 50 and 60. This may
> cause On-Line to wait too long before rolling
> back a long transaction and allow it to completely
> fill the logs. See the OnLine Administrators Guide
> and $INFORMIXDIR/release/SERVERS_7.1 for more
> information on resetting LTXHWM and LTXEHWM.
>
>19:16:25 PANIC: Attempting to bring system down
>19:16:25 mt.c, line 1197, thread 0, proc id 443, semop: errno = 36
>19:16:25 Assert Failed: semop: errno = 36
>
>19:16:25 Who: Session(0, @, 0, 0)
> Thread(0, idle, 0, 3)
>19:16:25 Assert Failed: semop: errno = 36
>
>19:16:25 Results: Fatal Internal Error requires system shutdown
>19:16:25 Action: Restart OnLine
>19:16:25 See Also: /tmp/af.38c8
>19:16:25 mt.c, line 1197, thread 0, proc id 443, semop: errno = 22
>.
>19:16:25 Assert Failed: semop: errno = 22
>
>19:16:25 Who: Session(0, @, 0, 0)
> Thread(0, idle, 0, 3)
>19:16:25 Results: Fatal Internal Error requires system shutdown
>19:16:25 Action: Restart OnLine>
>Any idea ?!?!?
>
>Thanks!
>
>Edwin M. Manalo
>
>-----------== Posted via Deja News, The Discussion Network ==----------
>http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own