Informix & Uniface - severe problem
Posted in 1998
Hi gurus,
yeah, nice weather out there, isn't it... At least here... :-)
No, of course, we do have a problem; at first our 'problematic'
environment:
* Client: Win95/Uniface Runtime 6.1dp
* Server: Sun/Solaris 2.5/Informix OnLine 7.23 UC2/Polyserver
(BTW, it's the first time that we face a problem as serious as this
with this environment, usually it's very stable!)
Problem:
we have a form which is based on a big but not very complex view (it's
a join of one table to another view; this one is built of 10 joined
tables including 1 outer join). We retrieve the data into the form and
do some processing and show the processed data. If we do the same thing
right afterwards - without leaving our app - Uniface crashes because
Informix was forced to shutdown with the following error message
(part of the Informix log file):
17:09:12 Assert Failed: Internal Error - Segmentation Violation
17:09:12 Who: Session(8, pmkunde7@sun, 7481, 172976148)
Thread(31, sqlexec, a4d3998, 1)
17:09:12 Results: OnLine must abort
17:09:12 Action: Reinitialize shared memory
17:09:12 See Also: /tmp/af.1f7da8, shmem.1f7da8.0
17:09:13 rsinit.c, line 9947, thread 31, proc id 7474, Segmentation
Violation.
17:09:13 PANIC: Attempting to bring system down
Contents of file /tmp/af.1f7da8:
17:09:12
17:09:12 Assert Failed: Internal Error - Segmentation Violation
17:09:12 Who: Session(8, pmkunde7@sun, 7481, 172976148)
Thread(31, sqlexec, a4d3998, 1)
17:09:12 Results: OnLine must abort
17:09:12 Action: Reinitialize shared memory
17:09:12 See Also: /tmp/af.1f7da8, shmem.1f7da8.0
17:09:12 Stack for thread: 31 sqlexec
base: 0x0a73c018
len: 33280
pc: 0x00384850
tos: 0x0a743240
0x003841bc ***unknown*** (0x1f7da8, 0xa5e4578, 0xa4d3998,
0xa4f6814, 0xa4f6814, 0xa5e4518)
0x0027f434 ***unknown*** (0xa5e44d0, 0xa5e4518, 0xa5e4578,
0xa4d3998, 0xa4f6814, 0x0)
0x0007b990 ***unknown*** (0x4deb40, 0x2400, 0xb, 0x4df3b0, 0x0,
0x10000)
0xef5f7d44 ***unknown*** (0xb, 0x0, 0xa743b10, 0xa743d6c, 0x0, 0x0)
0x0011a1dc ***unknown*** (0xa7efde4, 0xa7efd38, 0x40250000, 0x0,
0x114001, 0x400101)
0x000b517c ***unknown*** (0xa7efd38, 0x0, 0x100, 0x100, 0xa6d4a70,
0xa6ec030)
0x000b5b84 ***unknown*** (0xa6ec030, 0x0, 0x0, 0x0, 0xa6ec030, 0x0)
0x0011a1dc ***unknown*** (0xa7efde4, 0xa7efd38, 0x40250000, 0x0,
0x114001, 0x400101)
0x000b517c ***unknown*** (0xa7efd38, 0x0, 0x100, 0x100, 0xa6d4a70,
0xa6ec030)
0x000b5b84 ***unknown*** (0xa6ec030, 0x0, 0x0, 0x0, 0xa6ec030, 0x0)
0x0015f7cc ***unknown*** (0x0, 0x0, 0xe230, 0x6, 0x30, 0x180)
0x001724fc ***unknown*** (0xe000, 0x57, 0x54a91c, 0x54a800,
0x54cd44, 0x57)
0x0036a6e4 ***unknown*** (0xffffffff, 0x0, 0xa5d1900, 0x10,
0xef6fd5ac, 0x54aa30)
0x003a84e4 ***unknown*** (0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
0x00000000 ***unknown***
17:09:13
------------------ End of assertion failure 0 -----------------
Uniface issues the following error message:
I/O function: S, mode: 0, on file/table: LST_ZTG_V index: 1 >=
INFORMIX ERROR (SQLSTATE: IX000): Network connection is broken.
INFORMIX ERROR (SQLSTATE: IX000): Bad file number
INFORMIX ERROR (SQLSTATE: IX000): Network connection is broken.
SQLCODE -25582: Network connection is broken.
This error occurs _only_ if we do _not_ leave the Uniface runtime
session! If we leave it and run the "special" form again - it behaves
o.k.. If we run it 2 times in one session (even if we run some other
forms in between) - *crash*.
And: this happens at a client's site; it didn't happen 'til now and
one reason could be that the amount of data which is retrieved grew
in the last months. Maybe this is a clue?
With io level 63 I got the SQL statement built by Uniface and I tried
this one directly in dbaccess and it worked correctly - and not only
one time in a row!
Also if we run a report (within our app or directly out of Crystal
Reports) which is based on the views mentioned above - it works more
than one time in a row!
So, the only way to "achieve" this error is to run the Uniface form
and only if we do this 2 times in a row. It works even fine if I start
it on one client and right afterwards on another client - but if I dare
to start it once again on one of the two clients without leaving the
app in the meantime - hasta la vista, database! ;-)
If anybody out there can deliver some hints or has even experienced
similar problems - please do not hesitate and send us some lines!
(Also if you have additional questions - post it to the newsgroup
or directly to me!)
TIA and many regards,
Stephan.
--
Stephan Stresing
Media Systeme
Gesellschaft fuer Druck & Verlag mbH
Suedwestpark 48
D-90449 Nuernberg
Phone +49 911 6809-113
Fax +49 911 6809-110
eMail triple-p.sst@t-online.de