Threads from 2022
Browse by month: Jan · Feb · Mar · Apr · May · Jun · Jul · Aug · Sep · Oct · Nov · Dec
Hibernate 6 does not support Infomix anymore
Hello, Hibernate ORM 6.0 was released in the summer of 2022. And Hibernate ORM 6.x no longer supports Informix,The InformixDialect has been removed from Hibernate. Hibernate no longer sees the need to support Informix. Has anyone found a way to use Hibernate ORM 6.x with Informix…
stat() failed for chunk file
Hello. I have Informix 14 FC8 on Windows Server. All works great, but when server is starting i see message in log file to all my chunks: Warning: stat() failed for chunk file... How I can fix it? ------------------------------ Alexander Ivanov ------------------------------ #Inf…
Ontape parameters
Dear colleagues: I need to make backups on tape. I have an external HP LTO Ultrium 6 drive with native 2.50TB cartridges, and my problem is focused on the TAPEBLK parameter, which I had at 2048 when I backed up to disk, but when I want to do it to tape, the ontape tells me that d…
Informix KMIP Encryption
Hello Team, One of my customers is migrating from the Local Key Store to KMIP Key Store. They have tried migrating from the Local Key Store to KMIP but the Database stops working. Any recommendation?? Regards Amit Kumar Thakur Software Engineer : Customer Success. ---------------…
Unable to interrupt SQL queries in some cases
We have some problems where we are not able to interrupt queries in dbaccess with certain combinations of clients and servers. Could it be due to some traffic passing a firewall in the network? How is sqlbreak() (which I am guessing is used to implement the interrupt functionalit…
index on timestamp & optimizer strategy failure
I've got a large events table (~1500 million rows) with 2 timestamps (datetime hour to second) recording a time associated with the event and a time when the row was inserted. The event-time may be in the future, but in most of the cases it is near the actual point in time. If th…
Blade server (hs 23) hard disk information
Dear all, I have bladecenter hs 23 and I want to know hdd serial and product number of blade server. I can't find any information. I logged in bladecenter advanced management console and I see more of them have infor about sn and pn number except hdd/ssd. Best regards, Sabina Agh…
Where can I download ESQL/COBOL
Hi everyone, Last year it was still possible to download the ESQL/COBOL SDK but today I did not success to find the download location. Is someone know where I can find it please? Best regards, ------------------------------ Stephane GONZALEz ------------------------------ #Inform…
Informix 14 and AIX 7.3
Hi all customer wants to buy new HW (P10) and they want AIX 7.3 - but according to Informix Server System Requirements ( Informix Server System Requirements ) this is not supported combination. I know it is working but customer wants IBM to state that. Whom do I have to contact? …
V14.10.FC9 installer missing librarie(s)?
After a full root installaton informix@Elbereth:~/GoogleDrive/IBM_Files/installfiles$ $INFORMIXDIR/bin/oninit -V cannot access /opt/informix/infmx.14.10.FC9DE/lib/libisi.so.2 No such file or directory (errno 2) IBM Informix Dynamic Server Version 14.10.FC9DE Mon Oct 3 16:03:02 CD…
Getting IDS 12.10 FC12 support on RHE 8.6
HI Everyone We have a system upgrade need in our datacenter , whereby we need to upgrade our current RHEL6.x OS system to RHEL 8.6 and that is driving our need to get 12.10 FC12 being supported by IBM on RHEL 8.6 otherwsie its is a upgrade without IBM supported platform. Also we …
Separate DBspace for indexes
Hello all. I have a task to migrate from 9 to 14 Informix. I saw Lester Knutsen's webcasts and he recommended separating indexes from data. At the moment the indexes are not separate. Can I, as a DBA, automatically separate all indexes from data after I import data from 9 to 14 I…
Ifx 14.10xc8 - ISAM error: operation illegal on a DR Secondary
Hello, I need help for : IBM Informix Dynamic Server Version 14.10.FC8DE -- Updatable (RSS) we are testing an hdr/rss (updatable) configuration and we are getting systematic errors like this on rss : 229: Could not open or create a temporary file. 140: ISAM error: operation ille…
Replication of Informix
Hi Team, I am setting up HA for Informix. I am getting issue with trusting both Primary + Secondary Servers. The errors are as follow: Primary DR: new type = primary, secondary server name = labsoc DR: Cannot connect to secondary server DR: Turned off on primary server Secondary …
libbsapsm.dll missing
Hello. I am learning Informix from scratch. I installed Informix 14 Express Edition on Windows Server 2019. Now I'm trying to use "archecker" but it can't work because it needs "libbsapsm.dll". But there is no such dll in my informix folder. Where can I download it? -------------…
delete time series data using tscontainerpurge
Hi, i tried to delete time series data through a specified timestamp using tscontainerpurge with this script: - unload to "regular_purgetest.unl" SELECT GetContainerName(para_values),InstanceId(para_values),GetIndex(para_values,'2018-01-01 23:00:00.00000'::datetime year to fracti…
Informix recommended setup for storage
Hi everybody, we are planning a new database server (pair, should be HDR) for a huge customer. Our admins started a discussion on how to configure storage. We want to have ~6TB of space and are planning to be running with a set of NVME Raid (Raid 10, 5 disks e.g. 5x3.8TB like Sam…
Odd -1266 error with combined conditions and fragmented index
Hey, everyone. Hitting a weird issue which I can replicate on 12.10.FC14, 14.10.FC7 and 14.10.FC8 (all on CentOS). Run the script below (change the dbspace names in the index creation statement to ones that exist on your system). All of the statements work except for the final on…
Phantom rsccompdict table
Informix 12.10FC14 Solaris 10 1/13 I am attempting to delete unused chunks from an Informix rootdbs. One I would like to delete is almost empty. I say "almost" because when I examine the objects in that chunk, I observe one table: rsccompdict. I have looked at two sysmaster tab…
start onbar and ontape simultaneously
HI, all: When the onbar backup is running, I start a ontape backup simultaneously, the online.log display: Archive on rootdbs,phydbs,logdbs,datadbs ABORTED. Does it mean when the onbar is running I can't start ontape to do the backup again? Thanks for your time. -----------------…
Find start value of SERIAL/BIGSERIAL column
Hello! Where can I find the start value of a column defined as SERIAL( start-value ) or BIGSERIAL( start-value ) in the Informix system tables? I did not find this in the syscolumns... Seb ------------------------------ Sebastien FLAESCH ------------------------------ #Informix…
TLS/SSL with IBM Data Server Driver
All: We have a .NET application which, unfortunately, is connecting to Informix using the IBM Data Server Driver v10.5. We need to change our connections to communicate via TLS/SSL rather than unencrypted. Does anyone here have any experience with this? From what I can tell, the …
Informix 14.10 FC8 installation on Linux
Hi, Any idea on the following errors ? Done this for 20 + years, first time got this:-) Thanks Frank 1) case 1 Root# ./ids_install Preparing to install Extracting the JRE from the installer archive... Unpacking the JRE... Extracting the installation resources from the installer a…
restore through STDIO
HI, I want to backup the instance and restore to another 3 instance. 1, I run the blow comand to do the backup. ontape -s -L 0 -t STDIO | gzip >level-0.gz then, I use scp copy the zip file to another machine. 2, I try to run below command to do the restore , chmod 660 level-0.gz …
Spammed by Lil Durk - Malware?
Just FYI - I received 6 emails from "Lil Durk via IBM Community" on August 22, 2022 between 1:05AM (ET) and 1:12AM (ET). Apparently, the real Lil Durk is a rapper. One of the links is https://lildurk.com, which is not the rapper's website. Whois shows the website hosting company …
Informix 14 Certification
Hello, I have earned the IBM Informix on Cloud V12.10 Database Administrator badge in 2020. Do I need to upgrade to the 14.10 version of the badge? Thanks, ------------------------------ SangGyu Jeong Software Engineer Infrasoft Seoul Korea, Republic of --------------------------…
Innovator-C download?
We want to use the Informix Innovator-C Edition. The links (both the Developer and Innovator links) are broken. Clicking on them yields: Oops - that's not right! The page you requested cannot be displayed. 503: Service Unavailable Suggested actions If you typed the address, plea…
Manual Switch Primary , Secondary while RSS exist
Hi I have a client running IBM Informix 12.14 in RedHat 7.6. They have IDS Primary & IDs Secondary in HQ Data Centre while IDS RSS in DRC Data Centre. I didnt setup Control Manager. All this while I'm using manual via onmode command. I always refer Art Kagel document how to sw…
varchar maximum length of 254 with an index
All, I learnt very early on in my Informix career that the maximum length of a varchar column is limited to 254 characters, instead of 255, if the column is indexed. This restriction is documented here: https://www.ibm.com/docs/en/informix-servers/14.10?topic=types-varcharmr-data…
IFX 14.10xc8 Updatable RSS and CPU Usage
Hello, In dev env. i've configured a pimary with 2 rss. there is no user activity and i see a high usage of CPU when a do a onstat -z followed by onstat -g smx i've notice a very high number at #scheds onstat -z; onstat -g cpu | grep smx IBM Informix Dynamic Server Version 14.10.…
Automating IBM Systems with Ansible Automation Platform Webinar
Summary It's been understated, but IBM has been very involved with Red Hat's Ansible Automation Platform. This webinar will look at how Ansible can be used to automate IBM Systems from the Mainframe to the IBM Spectrum Virtualize Please join us on Thursday, Jul 21st, 2022 at 1:00…
"Physical Logging while in Critical Section" in online log
I'm getting the message below in the online log, and I want to know in which case it occurs. Looking at the transaction log at that time with onlog, this message seems to occur at the time of truncate and chfree. It is currently suspected that truncate caused the message. Is this…
%Cached using onstat -p vs %Cached using onstat -g buf
I am on Informix 11.70, and I am grabbing metrics to record. One of them is the buffer write% for each server. When running onstat -p , it shows the %cached as 90.60 . However when actually calculating the %cached, it yields 80.20. The 80.20 value aligns with the value from onsta…
how to execute tspurgefunction for rolling container
so, i tried to load creates a control file named regular_purge.unl to delete elements from time series instances: but it return error 674: routine(getcontainername) cannot be resolved. UNLOAD TO 'regular_purge.unl' SELECT GetContainerName(para_id),InstanceId(para_id), GetIndex(pa…
Informix 14.10.FC8 on RHEL 8.6 installation - missing packages ?
Hello, In the doc i see - Red Hat Enterprise Linux ES release 8.0 (Kernel: 4.18.0-80, Glibc: 2.28-42). The following packages have to be installed: libaio-0.3.110 libgcc_s1-8.2.1 libstdc++6-8.2.1 ncurses-utils-6.1-7 pam-1.3.1-4 elfutils-libelf-0.174-6 When i try to install libgcc…
Problem with EXTERNAL TABLE
Informix 14.10.FC7W1, RHEL 8.5 (I think) I have a table invoice_tbl, and I want to unload some of the data from that table to an external table. The table has six rows that meet the selection criteria, but the resulting file contains only one row. I have the following SQL: SELEC…
Potentially Serious HDR Bug 14.10.FC7W1
All: I wanted to make you aware of something we've hit a couple of times and also find out if someone else has encountered it. Twice in the past few months, I've had DR Ping faliures on our HDR primary which seem to have left the cluster in an unstable state. It's as if the prima…
Next Informix Tech Talk: Updated Informix SQL Performance Tuning Tips for Informix Developers by Jeff Filippi
Next Informix Tech Talk: Updated Informix SQL Performance Tuning Tips for Informix Developers by Jeff Filippi Thursday, June 16, 2022 at Time: 2:00 PM EDT Learn how to improve your Informix SQL statements to optimize performance on your Informix Database system. Info at - https:/…
restoring informix using the onbar command. problem
hello, i had both informix and tsm spaces on the same physical disk. this disk is broken. Using the files devices.cfg, volhistory, dsm.opt. I was able to restore TSM using the DB restore command. Next, I need to restore the informix spaces that were backed up once a week with onb…
create function uisng foreach cursor from multiple table to return multiple row
Hi, i try to create SPL routine using foreach cursor from multiple table but it did not follow the parameter given during the execution. Anyone know how to fix this? CREATE FUNCTION neo_trend1(ParaId INT, startdate DATETIME YEAR TO FRACTION(5), enddate DATETIME YEAR TO FRACTION(5…
How to create function using foreach cursor from multiple table to return multiple row
Hi, anyone know how can i fix this? CREATE FUNCTION neo_trend1(ParaId INT, startdate DATETIME YEAR TO FRACTION(5), enddate DATETIME YEAR TO FRACTION(5), Code NVARCHAR(10)) RETURNING INT AS ParaId, DATETIME YEAR TO FRACTION(5) AS date, DECIMAL AS value, NVARCHAR(10) AS Code; DEFIN…
4GE 7.50 to 7.51.FC2
Does anyone know if you can upgrade the Informix 4GE to 7.50.FC6 to 7.51.FC2 just by installing the binaries there? I know HCL said we had to recompile to go to 7.51.FC3 because it was build with 4.50 CSDK, but 7.51.FC2 was built with 4.10 CSDK. -- Thanks, Kate Tomchik She/Her…
xC8 download
Hi, I see that 14.10.xC8 is available for download only on fixcentral (not on PA). But, I can't find any licence installation file there. Any hints? TY Regards Hrvoje ------------------------------ Hrvoje Zokovic ------------------------------ #Informix…
JDBC & TLS/SSL
Pardon the n00b-ish question, but I'm [thankfully] mostly Java and JDBC illiterate. Traditionally, we've connected to JDBC data sources by using something like the following: jdbc:informix-sqli://myhost.mydomain.com:9288/mydb:INFORMIXSERVER=my_ifxsvr This works for 'onsoctcp' ser…
archecker error with PSM
Hi, Level 0 and log backups are being made using psm on an AIX system for testing. I tried to recover the table with archecker using psm's backup, but I get an error as below. command) archecker -bdvs -f schemafile onbar backups or restores are performing fine. I also tried slibc…
Buffer wait occurs when performing INSERT in multiple sessions
Hello All, In my customer's system, a buffer wait often occurs when an INSERT statement is performed on the same table in multiple sessions. In that case, there are about 1000 sessions with the first flag value of B in the onstat -u command. And the online log file shows the mess…
How to detect if table has old-fashioned attached indexes (index pages in non-fragmented table partition)
Hello, does any one knows, if there is a way how to detect tables with attached indexes (in old meaning – index pages are together with data pages in one partition). Curently system catalogs have such indexes, but we can configure such indexes for user tables via DEFAULT_ATTACH e…
Memory issue on Informix primary server
Dear All, We have upgrade our Informix server from 11.7 to Version 14.10.FC6X3 on Sun OS 5.11. After that We are facing multiple memory segment issue on Primary server, but everything is normal on Secondary server. Before Upgrade there was only on Virtual memory segment. I have …
Replay available - Informix TechTalk
Folks, Replay available - Informix TechTalk: All about Informix data export and Import tools by Art S. Kagel on YouTube at https://youtu.be/6wF3eNwSU9w Informix TechTalk: All about Informix data export and Import tools by Art S. Kagel Informix TechTalk: All about Informix data ex…
Only on temp dbspace is used
Hello Team on 12.1 server , i have many temp dbspaces , but got an error when one of them is full !! is there a way to fix it ? without increasing their sizes ? i also set PSORT_DBTEMP variable but nothing changed ! thanks in advance for your help ------------------------------ J…
Bug fix to myschema!
I uploaded an update to utils2_ak that includes a fix for a serious bug affecting partitioned indexes using BY EXPRESSION schemes. Myschema was only displaying the first partition. Somehow, even though it is an error and not permitted, one client was able to create an index with …
Informix TechTalk: All about Informix data export and Import tools by Art S. Kagel
Folks, Our next Informix TechTalk is: Informix TechTalk: All about Informix data export and Import tools by Art S. Kagel Date: Thursday, February 10, 2022, 2:00 pm EST Description: Art will share his latest testing on Informix data export and Import tools, loading and unloading d…
Connection Manager + TLS: A Major Annoyance
Periodically, we'll have clients attempt to connect to our connection manager, but be rejected (or disconnect themselves abruptly). Those rejections will come with error messages like these: ``` 18:34:26 listener accept new fd failed:network error = -28014 cannot accept/error:140…
Update to utils2_ak
I posted an updated utils2_ak to my web site. It contains a critical fix to dostats_ng.ec and a couple of new features in dostats_ng.ec and in myschema. www.askdbmgt.com/my-utilities ------------------------------ Art S. Kagel, President and Principal Consultant ASK Database Mana…
JDBC driver download
I have seen this sentence in the JDBC documentation previously, and it is still in the latest (14.10) documentation: https://www.ibm.com/support/knowledgecenter/en/SSGU8G_14.1.0/com.ibm.jdbc.doc/ids_jdbc_021.htm "You can obtain the IBM Informix® JDBC Driver from the IBM Informix …
Block during checkpoint
Hi I need some input advise what could be wrong on my configuration. The users reported slow / hang performance during their processes. Is it normal during checkpoint there are blocked? By refer to online log , i got some weird situation which i never encounter at other places. …
Who is BeMyApp? Targeting members of IBM forums?
Hi Y'all. I just got an email from no-reply@bemyapp-mail.com , informing me about a new question posted. The lead text reads: [IBM USER GROUP DAYS] NEW QUESTION NOTIFICATION With a button inviting me to [SEE THE QUESTION]. I foolishly failed to notice the unfamiliar "from" line…
Informix NUMA shared memory access
Are there anyone running Informix on VMWare, and also on HP SuperDome Flex? Or any NUMA architecture at all? I'm interested in shared memory access patterns across the NUMA nodes. We are running an instance with approximately 400GB of shared memory on an HP SuperDome Flex, Intel …